.titleBar { margin-bottom: 5px!important; }

Verbindung mit SIP wird nicht unterbrochen!

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von sampo33, 23 März 2005.

  1. sampo33

    sampo33 Neuer User

    Registriert seit:
    23 März 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    ich habe ebenfalls gestern Asterisk installiert und habe meinen Server hinter einem NAT-Router Sinus1054 stehen. Bei mir erscheint das Phenomen, dass ich von extern (ISDN) und von Sipgate(intern, wie übers Festnetz) mit X-lite auf einem Windows-Rechner mit XP erreichbar bin, jedoch wenn ich jemanden anrufe keinen Sound habe und das Gespräch nicht mehr beendet wird.

    Ich erhalte folgende Fehlermeldung:

    Mar 23 15:42:31 WARNING[2186]: chan_sip.c:694 retrans_pkt: Maximum retries exceeded on call 840D27B9-ADAF-4E7B-A9A7-A0CF25113710@192.168.2.100 for seqno 56705 (Critical Response)

    Wenn ich den Vorgang ein paar mal wiederhole, werde ich auch aus meiner SSH-Session geworfen.

    Wer hat diese Erfahrung schon mal gemacht und weiß eine Lösung?
     
  2. traxanos

    traxanos Mitglied

    Registriert seit:
    15 Juli 2004
    Beiträge:
    486
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Problem ist das du eine dynamische IP hast. In der sip.conf muss im hauptcontext externip=0.0.0.0 eingetragen werden. Wenn du aber kein statische hast musst du das über einen DynDNS abieter lösen. www.dyndns.org bietet so einen Service kostenlos an. Du bekommst dann eine Hostname un den Trägst du dann externip=dein.dyndns.org ein.
    srvlookup=yes muss ebenfalls gesetzt sein und dein Router muss bei der Einwahl den DynDNS Anbieter updaten. Ander wirds leider nicht klappen.
     
  3. sampo33

    sampo33 Neuer User

    Registriert seit:
    23 März 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi Traxanos,

    danke für den Tipp. Das hatte ich jedoch bereits gemacht. Ich habe folgende Einstellungen vorgenomme:


    [general]
    port = 5060
    bindaddr = 192.168.2.102
    externip = webindustry.dyndns.de
    ;Localnet = 192.168.0.0/255.255.0.0
    context = default
    tos = reliability
    srvlookup = yes
    insecure = very
    nat = yes
    maxexpirey = 1200
    defaultexpirey = 20
    register => 7775992:passwd@sipgate.de/7775992
    disallow = all
    allow = ulaw
    canreinvite = yes
    insecure = very
    qualify = yes
    language = de

    Angerufen werden geht ohne Probleme. Nur wie gesagt rausrufen geht nur ohne Ton. Vielleicht habe ich noch eine Einstellung in x-lite vergessen.Gibt es hierzu noch etwas zu beachten?

    Gruß vom Ammersee

    Frank
     
  4. rabaucke

    rabaucke Neuer User

    Registriert seit:
    23 Sep. 2004
    Beiträge:
    199
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Mein Asterisk arbeitet über die Modem Funktion der FritzBox mit einem eigene Internetzugang, also kein Router mehr dazwischen. Vor einigen Tagen tauchten bei den angemeldeten Clients, allesamt FBF, Probleme nach einiger Zeit auf. DNS-Fehler bei den FBF Boxen. Es war den FBF Boxen nicht mehr möglich zu connecten. Nachdem ich dann auf no-ip.com umgestiegen bin rennt die Kiste schon seit mehreren Tagen ohne Probleme auch nicht bei den FBF Clients.

    Kann es sein das dyndns.org Probleme mit dem DNS hat?
     
  5. traxanos

    traxanos Mitglied

    Registriert seit:
    15 Juli 2004
    Beiträge:
    486
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    war zu fälligerweise ein 24h discconnect dazwischen oder ist das immer?
     
  6. traxanos

    traxanos Mitglied

    Registriert seit:
    15 Juli 2004
    Beiträge:
    486
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    [sorry] hab den falschen TAB erwischt ;)