.titleBar { margin-bottom: 5px!important; }

Vigor 2600Vi, Codec-Problem

Dieses Thema im Forum "DrayTek (VoIP)" wurde erstellt von bongartz, 8 Apr. 2005.

  1. bongartz

    bongartz Mitglied

    Registriert seit:
    7 Mai 2004
    Beiträge:
    214
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Hi Forum,

    kurz mein Szenario:

    Vigor 2600Vi
    Sipura SPA-3000

    am (eigenen) Asterisk-Server,
    Asterisk (u.a.) angemeldet an Sipgate.

    Lasse ich alle Codecs zu, wird generell g711 verwendet, alles funktioniert prima.

    Nun möchte ich - da zwischen den Telefonen und dem Asterisk DSL 1024/128 liegt - den Vigor gerne mit g726 am Asterisk betreiben.

    Da man dem Vigor leider nicht sagen kann, genau einen bestimmten Codec zu verwenden, hänge ich den Port des Asterisk fest auf g726 (Details zum Asterisk erspare ich mir hier).

    Rauswählen funktioniert perfekt - der Vigor benutzt g726 (weil der Asterisk nichts anderes erlaubt), von dort geht die Verbindung mit g711 zu Sipgate.

    Kommt aber ein Anruf rein (mit g711 vom Asterisk zu Sipgate) und wird mit g726 beim Vigor signalisiert, erscheint im Log "Got SIP resonse 415 "Unsupported Media Type" back from <IP-Addr des Vigor>".

    Er mag also den g726 ausgehend, aber nicht ankommend.

    Um zu verifizieren ob es genau daran liegt habe ich den selben Test mit meinem Sipura gemacht (der sich - nebenbei erwähnt, auch prima auf einen Codec "festhängen" lässt - was ich in diesem Fall nicht getan habe).

    Klappt einwandfrei.

    Fehlkonfigurationen seitens Asterisk kann ich damit definitiv ausschliessen.

    Vielleicht gibt es von euch ja schon Erfahrungen/Meinungen dazu - ich werde wohl ein Ticket bei Draytek dafür aufmachen, der Fall erscheint mir mittlerweile relativ eindeutig. Überhaupt ist das Handling der Codecs wohl nicht so toll implementiert...

    Ansonsten habe ich den 2600Vi wirklich lieb. QoS funktioniert absolut perfekt. Das DSL läuft stabil, und Stromverbauch und Erwärmung sind angenehm gering.

    Gruss,
    Micha
     
  2. DSL-Hexe

    DSL-Hexe Guest

    Die Codec Einstellung ist eigentlich automatisch am Draytek Router und man kann ihm bis jetzt nur ein Empfehlung geben welchen Codec er benutzen soll und steht bei einem VoIp Gespräch ein besserer Codec als der gewählte zu Verfügung dann nimmt der Draytek den besseren.
     
  3. bongartz

    bongartz Mitglied

    Registriert seit:
    7 Mai 2004
    Beiträge:
    214
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Danke für die schnelle Antwort. Ja - das ist sehr unschön, aber soweit klar.

    Allerdings kann es nicht sein, dass er einen eingehenden g726-only call nicht annehmen möchte. Das ist - kurz zusammengefasst - das eigentliche, aber wirklich schwerwiegende, Problem.

    Gruss,
    Micha
     
  4. DSL-Hexe

    DSL-Hexe Guest

    Kann noch ein Bug in der Firmware sein. Diesen Bug ruhig melden, aber bitte nicht in Deutschland sondern gleich in Taiwan, dann wird er besser behandelt als in Deutschland und ist gleich an der richtigen Stelle. Aber bitte in Englisch schreiben.
     
  5. bongartz

    bongartz Mitglied

    Registriert seit:
    7 Mai 2004
    Beiträge:
    214
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ist wohl als Bug "anerkannt", in der Form daß es unterschiedliche g726 gibt (wobei der Call ja durchaus ausgehend funktioniert, nur eingehend nicht).

    Mit diesem Hinweis habe ich mal eine g729-Lizenz für den Asterisk erworben und auf g729 umgestellt -> damit klappt es einwandfrei.

    Gruß,
    Micha