[vISDN] Starke Latenzen nach dem ersten Anruf

guardian_de

Neuer User
Mitglied seit
26 Okt 2005
Beiträge
21
Punkte für Reaktionen
0
Punkte
0
Hallo,

ich wäre sehr zufrieden mit vISDN, wenn da nicht der Umstand wäre, dass das Subsystem nachdem ersten Anruf nicht mehr zu gebrauchen ist.

Ich habe einen internen S0-Bus mit einer HFC-S-Karte und vISDN (also im NT-Modus) realisiert. Diese Konstellation hat zuletzt mit Fedora Core 4 und * 1.0.10 mit Bristuff prinzipiell gut funktioniert.

Im Zuge eines Systemwechsels auf Ubuntu habe ich gleichzeitig auf * 1.2.5 und vISDN gewechselt. Leider ist es so, dass nach dem ersten vISDN-Anruf folgende vISDN-Anrufe eine Verzögerung von ca. 1 Sekunde haben. D.h. wenn ich zum Beispiel die lokale Echo-Applikation von einem internen ISDN-Telefon aus anrufe und "21" sage, höre ich das Echo erst, nachdem ich das Wort zu Ende gesagt habe. Wenn ich Asterisk beende, die vISDN-Module entlade und neu lade und Asterisk wieder starte, ist der erste Anruf wieder einwandfrei.

Kennt jemand das gleiche Problem? Gibt es Abhilfe?

Meine Konfiguration: Ubuntu Dapper Drake, AVM FritzCard PCI 2.0 nach extern, HFC-S PCI nach intern. Ich benutze aktuelle vISDN-Snapshots seit ca. 20. Februar.

/etc/visdn/device-pci-0000:00:08.0

Code:
<netdev visdn0>
  protocol lapd
  role NT
  mode P2MP
</netdev>

<port st0>
  attribute role NT

  <chan D>
    connectmodule netdev visdn0
  </chan>

  <chan E>
    connectmodule netdev visdn0 echo
  </chan>
</port>
/etc/asterisk/visdn.conf

Code:
[general]

[global]
network_role = private
tones_option = yes
outbound_called_ton = unknown
force_outbound_cli =
force_outbound_cli_ton = no
clir_mode = default_off
cli_rewriting = No
national_prefix = 0
international_prefix = 00
network_specific_prefix =
subscriber_prefix =
abbreviated_prefix =
overlap_sending = No
overlap_receiving = No
autorelease_dlc = 10
call_bumping = No
echocancel = No
echocancel_taps = 256

[visdn0]
network_role = private
context = visdn-trunk
tones_option = yes
outbound_called_ton = unknown
force_outbound_cli =
force_outbound_cli_ton = no
clip_default_number = 123456
clip_numbers = 123456
clir_mode = default_off
overlap_sending = No
overlap_receiving = No
 

htims

Neuer User
Mitglied seit
22 Apr 2005
Beiträge
70
Punkte für Reaktionen
0
Punkte
0
solch ein problem wird auch gerade auf der mailingliste diskutiert. bisher soweit ich weiß ohne ergebnis.
 

guardian_de

Neuer User
Mitglied seit
26 Okt 2005
Beiträge
21
Punkte für Reaktionen
0
Punkte
0
Das habe ich auch verfolgt. Ich hatte lediglich den Eindruck, dass dieses Problem mit einem anderen Problem vermischt wurde: Das Wiederholen der letzten Sekunde des vorherigen Gesprächs. Abgesehen davon scheinen es in der Regel deutsche Benutzer zu sein, die dieses Problem haben.

Wenn Daniele von der Cebit zurück ist, werde ich versuchen, das Problem in der Mailingliste erneut zu thematisieren.

Was mich allerdings wundert: Gibt es hier niemanden, der das gleiche Problem feststellt? Oder anders gefragt: Gibt es Leute, die vISDN ohne dieses Problem einsetzen?
 

htims

Neuer User
Mitglied seit
22 Apr 2005
Beiträge
70
Punkte für Reaktionen
0
Punkte
0
ich hab mit visdn noch nicht viel telefoniert, weil ich nen heftiges echo habe und mit dem snapshot von gestern garnicht angerufen werden kann. ;-)
 

guardian_de

Neuer User
Mitglied seit
26 Okt 2005
Beiträge
21
Punkte für Reaktionen
0
Punkte
0
Vielleicht ist das, was ich eingangs beschrieben habe, genau Dein heftiges Echo. Richte doch mal bitte eine Echo-Extension bei Dir lokal ein und rufe von vISDN dort an. Mindestens zweimal ;) Und dann berichte mal, wie prompt Du Dein eigenes Echo hörst.
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
234,367
Beiträge
2,045,548
Mitglieder
354,020
Neuestes Mitglied
danies