.titleBar { margin-bottom: 5px!important; }

Voicemail als eMail senden

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von pbx-stefan, 31 Jan. 2006.

  1. pbx-stefan

    pbx-stefan Neuer User

    Registriert seit:
    26 Jan. 2006
    Beiträge:
    128
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,

    ich denke mal, das es nur am Rande hier her gehört... durchschaue aber irgendwie den Zusammenhang nicht.

    Ich nutze voicemail und die Ansagen kann ich mir mittels vocemailmain() anhören.

    Die email adresse im Eintrag soll eigentlich dafür sorgen, dass der WAV an diese gesendet wird.
    Nach Einrichten des MTA (Suse 9.3) auf dem * Server, dendet dieser auch brav eine Mail... naja, er versucht es zumindest.

    Am in MTA als Ziel eingetragenen Server versucht sich das * system mit dem Usernamen 'root@suse1.test' anzumelden. Vorgegeben hatte ich allerdings einen anderen Usernemen....

    Wo kann ich denn den Absende User beeinflussen?
    Wie ist der genaue Ablauf?
    Record,
    Hangup,
    irgendetwas erzeugt eine Mail,
    stellt sie dem lokalen MTA zu,
    dieser stellt sie dem Mailserver beim Provider zu....

    Hmmm :confused: :confused: :confused: :confused:

    Kann mich jemand auf Spur bringen?

    was meint die Zeile:
    ; You can override the default program to send e-mail if you wish, too
    genau? Hat * einen eigenen SMTP client? Und wo konfiguriere ich den?


    Danke Euch.

    Gruss Stefan
     
  2. betateilchen

    betateilchen Grandstream-Guru

    Registriert seit:
    30 Juni 2004
    Beiträge:
    12,882
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    am Letzenberg
    Die Konfigruation erfolgt in der voicemail.conf - schau Dir mal die Beispiel-Datei an, die Du in den Quelltexten von Asterisk findest.

    Dort wird z.B. auch die Absenderkennung konfiguriert. Sofern auf dem Linux Server ein sendmail vorhanden ist, kann Asterisk ohne Dein weiteres Zutun darüber emails versenden.
     
  3. pbx-stefan

    pbx-stefan Neuer User

    Registriert seit:
    26 Jan. 2006
    Beiträge:
    128
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich danke Dir.
    wenn Du die voicemail.conf.sample mainst, dann habe ich genau diese übernommen und modifiziert.
    serveremail = meinname@irgendwo.de

    Ist sendmail default oder muss ich diese als mailcmd aktivieren? Habe mal mit und mal ohne versucht...

    Danke
    Stefan
     
  4. betateilchen

    betateilchen Grandstream-Guru

    Registriert seit:
    30 Juni 2004
    Beiträge:
    12,882
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    am Letzenberg
    sendmail ist default - da mußt Du nix extra konfigurieren. (Außer sendmail auf Deinem Server natürlich einrichten)
     
  5. betateilchen

    betateilchen Grandstream-Guru

    Registriert seit:
    30 Juni 2004
    Beiträge:
    12,882
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    am Letzenberg
    Ich habe hier mal den Abschnitt aus meiner voicemail.conf:

    Code:
    [general]
    format=wav
    fromstring=ASTERISK
    serveremail=asterisk@pbx.gs-info.net
    attach=yes
    
    Dann habe ich das eben mal getestet und eine Nachricht aufgenommen. Nachdem die bei mir angekommen ist, sieht das dann so aus wie auf dem angehängten Bild. Es stehen also exakt die Daten drin, die in der voicemail.conf angegeben sind - sogar die Groß- Kleinschreibung wurde exakt übernommen.

    Vermutlich liegt also ein Problem in der Konfiguration Deines email-Programmes vor - von Asterisk Seite funktioniert es genau so wie es soll.
     

    Anhänge:

    • mail.jpg
      mail.jpg
      Dateigröße:
      10.3 KB
      Aufrufe:
      75
  6. pbx-stefan

    pbx-stefan Neuer User

    Registriert seit:
    26 Jan. 2006
    Beiträge:
    128
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Moin,

    jo. nun geht es.
    Es war ein ganz dummer Fehler, und wie ich im ersten Posting annahm eigentlich auch kein * related Fehler.

    Meine Box nutzt postfix. in der sasl_passwd Datei war der Hostname meines Ziel Mailservers falsch geschrieben. Da durch gab es für den anzusprechenden Host eigentlich keinen Usernamen in der sasl_passwd und der default scheint auf root@rechnersdomian zu stehen.

    Gefixed, postfix durchgestartet, *relaod und nun geht es.

    Ich danke Euch, dass Ihr darauf bestanden habt, dass meine * Konfig OK war. Deshalb konnte ich mich auf die Grundkonfig meiner Box konzentrieren :rolleyes:

    Schönen Tag
    Stefan