.titleBar { margin-bottom: 5px!important; }

Voicemail bringt "*" zum Absturz

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von CLauinger, 21 Apr. 2005.

  1. CLauinger

    CLauinger Neuer User

    Registriert seit:
    27 Jan. 2005
    Beiträge:
    94
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Ettlingen
    Hallo,

    nachdem die Voicemail angesprungen ist, und die Nachricht aufgezeichnet hat, funktioniert mein "*" nicht mehr. Einzig und allein ein restart über init-script belebt das Teil.
    Die Nachricht wurde aber korrekt aufgezeichnet und wird per Mail verschickt und kann übers Telefon abgehört werden.

    Code:
    ;eigenen Anrufbeantworter testen
    exten => 83,1,Wait(1)
    exten => 83,2,Playback(voicebox-${CALLERID})
    exten => 83,3,SetLanguage(de)
    exten => 83,4,Voicemail(${CALLERID})
    exten => 83,5,Hangup
    
    Im Log steht nix dazu :(
    Warum nimmt der eigentlich 3 Formate auf ?

    Gruss

    Christian
     
  2. pygmalion

    pygmalion Neuer User

    Registriert seit:
    12 Nov. 2004
    Beiträge:
    56
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Nur so ne Vermutung: Hast du evtl. nen ältlichen PC, und es müssen Formate konvertiert werden (cpu-intensiv) ? Hatte zumindest bei mir immer diesen Effekt, das der Prozess jedesmal abgeschmiert ist.
     
  3. CLauinger

    CLauinger Neuer User

    Registriert seit:
    27 Jan. 2005
    Beiträge:
    94
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Ettlingen
    Und was kann ich tun ?
    Ist ein Athlon XP 1600, läuft allerdings so allerhand drauf ;)
    Apache mysql, Mailserver, Asterisk, LDAP, Samba ...
     
  4. rollo

    rollo IPPF-Promi

    Registriert seit:
    5 Juli 2004
    Beiträge:
    8,281
    Zustimmungen:
    1
    Punkte für Erfolge:
    38
    Ort:
    JO30SK
    Dich erstmal für ein Aufzeichnungsformat entscheiden, dann gibt es schonmal zwei Fehlerquellen weniger. Guck Dir mal die voicemail.cfg an.

    jo
     
  5. CLauinger

    CLauinger Neuer User

    Registriert seit:
    27 Jan. 2005
    Beiträge:
    94
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Ettlingen
    jo, dann nehm ich mal nur noch wav ;) thx
    ich poste morgen meine ergebnisse.

    cu & n8
     
  6. CLauinger

    CLauinger Neuer User

    Registriert seit:
    27 Jan. 2005
    Beiträge:
    94
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Ettlingen
    hab nur noch ein format drin.
    trotzdem noch das gleiche problem. asterisk stürzt nimmer ab, der prozess läuft noch, allerdings nimmt er keine anrufe mehr entgegen :(
    das einzige was ich im log gefunden habe an (fehler)meldung ist:
    unable to open pseudochannel for timing, sound may be choppy.

    was soll mit das sagen ?
     
  7. lo4dro

    lo4dro Mitglied

    Registriert seit:
    14 Okt. 2004
    Beiträge:
    656
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Was für eine Hardware hast du?
     
  8. CLauinger

    CLauinger Neuer User

    Registriert seit:
    27 Jan. 2005
    Beiträge:
    94
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Ettlingen
    AthlonXP 1600
    512 MB RAM
    Elitegroup Board
    HFC-PCI (Asus) mISDN "*"
    FritzCard PCI mISDN "*"
    Fritzcard B1 PCI (CAPI Hylafax)

    Habe herausgefunden, das "*" immer dann hängt, nachdem er auf Platte geschrieben hat (egal ob Faxe oder Voicemail).
     
  9. CLauinger

    CLauinger Neuer User

    Registriert seit:
    27 Jan. 2005
    Beiträge:
    94
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Ettlingen
    Hylafax hab ich nun deinstalliert, mache nun alles was ISDN betrifft über "*".

    Das Problem das "*" hängt, nach dem er auf Platte geschrieben hat ist allerdings immer noch :(
     
  10. CLauinger

    CLauinger Neuer User

    Registriert seit:
    27 Jan. 2005
    Beiträge:
    94
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Ettlingen
    Hab ein bisschen weiter debuged:

    Ich rufe die Voicemail an, hinterlasse eine Nachricht und lege auf.
    bis dahin alles i.O.
    Wenn ich dann nochmal die Voicemail anrufen will wird unzählige Male die Meldung ins log geschrieben:
    Code:
    phd_conf: not matching (nil)/0x8103478
    
    Weiss jemand was das heisst bzw. wie man es wegbekommt ?

    Gruss

    Christian
     
  11. Blint

    Blint Neuer User

    Registriert seit:
    6 Apr. 2005
    Beiträge:
    36
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Mal Festplatte durchchecken, ob nicht etwa zu viele kaputte Bereiche exisitieren. Wenn Asterisk seine Daten an Stellen schreibt, die nicht lesbar sind, kann das etliche Fehler zur Folge haben.
     
  12. CLauinger

    CLauinger Neuer User

    Registriert seit:
    27 Jan. 2005
    Beiträge:
    94
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Ettlingen
    Hab ich gemacht, keine kaputten Bereiche - Filesystem ist ext3.

    Komisch ist, das ich die Voicemail-Nachrichten löschen kann über Voicemenü.
    Nur nach der Aufzeichnung einer neuen ist die "*" im Nirvana :(