.titleBar { margin-bottom: 5px!important; }

Voicemailansage und Mailtext

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von alexshh, 26 Apr. 2005.

  1. alexshh

    alexshh Neuer User

    Registriert seit:
    19 Apr. 2005
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Wie kann ich den Mailtext der mit übertragen wird ins deutche editieren :

    "...Just wanted to let you know you were just left a 0:05 long message (number 10) in mailbox hotline from, on Tuesday, April 26, 2005 at 11:23:08 AM so you might want to check it when you get a chance. Thanks!


    Warum fehlt bei der Ansage der Mailbox "der Teilnehmer mit der Rufnummer ist immoment" die Rufnummer welcher eintrag fehlt habe in der voicemail.conf schon den Eintrag saycid = yes benutze das deutsche paket von pforzheim hier sind die einzelnen rufnummern dabei
     
  2. CLauinger

    CLauinger Neuer User

    Registriert seit:
    27 Jan. 2005
    Beiträge:
    94
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Ettlingen
    in der voicemail.conf steht der drin
    Code:
    ;
    ; Voicemail Configuration
    ;
    [general]
    ; Default formats for writing Voicemail
    ;format=g723sf|wav49|wav
    ;format=wav|gsm|wav49
    format=wav
    ; Who the e-mail notification should appear to come from
    serveremail=asterisk
    ;serveremail=asterisk@linux-support.net
    ; Should the email contain the voicemail as an attachment
    attach=yes
    ; Maximum length of a voicemail message in seconds
    maxmessage=180
    ; Minimum length of a voicemail message in seconds
    minmessage=3
    ; Maximum length of greetings in seconds
    ;maxgreet=60
    ; How many miliseconds to skip forward/back when rew/ff in message playback
    skipms=3000
    ; How many seconds of silence before we end the recording
    maxsilence=10
    ; Silence threshold (what we consider silence, the lower, the more sensitive)
    silencethreshold=128
    ; Max number of failed login attempts
    maxlogins=3
    ; If you need to have an external program, i.e. /usr/bin/myapp
    ; called when a voicemail is left, delivered, or your voicemailbox
    ; is checked, uncomment this:
    ;externnotify=/usr/bin/myapp
    ; If you need to have an external program, i.e. /usr/bin/myapp
    ; called when a voicemail password is changed,
    ; uncomment this:
    ;externpass=/usr/bin/myapp
    ; For the directory, you can override the intro file if you want
    ;directoryintro=dir-intro
    ; The character set for voicemail messages can be specified here
    charset=ISO-8859-1
    ; The ADSI feature descriptor number to download to
    ;adsifdn=0000000F
    ; The ADSI security lock code
    ;adsisec=9BDBF7AC
    ; The ADSI voicemail application version number.
    ;adsiver=1
    ; Skip the "[PBX]:" string from the message title
    ;pbxskip=yes
    ; Change the From: string
    fromstring=The Asterisk PBX
    ;
    ;Change the From: string for pager messages
    ;Change the From: string for pager messages
    ;pagerfromstring=The Asterisk PBX
    ;
    ; Change the email body and/or subject, variables:
    ;     VM_NAME, VM_DUR, VM_MSGNUM, VM_MAILBOX, VM_CALLERID, VM_DATE
    ;
    ; Note: The emailbody config row can be up to 512 characters due to a limitation in
    ;       asterisk config files.
    emailsubject=[PBX]: Neue Nachricht ${VM_MSGNUM} fuer ${VM_NAME} in Mailbox ${VM_MAILBOX}
    ; The following definition is very close to the default, but the default shows just
    ; the CIDNAME, if it is not null, else just the CIDNUM, or "an unknown caller" if they are both null.
    emailbody=Hallo ${VM_NAME},\n\nwollte Dich nur wissen lassen, das eine ${VM_DUR} lange Nachricht (Nummer ${VM_MSGNUM})\nin deiner Mailbox ${VM_MAILBOX} von
    ${VM_CALLERID}, am ${VM_DATE}, hinterlassen wurde.\nDanke!\n\n\t\t\t\t--Asterisk\n
    
     
  3. alexshh

    alexshh Neuer User

    Registriert seit:
    19 Apr. 2005
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Voicemailtext

    Hi, habe in der voicemail.conf
    den emailbody=.............
    von dir eingefügt, kommt trotzdem der englische text an. Hatte vorher die voicemail.conf mit den Beispielen gelöscht muss hier noch ein Eintrag gesetzt werden das er den emailbody Eintrag auch nimmt ?


    Danke für jeden TIP.
     
  4. thepontifex

    thepontifex Neuer User

    Registriert seit:
    2 März 2005
    Beiträge:
    141
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Hi,

    also bei mir funktionierts mit dem deutschen Text:
    hier mal der entsprechende Ausschnitt aus der voicemail.conf

    Code:
    
    ;Change the From: string for pager messages
    ;pagerfromstring=The Asterisk PBX
    
    
    ;
    ; Change the email body and/or subject, variables:
    ;     VM_NAME, VM_DUR, VM_MSGNUM, VM_MAILBOX, VM_CALLERID, VM_DATE
    ;
    ; Note: The emailbody config row can be up to 512 characters due to a limitation in
    ;       asterisk config files.
    ;emailsubject=[PBX]: New message ${VM_MSGNUM} in mailbox ${VM_MAILBOX}
    ; The following definition is very close to the default, but the default shows just
    ; the CIDNAME, if it is not null, else just the CIDNUM, or "an unknown caller" if they are both null.
    ;emailbody=Dear ${VM_NAME}:\n\n\tjust wanted to let you know you were just left a ${VM_DUR} long message (number ${VM_MSGNUM})\nin mailbox ${VM_MAILBOX} fro
    m ${VM_CALLERID}, on ${VM_DATE}, so you might\nwant to check it when you get a chance.  Thanks!\n\n\t\t\t\t--Asterisk\n
    ;
    
    ;********************** Notification Email für neues Soundfile in der Voicemailbox ***********************************
    ;********************** Stand 17.05.2005,  auf deutsch by Frank  *****************************************
    
    emailsubject=[PBX]: Neue Nachricht ${VM_MSGNUM} fuer ${VM_NAME} in Mailbox ${VM_MAILBOX}
    emailbody=Hallo ${VM_NAME},\n\nich wollte Sie nur wissen lassen, das eine ${VM_DUR} Minuten lange Nachricht (Nummer ${VM_MSGNUM})\nin Ihrer Mailbox ${VM_MAI
    LBOX} von ${VM_CALLERID}, am ${VM_DATE}, hinterlassen wurde.\nDanke!\n\n\t--Ihre freundliche Asterisk-Telefonanlage\n
    
    ;*********************************************************************************************************************
    
    
    Du musst natürlich auch drauf achten dass der text nicht mit einen ";" auskommentiert ist (so wie die englische Beschreibung oben). ;-)

    Gruss
    Frank
     
  5. stäubel

    stäubel Neuer User

    Registriert seit:
    11 Aug. 2006
    Beiträge:
    198
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Beruf:
    Dipl. Techniker HF / Applikations-Entwickler
    Ort:
    Kt.Glarus
    Hallo zusammen

    Bei mir funktionierts zwar super, aber ein kleiner Schönheitsfehler hats noch.
    Z.b. werden unter anderem die Wochentage ( Variable ${VM_DATE} ) noch in Engisch angezeigt und ich finde den Parameter nicht wo man dies auf deutsch umschalten kann.

    Mail Ausschnitt:
    HTML:
    Die Nachricht (Länge = 0:18min) wurde am Friday, November 17, 2006 at 11:40:04 AM in deiner Mailbox gespeichert
    Kann mir jemand ein Stichwort geben?
    Wäre mega!

    Viele Grüsse Stäubel
     
  6. Knaut

    Knaut Neuer User

    Registriert seit:
    13 Mai 2007
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    wie bekommt man die ${VM_DATE} in Deutsch?
     
  7. betateilchen

    betateilchen Grandstream-Guru

    Registriert seit:
    30 Juni 2004
    Beiträge:
    12,882
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    am Letzenberg
    Sieht also danach aus, daß man die timezone im jeweilgen Mailboxeintrag entsprechend richtig setzen muß.
     
  8. Knaut

    Knaut Neuer User

    Registriert seit:
    13 Mai 2007
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #8 Knaut, 6 Juni 2007
    Zuletzt bearbeitet: 6 Juni 2007
    habe folgendes gesetzt

    PHP:
    tz=germany        Timezone from zonemessages above.  Irrelevant if envelope=no.

    [
    zonemessages]
    germany=Europe/Berlin|'vm-received' 'digits/at' kM
    geht aber nicht

    -> Asterisk 1.2.18