.titleBar { margin-bottom: 5px!important; }

VoIP eingehend funktioniert nicht

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von tcp, 27 Dez. 2005.

  1. tcp

    tcp Neuer User

    Registriert seit:
    27 Dez. 2005
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo zusammen!

    Ich bin noch recht neu in der Welt von Asterisk und wühle mich schon seit eingen Tagen hier durch's Forum (man will ja keine schon beantworteten Fragen stellen).
    Mal kurz zu meinem Vorhaben:
    Der * soll Anrufe über VoIP (hinter NAT) und ISDN (Fritzcard Classic am NTBA) annehmen und an unsere ISDN Anlage (alte Eumex 308 an HFC-S im NT mode) weiterleiten bzw Anrufe von den Eumex-Nebenstellen per VoIP oder ISDN rausschicken.
    Ich habe dabei genau zwei Probleme:

    1) Ich kann über meine Nebenstellen nicht rauswählen, da ich immer im s-Kontext lande (Lösung evtl http://ting.ip-phone-forum.de/showthread.php?t=89112 , muss ich aber erst testen)

    2) (und darum geht's mir erstmal) Ich kann zwar per VoIP raustelefonieren (getestet mit X-Lite) aber ich kann nicht vom Festnetz aus per VoIP reinwählen. Selbst wenn ich asterisk mit -vvvvc starte, scheint er den Anruf gar nich zu bemerken (Es passiert einfach gar nichts, Im Telefon höre ich auch nix). Habe deshalb mal die Portforwarding Regeln auf meinen Rechner umgebogen und mit dem T-Online Softphone getestet -> es klappt.
    Ich forwarde übrigens 5060,5070 und 30000-30005 an den * wobei die 30000-30005 auch in der rtp.conf stehen.

    Meine sip.conf:
    Code:
    [general]
    port = 5060
    bindaddr = 0.0.0.0
    localnet = 192.168.0.0/255.255.255.0
    srvlookup = yes
    externip=*noip-hostname*
    context=voip-in
    disallow=all
    allow=gsm
    allow=ulaw
    allow=alaw
    allow=speex
    allow=g726
    allow=g729
    allow=g723.1
    
    register => 032******:*mail*:*secret*@tel.t-online.de/032******
    
    [032******]
    type=friend
    username=*mail*
    secret=*secret*
    fromuser=032******
    fromdomain=tel.t-online.de
    host=tel.t-online.de
    disallow=all
    allow=alaw
    allow=ulaw
    allow=libc
    allow=g726
    allow=g729
    allow=gsm
    ;qualify=500
    qualify=no
    insecure=very
    ;dtmfmode=inband
    dtmfmode=info
    tos=0x18
    ;canreinvite=yes
    canreinvite=no
    nat=yes
    context=tonline
    
    Relevanter Abschnitt aus der extensions.conf:
    Code:
    [tonline]
    exten => _X.,1,Dial(SIP/11/${EXTEN},60)
    exten => _X.,2,Hangup
    
    Wobei hier an mein X-Lite weitergeleitet wird, weil die Eumex zur Zeit nicht am * hängt.

    So, Ich hoffe, dass die Frage wirklich so noch nicht aufgetaucht ist und freue mich auf eure Antwort(en).

    Gruß
    Tim
     
  2. tcp

    tcp Neuer User

    Registriert seit:
    27 Dez. 2005
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    So, habe jetzt nochmal alles, was ich hier in den ganzen "t-online - so klappt's" Threads gelesen habe ausprobiert - ohne Erfolg. Raustelefonieren klappt nach wie vor völlig problemlos.
    "sip show registry" sagt registered, aber es klappt trotzdem nicht.
    Wenn ich mal (ohne sip aktivität) "sip debug" eingebe, so kommt nach einigen sekunden:
    Code:
    *CLI> sip debug
    SIP Debugging enabled
    *CLI>
    <-- SIP read from 192.168.0.33:5060:
    
    
    --- (0 headers 0 lines) Nat keepalive ---
    
    <-- SIP read from 192.168.0.33:5060:
    
    
    --- (0 headers 0 lines) Nat keepalive ---
    12 headers, 0 lines
    Reliably Transmitting (no NAT) to 217.6.167.90:5060:
    OPTIONS sip:tel.t-online.de SIP/2.0
    Via: SIP/2.0/UDP 80.140.207.157:5060;branch=z9hG4bK61d5b7b7;rport
    From: "asterisk" <sip:asterisk@80.140.207.157>;tag=as035ef96f
    To: <sip:tel.t-online.de>
    Contact: <sip:asterisk@80.140.207.157>
    Call-ID: 4319dccc5d28e3f341302d794bfa0f05@80.140.207.157
    CSeq: 102 OPTIONS
    User-Agent: Asterisk PBX
    Max-Forwards: 70
    Date: Sat, 31 Dec 2005 12:50:25 GMT
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
    Content-Length: 0
    
    
    ---
    12 headers, 0 lines
    Reliably Transmitting (no NAT) to 217.6.167.90:5060:
    OPTIONS sip:tel.t-online.de SIP/2.0
    Via: SIP/2.0/UDP 80.140.207.157:5060;branch=z9hG4bK5ca07c6e;rport
    From: "asterisk" <sip:asterisk@80.140.207.157>;tag=as4452582e
    To: <sip:tel.t-online.de>
    Contact: <sip:asterisk@80.140.207.157>
    Call-ID: 4e8913907400ff49168cca1c5b3d3419@80.140.207.157
    CSeq: 102 OPTIONS
    User-Agent: Asterisk PBX
    Max-Forwards: 70
    Date: Sat, 31 Dec 2005 12:50:25 GMT
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
    Content-Length: 0
    
    
    ---
    
    <-- SIP read from 217.6.167.90:5060:
    SIP/2.0 403 Sie dürfen nur innerhalb der T-Online Domain telefonieren
    Via: SIP/2.0/UDP 80.140.207.157:5060;branch=z9hG4bK61d5b7b7;rport=5060
    From: "asterisk" <sip:asterisk@80.140.207.157>;tag=as035ef96f
    To: <sip:tel.t-online.de>;tag=47165fcb65057e64f28be770f6992452.cea6
    Call-ID: 4319dccc5d28e3f341302d794bfa0f05@80.140.207.157
    CSeq: 102 OPTIONS
    Server: Sip EXpress router (3.0.1-toi-lb19 (i386/linux))
    Content-Length: 0
    Warning: 392 217.6.167.80:5060 "Noisy feedback tells:  pid=9684 req_src_ip=217.6.167.90 req_src_port=5060 in_uri=sip:tel.t-online.de out_uri=sip:tel.t-online.de via_cnt==2"
    
    
    --- (9 headers 0 lines)---
    Destroying call '4319dccc5d28e3f341302d794bfa0f05@80.140.207.157'
    
    <-- SIP read from 217.6.167.90:5060:
    SIP/2.0 403 Sie dürfen nur innerhalb der T-Online Domain telefonieren
    Via: SIP/2.0/UDP 80.140.207.157:5060;branch=z9hG4bK5ca07c6e;rport=5060
    From: "asterisk" <sip:asterisk@80.140.207.157>;tag=as4452582e
    To: <sip:tel.t-online.de>;tag=47165fcb65057e64f28be770f6992452.cea6
    Call-ID: 4e8913907400ff49168cca1c5b3d3419@80.140.207.157
    CSeq: 102 OPTIONS
    Server: Sip EXpress router (3.0.1-toi-lb19 (i386/linux))
    Content-Length: 0
    Warning: 392 217.6.167.80:5060 "Noisy feedback tells:  pid=9681 req_src_ip=217.6.167.90 req_src_port=5060 in_uri=sip:tel.t-online.de out_uri=sip:tel.t-online.de via_cnt==2"
    
    
    --- (9 headers 0 lines)---
    Destroying call '4e8913907400ff49168cca1c5b3d3419@80.140.207.157'
    Destroying call '3edb387061b43d8d6d032e981da0639d@192.168.0.1'
    g
    SIP Debugging Disabled
    
    Erstmal wundert mich da die Zeile
    Code:
    Reliably Transmitting (no NAT) to 217.6.167.90:5060:
    Warum no NAT? In den Optionen steht doch "nat=yes" (s.oben).
    Dann frage ich mich, was der da überhaupt macht? Und warum kommt vom Server zurück, dass ich nur innerhalb der T-online Domain telefonieren darf? Wie gesagt: Ich kann ohne Probleme via SIP ins Festnetz telefonieren.
    Ich hatte auch ab und zu Serverantworten die sich über zu viele Registrierungen beklagt haben. Also irgendwas scheint da bei mir völlig falsch zu laufen. Ich werde auch das Gefühl nicht los, dass ich grad den Wald vor lauter Bäumen nicht sehe, da ich anscheinend der einzige mit diesem Problem bin.
    Ich würde mich echt über jede Antwort freuen, ob's jetzt Hilfe ist oder ein "geht mir ähnlich".
    Ich werd mir jetzt mal das Asterisk Documentation Project anschauen, vielleicht finde ich da nen Hinweis.
    Gruß
    Tim
     
  3. blauerpeti

    blauerpeti Mitglied

    Registriert seit:
    28 Juni 2005
    Beiträge:
    723
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich sehe keinen Teilnehmer 11 in der sip.conf
     
  4. tcp

    tcp Neuer User

    Registriert seit:
    27 Dez. 2005
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Sorry, mein Fehler. Dachte, um's kurz zu halten lasse ich die Einträge für meine internen Softphones weg.
    Ich poste am besten nochmal meine ganze aktuelle sip.conf, weil ich die jetzt noch nach einem Beispiel hier im Forum verändert habe.
    Code:
    [general]
    port = 5060
    bindaddr = 0.0.0.0
    localnet = 192.168.0.0/255.255.255.0
    srvlookup = yes
    externip=xxx.no-ip.org
    context=voip-in
    disallow=all
    allow=gsm
    allow=ulaw
    allow=alaw
    allow=ilbc
    allow=speex
    allow=g726
    allow=g729
    allow=g723.1
    
    register => 032***:email:password@tel.t-online.de/t-in 
    
    [sip_t-online]
    type=peer 
    context=voip-out
    username=email ; von EmailName@t-online.de
    secret=password
    fromuser=032***
    fromdomain=tel.t-online.de
    host=tel.t-online.de
    disallow = all
    ; allow = g726 ; ich will komprimieren
    ; allow = g729 ; nur wenn Lizenz, ansonsten geht MoH nicht
    allow = ulaw
    ; allow = alaw
    nat=yes
    canreinvite=yes
    ; dtmfmode=rfc2833
    dtmfmode=inband ; bei ulaw und alaw benutzen
    qualify=2000
    call-limit=2 ;ich weiß nicht wieviel Verbindungen T-Online zuläßt
    ;################################################# ####################################
    [t-online-proxy]
    type=peer
    context=voip-in
    fromdomain=tel.t-online.de
    host=tel.t-online.de
    disallow=all
    ; allow = g726 ; ich will komprimieren
    ; allow = g729 ; nur wenn Lizenz, ansonsten geht MoH nicht
    allow = ulaw
    ; allow = alaw
    nat=yes
    ; dtmfmode=rfc2833
    dtmfmode=inband ; bei ulaw und alaw benutzen
    qualify=500
    incominglimit=5
    
    
    [11]
    type=friend
    auth=md5
    language=de
    username=11
    secret=blabla
    callerid="Softphone1" <11>
    host=dynamic
    nreinvite=no
    canreinvite=no
    disallow=all
    allow=gsm
    allow=ulaw
    allow=alaw
    context=sip1
    
    [12]
    type=friend
    auth=md5
    language=de
    username=12
    secret=blabla
    callerid="Softphone2" <12>
    host=dynamic
    nreinvite=no
    canreinvite=no
    disallow=all
    allow=gsm
    allow=ulaw
    allow=alaw
    context=sip2
    
     
  5. blauerpeti

    blauerpeti Mitglied

    Registriert seit:
    28 Juni 2005
    Beiträge:
    723
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Die Nebenstelle 11 hat den context=sip1
    nur der "relevate-Aufruf" steht in der exte* im context [tonline]
     
  6. tcp

    tcp Neuer User

    Registriert seit:
    27 Dez. 2005
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Irgendwie bin ich jetzt verwirrt.
    Wenn von aussen ein SIP Gespräch per t-online reinkommt sollte dass doch im kontext t-online bzw nach der neuen config in voip-in landen, oder nicht?
    Und im Kontext sip1 landet alles was von sip1 ausgeht, oder? Das funktioniert ja auch soweit.
    sip1 in extensions.conf:
    Code:
    [sip1]
    exten => _9[1-9].,1,SetCallerID(032***)
    exten => _9[1-9].,2,Dial(SIP/sip_t-online/02851${EXTEN:1},30)
    exten => _9[1-9].,3,Hangup
    
    exten => _90.,1,SetCallerID(032***)
    exten => _90.,2,Dial(SIP/sip_t-online/${EXTEN:1},30)
    exten => _90.,3,Hangup
    
    exten => 12,1,Dial(SIP/12/${EXTEN},60)
    exten => 12,2,Hangup
    
    Das bewirkt, dass man mit ner 9 als Vorwahl vom Softphone sip1 per SIP rauswählt und mit der 12 das andere interne Softphone erreicht.
    Ich frag glaub ich mal in dem t-online thread nach einer funktionierenden Kombination aus sip.conf und extensions.conf. Irgendwo hab ich da was durcheinandergebracht, glaube ich.

    Auf jeden Fall erstmal danke, dass Du bereit bist zu helfen!

    Gruß
    Tim
     
  7. madiehl

    madiehl Mitglied

    Registriert seit:
    15 Feb. 2005
    Beiträge:
    438
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    In Deinem sip_t-online steht kein context=
    Dort würde ich einen context eintragen, ich bin nciht sicher ob der context in den Defaulteinstellungen reicht.
    Dein t-online-proxy wird wohl nie verwendet, denn Du meldest Dich ja nirgends an. Was sagt denn das CLI wenn Du versuchst Deine Telefone klingeln zu lassen?
     
  8. tcp

    tcp Neuer User

    Registriert seit:
    27 Dez. 2005
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Frohes neues Jahr erstmal!
    "context=voip-out" ist die zweite Zeile in "sip_t-online". Habe ich beim kopieren des Beispiels auch erst nicht gesehen :)
    Zu den CLI Ausgaben: Im moment klappt nichtmal die Registrierung. Vom t-online Server kommt keine Antwort zurück. Als es noch geklappt hat (gleiche Einstellungen) kam aber auch bei verbose=7 gar nix im CLI. sip debug hatte ich da aber noch nicht ausprobiert.
    Zu dem zweiten Kontext: Das ist die leicht angepasste sip.conf, die ich hier in diesem Thread gefunden habe und die nageblich funktioniert.

    Gruß
    Tim
     
  9. tcp

    tcp Neuer User

    Registriert seit:
    27 Dez. 2005
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Falls das noch jemanden interessiert: Ich kann mich jetzt auf meiner t-online Nummer anrufen. Den Fehler dürfte ich eigentlich gar nicht zugeben, so dumm ist der:
    muss heissen:
    Code:
    register => 032***:password:email@tel.t-online.de/032***
    
    wobei die Vertauschung von password und email wichtig ist. Das tut echt ganz schön weh, kann ich euch sagen :)

    Das Problem ist jetzt, dass der Anruf zwar zustande kommt, aber nix übertragen wird ausser rauschen (beide Richtungen). Aber dazu gibt's hier ja auch einige Threads.