.titleBar { margin-bottom: 5px!important; }

Voipbox Capi incoming

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von Daverichter, 1 Jan. 2006.

  1. Daverichter

    Daverichter Neuer User

    Registriert seit:
    25 Juli 2005
    Beiträge:
    106
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,

    ich wollte heute mal die Voipbox testen, soweit so gut funktioniert auch soweit alles, bis auf die kleinigkeit das ISDN (CAPI) incoming nicht funzt, ich bin mir allerdings auch nicht sicher ob meine config so passt...

    ;
    ; CAPI config
    ;
    ;

    ; general section

    [general]
    nationalprefix=0
    internationalprefix=00
    rxgain=0.8
    txgain=0.8
    ;ulaw=yes ;set this, if you live in u-law world instead of a-law

    ; interface sections ...

    [ISDN1] ;this example interface gets name 'ISDN1' and may be any
    ;name not starting with 'g' or 'contr'.
    ;ntmode=yes ;if isdn card operates in nt mode, set this to yes
    isdnmode=msn ;'MSN' (point-to-multipoint) or 'DID' (direct inward dial)
    ;when using NT-mode, 'DID' should be set in any case
    incomingmsn=* ;allow incoming calls to this list of MSNs/DIDs, * = any
    ;defaultcid=123 ;set a default caller id to that interface for dial-out,
    ;this caller id will be used when dial option 'd' is set.
    ;controller=0 ;ISDN4BSD default
    ;controller=7 ;ISDN4BSD USB default
    controller=1 ;capi controller number to use
    group=1 ;dialout group
    ;prefix=0 ;set a prefix to calling number on incoming calls
    softdtmf=on ;enable/disable software dtmf detection, recommended for AVM cards
    relaxdtmf=on ;in addition to softdtmf, you can use relaxed dtmf detection
    accountcode= ;Asterisk accountcode to use in CDRs
    context=capi-in ;context for incoming calls
    holdtype=hold ;when Asterisk puts the call on hold, ISDN HOLD will be used. If
    ;set to 'local' (default value), no hold is done and Asterisk may
    ;play MOH.
    ;immediate=yes ;DID: immediate start of pbx with extension 's' if no digits were
    ; received on incoming call (no destination number yet)
    ;MSN: start pbx on CONNECT_IND and don't wait for SETUP/SENDING-COMPLETE.
    ; info like REDIRECTINGNUMBER may be lost, but this is necessary for
    ; drivers/pbx/telco which does not send SETUP or SENDING-COMPLETE.
    ;echosquelch=1 ;_VERY_PRIMITIVE_ echo suppression
    ;echocancel=yes ;EICON DIVA SERVER (CAPI) echo cancelation
    ;(possible values: 'no', 'yes', 'force', 'g164', 'g165')
    echocancelold=yes;use facility selector 6 instead of correct 8 (necessary for older eicon drivers)
    ;echotail=64 ;echo cancel tail setting
    ;bridge=yes ;native bridging (CAPI line interconnect) if available
    ;callgroup=1 ;Asterisk call group
    devices=2 ;number of concurrent calls on this controller
    ;(2 makes sense for single BRI, 30 for PRI)


    Extensions.conf

    [capi-in]
    exten => 8592xx,1,Dial(Sip/704,60)
    exten => 8592xx,2,Hangup()


    wenn sich die config mal jemand anschauen könnte währe ich sehr dankbar.

    MFG

    Dave
     
  2. rbaer

    rbaer Mitglied

    Registriert seit:
    7 Okt. 2004
    Beiträge:
    280
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    München
    Mach da mal einen Unterstrich davor.
    exten => _8592xx,1,Dial(Sip/704,60)
    exten => _8592xx,2,Hangup()
     
  3. armincm

    armincm Aktives Mitglied

    Registriert seit:
    3 Aug. 2005
    Beiträge:
    1,006
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Und auch grosse 'X'...

    Armin
     
  4. Daverichter

    Daverichter Neuer User

    Registriert seit:
    25 Juli 2005
    Beiträge:
    106
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    HI,

    danke für die tipps...

    ich habe den fehler allerdings an anderer stelle gefunden

    das Modul chan-capi war nicht geladen.

    MFG

    Dave