VTO2000A - Dauerlicht bei 1-Klingel-Erweiterungsmodul B1

༺Leͥgeͣnͫd༻

Neuer User
Mitglied seit
23 Okt 2019
Beiträge
7
Punkte für Reaktionen
1
Punkte
1
Hallo Forum,

ich habe das Problem, dass bei meiner Kombi aus VTO2000A-C und 1-Klingeltaster-Modul (VTO2000A-B1) folgendes Phänomen auftritt:
  • Klingele ich mit dem Erweiterungsmodul, bleibt die Hintergrundbeleuchtung aller Klingelschilder dauerhaft an (auch nach Beendingung des Gesprächs).
  • Klingele ich mit dem Hauptmodul, dann geht die Hintergrundbeleuchtung der Klingelschilder wieder aus (sogar noch vor Beendigung des Gesprächs).
Ich habe Google und die Forumssuche bemüht, konnte aber keine Lösung finden.

Hat irgendjemand eine Idee woran das liegen könnte? Oder das gleiche Problem? Ich bin inzwischen etwas ratlos.

Mein Setup besteht aus 2 x VTO2000A-C mit je 1-Klingeltaster-Modul (VTO2000A-B1) - für Haustür und Tor. Dazu 3 x VTH1510CH als Innenstationen (9901, 9902 und eine als Slave 9902-1). Alles funktioniert soweit bestens, aber das Dauerleuchten der Klingelschildbeleuchtung treibt mich fast in den Wahnsinn. :)

Als Firmware verwende ich momentan die V3.2 in der letzten Versionen wie sie TOYCU zur Verfügung stellt. Bei den Außenstationen die "T" Version für die Verwendung des DEE1010B Relaismoduls. Ich habe auch schon andere Firmwareversionen in den Außenstationen probiert, aber das Problem mit der Dauerbeleuchtung bei Betätigung des Klingeltasters im Erweiterungsmodul bleibt bei allen Firmwareversionen bestehen.

Irgendjemand eine Idee?

Viele Grüße,
Micha
 

riogrande75

Mitglied
Mitglied seit
30 Okt 2017
Beiträge
556
Punkte für Reaktionen
59
Punkte
28
Welche MCU Versionen hast du denn installiert?
Offenbar spielt der verbaute Microcontroller (MCU) doch eine gewisse Rolle bei der Kommunikation mit "low-level"-Hardware wie z.b. den Helligkeitssensor.
 

༺Leͥgeͣnͫd༻

Neuer User
Mitglied seit
23 Okt 2019
Beiträge
7
Punkte für Reaktionen
1
Punkte
1
Hallo riogrande75,

ich habe zwar verschiedene Firmwares ausprobiert, aber noch nie das MCU verändert. Wie bekomme ich denn raus welche Version installiert ist? Weder in der WebUI noch im Config-Tool konnte ich einen entsprechenden Versionshinweis sehen.

Ein weiteres merkwürdiges Verhalten (welches ggf. mit obigem Phänomen zusammenhängt - oder auch nicht): Beide Außenstationen sind auf einen Helligkeitsschwellwert von 60 (0-255) eingestellt, um die Klingelschildbeleuchtung zu aktivieren. Wenn es dunkel wird, dann sollte das Licht irgendwann an gehen und an bleiben. Stattdessen blinkt es - es geht an, dann aus, dann an, dann aus, ...

Ok, könnte sein, dass das Licht nach dem Anschalten so hell ist, dass die Helligkeit wieder überhalb des Schwellwertes liegt. Also den oberen Teil mit der Kamera abgedeckt - es sollte für die VTO nun absolut dunkel sein (egal ob ihr Licht gerade an oder aus ist). Aber es blinkt immer noch vor sich hin.

So gut der Rest auch funktioniert - die Klingelschildbeleuchtung gibt mir Rätsel auf.

Viele Grüße,
Micha
 

riogrande75

Mitglied
Mitglied seit
30 Okt 2017
Beiträge
556
Punkte für Reaktionen
59
Punkte
28

༺Leͥgeͣnͫd༻

Neuer User
Mitglied seit
23 Okt 2019
Beiträge
7
Punkte für Reaktionen
1
Punkte
1
Die MCU sehe ich bei mir nicht:
Screenshot.png

Ich habe auch mal nach einer MCU-Version für mein 1-Button-Modul gesucht und folgendes gefunden:

General_VTO2000A-Slave_MCU_V3.000.0000.0.R.20180316.hex - für VTO2000A-B1, VTO2000A-B3, VTO2000A-B5 (MCU Firmware Version 2.5.01.02.11739) - Quelle dieser Post.

Die hex-Datei habe ich nun. Wie verwende ich diese nun zum Updaten meines Slave VTO2000A-B1? Ich gehe mal davon aus, dass man sie nicht einfach via Config-Tool oder VDPConfig auf das Gerät spielen kann. Im verlinkten Post wird am Ende von einem "ST-LINK/V2 in-circuit Programmer" gesprochen. Das klingt nicht gut.

--

Update: Ich habe jetzt eine neuere MCU im bin-Format gefunden, die @riogrande75 freundlicherweise in diesem Post verlinkt hatte. Diese mit dem VDPConfig aus der Dahua Toolbox auf die VTO gespielt (bei der Frage ob "Main Program" oder "MCU" aktualisiert werden soll - "MCU" ausgewählt). Das Update lief durch.

Verhalten nun: Nach dem Klingeln mit dem 1-Klingeltaster-Modul geht die Klingelschildbeleuchtung wieder an und bleibt an. Sie bleibt nun auch an, wenn ich mit der VTO klingele. Die Klingelschildbeleuchtung geht nun gar nicht mehr aus. Nicht ganz das erwünschte Ziel.

Hat jemand eine Kombination aus VTO Firmware und MCU am laufen, bei der sich das 1-Klingeltaster-Modul (VTO2000A-B1) wie gewünscht verhält? (VTO Firmware mit abstellbaren Sprachansagen und läuft mit VTH1510CH in deutscher Menüführung? SIP oder nicht SIP ist mir nicht wichtig - Hauptsache die Basics laufen.)
 
Zuletzt bearbeitet:

riogrande75

Mitglied
Mitglied seit
30 Okt 2017
Beiträge
556
Punkte für Reaktionen
59
Punkte
28
Hab ich mich auch schon gefragt, wie man das .hex file in diese Dinger einspielen kann, k.A.
Was anderes als mit einem STM-Programmer ist mir als Elektroniker nicht eingefallen - auch wenn das nur was für Profis ist.

Da die MCU Firmware nun deutlich aktueller ist, als die FW auf der VTO, würde ich mal ein wenig mit aktuellen VTO-Firmwaren testen.
Kommt halt nun drauf an, was du genau haben willst (non-SIP, SIP, Sprachfiles auf deutsch/englisch/deaktiviert)...
 

༺Leͥgeͣnͫd༻

Neuer User
Mitglied seit
23 Okt 2019
Beiträge
7
Punkte für Reaktionen
1
Punkte
1
In der VTO sollten die Sprachfiles auf jeden Fall abstellbar sein. Momentan verwende ich die V3.2 wie sie TOYCU zur Verfügung stellt – hier sind die Sprachfiles in Deutsch und per WebUI abstellbar. Da ich die Sprachfiles aber sowie abstellen möchte, darf die Sprache in der VTO auch gerne Englisch sein.

Die letzte unsignierte Firmware, die man noch selbst modifizieren kann und von der man auch ohne TFTP-Methode wieder downgraden kann ist glaube ich die V3.12 (richtig?). Wenn ich hier einen Link zur letzten Deutschen oder Englischen Version hätte, würde ich die gerne mal schnell testen.

Wenn man dann mit der VTO zur V4 geht, bin ich mir nicht ganz so sicher ob das noch gut mit den VTHs in der alten Version 3.2 funktioniert. Für die drei VTH1510CH brauche ich nämlich zwingend eine Version mit deutscher Menüführung (bin leider nicht alleine im Haushalt).

Falls die Kommunikation von V4 VTO mit V3.2 VTHs kein Problem ist, dann würde ich auch hier ggf. mal die neuste Version in Englisch testen bei der man die Sprachfiles per WebUI abstellen kann. Downgrade auf V3.2 sollte dann per TFPT-Methode ja immernoch möglich sein (richtig?).

Und was SIP betrifft: Falls in den SIP-Firmwares für die VTO SIP nur ein Zusatzfeature ist und die VTO auch mit V3.2 Non-SIP VTHs auf herkömmliche Art zusammenarbeiten kann, dann würde ich natürlich die SIP-Firmware für die VTO bevorzugen. Ich habe hier noch eine Fritzbox mit Fritzphone und ein Intel NUC mit Ubuntu im 24h-Betrieb der ein paar Docker-Container am Laufen hat. Da könnte ich noch einen Asterisk mit drauf packen. Mir wäre hier aber wichtig, dass die VTHs auch noch herkömmlich funktionieren, falls ich den Server mal runterfahre.

Falls Du Pointers zu passenden Firmware-Versionen hast, die ich mal probieren könnte – ich wäre ein dankbarer Empfänger. :)
 

riogrande75

Mitglied
Mitglied seit
30 Okt 2017
Beiträge
556
Punkte für Reaktionen
59
Punkte
28
Alle aktuellen Firmware Files sind im "Firmware V4" Thread. Wenn alles funktionieren soll, auch ohne Asterisk, dann musst du auf der Non-SIP Firmware bleiben.
Ob eine V4 auf der VTO mit V3.x auf den VTHs tut, kann dir vielleicht jemand anders verraten - bin ein SIP-Only Fan.
Und ja, mit der TFTP Methode kommst du immer wieder auf eine funktionierende Version zurück - hab schon alles mögliche auf meine VTO's geflasht und es auch immer geschafft, die Teile wiederzubeleben. Nur vom Bootloader sollte man "Respekt" haben.
 

༺Leͥgeͣnͫd༻

Neuer User
Mitglied seit
23 Okt 2019
Beiträge
7
Punkte für Reaktionen
1
Punkte
1
Ich habe jetzt mal den Schritt gewagt eine VTO und eine VTH auf die von @pauls1965 in diesem Post hier verlinkte Firmware zu upgraden:
  • Customer_VTOXXX_EngItlFrnGerDutSpnPrt_P_16M_V3.120.001P000.0.T.20181025
  • Customer_VTH151X_EngItlFrnGerDutSpnPrt_V4.000.100B000.0.T.20180906
Erster Eindruck nach dem Update:
  • VTH: UI im neueren V4-Design. Deutsche Sprache verfügbar. Alles scheint zu funktionieren - sowohl im Zusammenspiel mit der V3.12 VTO also auch mit der (noch nicht aktualisierten) V3.2 VTO.
  • VTO: Sprachfiles lassen sich abschalten. Deutsche Sprache verfügbar. Funktionalität wie mit vorheriger V3.2 unverändert. Ein paar kleine Optionen im Web-UI sind hier und da hinzugekommen.
Mein Hauptproblem war jedoch, dass ich mit der VTO ein 1-Klingeltaster-Modul (VTO2000A-B1) verbunden habe und dass nach Betätigung des Klingelknopfes die Klingelschildbeleuchtung dauerhaft leuchtet (egal was danach passiert). Dieses Phänomen ändert sich auch nicht mit der obigen Firmware.

Ich habe nun zwar eine neuere V3.x Firmware auf der VTO und eine V4.x Firmware auf der VTH, aber das Problem mit der Klingelschildbeleuchtung besteht nach wie vor.

Für alle die mitlesen und ggf. auch ein 1-Klingeltaster-Modul (VTO2000A-B1) haben: Im Menüpunkt "Fassadengestalt" _NICHT_ den 1-Klingeltaster auswählen und einer Zimmernummer zuweisen - der Klingeltaster im 1-Klingeltaster-Modul reagiert hier nicht. Man muss das 3-Klingeltaster-Modul hinzufügen und den _mittleren_ Klingeltaster mit der gewünschten Zimmernummer belegen. Diese wird dann gerufen, wenn am 1-Klingeltaster-Modul der Knopf gedrückt wird. Hört sich komisch an, ist aber so. :)

Der nächste Schritt wäre nun, eine V4 auf der VTO zu testen und zu sehen, wie sich die Sachlage dort Verhält. Mal schauen, ob ich dazu den Mut aufbringen kann. ;)

BTW: Durch solche Experimente könnte sich die Community eine Art "Feature-Matrix" aufbauen, was mit welchen Firmware-Kombinationen von VTO und VTH kompatibel sind und was jeweils geht oder auch nicht. Hat das jemand schonmal begonnen? Gibt es da schon Ansätze?
 

riogrande75

Mitglied
Mitglied seit
30 Okt 2017
Beiträge
556
Punkte für Reaktionen
59
Punkte
28
Feature Matrix wäre schön, aber dieser Bereich des Forum's hier ist leider auch schon zu einem Selbstbedienungsladen verkommen: Jeder kauft günstig in China ein (absolut ok, mach ich nicht anders) und anstatt sich wenigstens einzulesen, wird einfach jede Frage die auftaucht gepostet. Wenn diese beantwortet wurde => tschüss. Rückmeldung, etc. gibts nur von den wenigsten.:mad:
 

༺Leͥgeͣnͫd༻

Neuer User
Mitglied seit
23 Okt 2019
Beiträge
7
Punkte für Reaktionen
1
Punkte
1
Update: Erfolg! :)

Beim Testen gestern war es spät, ich habe einfach nicht lange genug gewartet: Die Klingelschildbeleuchtung schaltet sich exakt 2 Minuten nach dem Klingeln wieder aus.

Zusammenfassung dieser Non-SIP-Konfig:

Außenstationen: VTO2000A-C mit 1-Klingeltaster-Modul (VTO2000A-B1):
  • MCU V3 (23.11.2018): „General_VTO2000A-MCU_V3.000.0000000.0.R.20181123.zip“ verlinkt hier (mit VDPConfig aus der Dahua Toolbox einspielen - nur die MCU _nicht_ das Hauptprogramm).
  • Firmware V3.12 (25.10.2018): „Customer_VTOXXX_EngItlFrnGerDutSpnPrt_P_16M_V3.120.001P000.0.T.20181025“ verlinkt hier.
Innenstationen: VTH1510CH
  • Firmware V4 (06.09.2018): „Customer_VTH151X_EngItlFrnGerDutSpnPrt_V4.000.100B000.0.T.20180906“ velinkt hier.
Ergebnis: UI der VTHs im neuen V4-Design, Deutsch als Sprache einstellbar. VTO WebUI auch in Deutsch. Sprachausgabe der Außenstation per WebUI abstellbar. Klingelschildbeleuchtung geht beim Klingeln an egal welchem Klingeltaster bei beiden Klingeltastern an und 2 Minuten später wieder aus.

Damit kann man doch erstmal arbeiten. :)

Das nächste Abenteuer wäre dann so ein Setup hinzubekommen, nur mit SIP-Support.
 
  • Like
Reaktionen: pjotr_weliki

riogrande75

Mitglied
Mitglied seit
30 Okt 2017
Beiträge
556
Punkte für Reaktionen
59
Punkte
28
Na, also. Habwegs aktuelle Versionen genommen und schon funktioniert's.
 

༺Leͥgeͣnͫd༻

Neuer User
Mitglied seit
23 Okt 2019
Beiträge
7
Punkte für Reaktionen
1
Punkte
1
Ja, zum Glück. :)

Danke nochmal für die Pointers @riogrande75! Die größte Challenge in dem Bereich ist glaube ich nicht unbedingt die Firmwares und MCUs durchzuprobieren, sondern erstmal geeignete Firmwares und MCUs zu finden. Dahua macht es einem hier nicht gerade einfach.
 

JoKruemel

Neuer User
Mitglied seit
28 Nov 2018
Beiträge
39
Punkte für Reaktionen
4
Punkte
8
Hallo Legend , riogrande,
hinsichtlich der Klingelbeleuchtung habe ich eine Überraschung erlebt.
Die alten VTO 2000 A haben die Beleuchtung immer eingeschaltet ( Tag und Nacht ). Altes Problem haben wir schon ausführlich behandelt. Als Erweiterung habe ich eine neue VTO 2000 A bei Ali bestellt mit dem Ergebnis : Klingelbeleuchtung wird bei Dunkelheit eingeschlatet und morgens aus. So sollte es sein. Die Version bei der VTO : 2017-09-12 V 3.200.0000 . Also bei Dahua tut sich doch was.!!!!!
 

JoKruemel

Neuer User
Mitglied seit
28 Nov 2018
Beiträge
39
Punkte für Reaktionen
4
Punkte
8
Als Nachtrag.
Auf meine Bitte hin hat mir der Chin. Händler heute per Mail die v.g. FW gesendet. Wer sie haben möchte bitte Mail Adresse. Ich selbst habe die FW noch nicht ausprobiert.
 

3CX PBX - GRATIS
Linux / Win / Cloud

Neueste Beiträge

Statistik des Forums

Themen
233,165
Beiträge
2,030,863
Mitglieder
351,562
Neuestes Mitglied
Brian91