.titleBar { margin-bottom: 5px!important; }

Warum funktioniert Asterisk+Sipgate nur parallel mit X-Lite?

Dieses Thema im Forum "sipgate" wurde erstellt von m_aus_a, 4 Dez. 2004.

  1. m_aus_a

    m_aus_a Neuer User

    Registriert seit:
    4 Dez. 2004
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo erstmal!

    Was vorhanden ist:
    Linux Router (Debian) mit
    - Asterisk
    - HFC-S Karte im NTmode, daran eine T-Concept XI321
    - FritzCard DSL für die Verbindungen nach draußen

    Was funktioniert:
    - Anrufe gehend über externe ISDN Leitung
    - Anrufe kommend über ext. ISDN und Sipgate
    - Anrufe gehend über Sipgate an Sipgate-interne Nummern(z.B. 10000, andere Sipgate Teilnehmer)

    Was also nicht funktioniert:
    - Anrufe gehend über Sipgate ins Handy- bzw. Festnetz

    ABER:
    Wenn ich mich auf einem PC im Netzwerk per X-Lite bei sipgate anmelde, dann funktioniert auch plötzlich der Asterisk tadellos und wählt brav über Sipgate ins Festnetz. Und kaum ist X-Lite wieder beendet höre ich wieder nur noch "Es ist ein Fehler aufgetreten........."

    Jetzt frag ich Euch: woher kommt denn sowas????

    Und glaubt mir, ich hab recherchiert wie ein Irrer, aber die Lösung für dieses Problem war nirgends in Sicht.
     
  2. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    So sieht bei mir die sip.conf aus, damit Anrufe ins Festnetz/Handynetz funzen. Oft leigt es an dem fehlenden "insecure=very" oder "fromdomain=sipgate.de".

    Code:
    [sipgate]
    insecure=very
    type=friend   
    username=1234567
    secret=abcdefg  
    host=sipgate.de 
    fromuser=1234567
    fromdomain=sipgate.de
    nat=no
    context=sipgateein
    canreinvite=no  
    dtmfmode=info  
    disallow=all
    allow=ilbc   
    allow=gsm
    allow=g726
    allow=ulaw
    allow=alaw
    
     
  3. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Um über sipgate abgehend telefonieren zu können muss man, anders als bei anderen Anbietern, auch registered/angemeldet sein für eingehende Gespräche!

    Genau dies machst du mit Xlite - Lösung:

    [general]
    .
    register => 800xxxx:passw@sipgate.de/800xxxx in sip.conf
     
  4. m_aus_a

    m_aus_a Neuer User

    Registriert seit:
    4 Dez. 2004
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke das war meine Rettung

    @Netview: Das war der Fehler!! Ich hatte nämlich schon ein "register" für sipgate in meiner sip.conf stehen.....
    das sah so aus:
    register => Nummer:passwort@sipgate.de

    jetzt:
    register => Nummer:passwort@sipgate.de/Nummer

    Ich dachte, das, was da hinterm "/" steht sagt lediglich an welche extension ein Anruf gehen soll......

    Aber egal.... es geht jetzt und mehr wollte ich auch gar nicht.

    Trotzdem würde mich sehr interessieren, was es nun genau mit dem Zeugs hintern "/" auf sich hat.....


    Erstmal tausend Dank!!!