.titleBar { margin-bottom: 5px!important; }

welche chan_capi lässt sich mit Asterisk 1.2 nutzen?

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von konabi, 11 Okt. 2005.

  1. konabi

    konabi Mitglied

    Registriert seit:
    11 Apr. 2005
    Beiträge:
    424
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Hallo,
    weiß jemand ob man sie chan_capi 0.3.5 von Junganns mit der Asterisk Version 1.2 nutzen kann?

    Was bedeutet folgender Hinweis in der Install Datei?

    Make sure you enable the "CFLAGS+=-DCVS_HEAD" if you want to built against CVS HEAD

    In welcher Datei muß dieser Eintrag gemacht werden.


    Danke Sven
     
  2. D-Trix

    D-Trix Neuer User

    Registriert seit:
    11 Juli 2005
    Beiträge:
    127
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    nein kann man nicht; nimm einfach die chan_capi-cm 0.6 :)
     
  3. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
  4. konabi

    konabi Mitglied

    Registriert seit:
    11 Apr. 2005
    Beiträge:
    424
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Danke für Eure Hilfe.

    Ich hatte es zwischendurch mit der chan_capi 0.4 PRE von Junghanns versucht. Kompilieren klappt, aber bei einen eingehenden Ruf über ISDN
    stürzt der * ab:

    CLI> -- creating pipe for PLCI=0x101 msn=51
    Segmantation fault


    Werde also mortgen die chan_capi-cm 0.6 versuchen.

    Es müsste doch reichen wenn sich alle junghanns capi module aus dem modules Verzeichnis lösche und die modules.conf anpasse oder?



    Danke Sven
     
  5. copytech

    copytech Neuer User

    Registriert seit:
    7 Nov. 2004
    Beiträge:
    61
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bitte um Hilfe....

    Guten Abend...

    Seit 4 Stunden probiere ich nun, Asterisk mit einer Capi ins Laufen zu bekommen. Leider ohne erfolg, schluchtz!

    Installiert:
    Asterisk 1.2.0.beta2
    chan_capi-cm6
    Suse 10.0

    FritzCard PCI ist installiert, und wird über lsmod korrekt angezeigt.
    Beim Compelieren der chan_capi kommen schon diverse capi warnungen, aber läuft durch.

    Starte ich nun Asterisk, stürzt er ab, und meldet:
    [chan_capi.so]Nov 7 23:11:31 WARNING[14627]: loader.c:325 __load_resource: /usr/lib/asterisk/modules/chan_capi.so: undefined symbol: use_ast_mutex_init_instead_of_pthread_mutex_init
    Nov 7 23:11:31 WARNING[14627]: loader.c:499 load_modules: Loading module chan_capi.so failed!

    Ich krieg`s nicht hin....
    Bitte um Hilfe....

    Cu, Dirk
     
  6. copytech

    copytech Neuer User

    Registriert seit:
    7 Nov. 2004
    Beiträge:
    61
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Es scheint wohl an der Asterisk Beta 2 zu liegen.
    Ich habe die "alte" 1.0.9 installiert, mit der gleichen ISDN Karte/einstellung und der gleichen chan_capi und es lief
    direkt ohne Fehler....


    Cu, Dirk
     
  7. armincm

    armincm Aktives Mitglied

    Registriert seit:
    3 Aug. 2005
    Beiträge:
    1,006
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Der mutex_init Fehler ist im neuen chan_capi-cm (CVS HEAD auf sourceforge) behoben.
    Diese Version wird bald 0.6.1 werden.

    Armin