werde wahnsinnig!! Telefon meldet sich nicht bei Asterisk an

pbtraveller

Neuer User
Mitglied seit
23 Jul 2004
Beiträge
121
Punkte für Reaktionen
0
Punkte
0
Hi,
ich werde langsam wirklich wahnsinnig. Mein Telefon Adabter Grandstream HandyTone 286 meldet sich einfach nicht richtig bei Asterisk an!! Verstehe nicht woran es liegt!!

Auf die Anfrage: "sip show peers" bekomme ich immer:

Name/username Host Mask Port Status
008/008 192.168.2.160 255.255.255.255 5060 UNREACHABLE
nullnullacht/nu 63.214.186.6 255.255.255.255 5060 Unmonitored

Außerdem bekomme ich beim rauswählen immer nach einer Weile einen Besetztzeichen. Beim reinwählen bekomme ich das gleiche!

meine sip.conf sieht folgendermasen aus:

[general]
port = 5060
bindaddr = 0.0.0.0
disallow=all
allow=ulaw
allow=alaw
#
register=nullnullacht:[email protected]/008

[nullnullacht]
type=friend
username=nullnullacht
fromuser=nullnullacht
secret=Nikotelpasswort
context=default
host=calamar0.nikotel.com
fromdomain=calamar0.nikotel.com
canreinvite=no
nat=yes

[008]
type=friend
username=008
fromuser=008
host=192.168.2.160
secret=Asteriskkennwort
nat=yes
dtmfmode=info
context=nikotel
canreinvite=no
qualify=yes

meine extensions.conf lautet:

[default]
exten => 008,1,Dial(Sip/${EXTEN},60)
exten => 008,2,Congestion
exten => 008,104, Busy

[nikotel]
inklude => default
exten =>_08.,1,Dial(SIP/${EXTEN:2}@nullnullacht,60,Ttr)

Hab jetzt folgende Fragen:
1. könnte die NAT-Einstellung falsch sein. (Bei meinem Router ist NAT eingeschaltet)
2. Wie bekomme ich es raus, dass NAT möglicherweise falsch ist
3. Nikotel passt ja immer die Firmware der Telefone an das eigene System an. Kann es daran liegen.
4. Der Asterisk-Server ist Wireless an das Netzwerk angebunden. Stellt das ein Problem dar?
5. Muss ich noch irgend etwas konfigurieren außer der sip.conf , extensions.conf und dem Telefon?
5. Wo sonst liegt das Problem?

Wäre super wenn mir jemand helfen könnte bevor ich jetzt das Telefon an die Wand werfe!!

Gruß
pbtraveller


PS: folgede Hardware ist im Einsatz: Apple Powerbook G4 867 Mhz / Router T-Sinus 154 DSL / Telefon:Grandstream HandyTone 286
 

Hupe

Aktives Mitglied
Mitglied seit
8 Apr 2004
Beiträge
2,586
Punkte für Reaktionen
0
Punkte
0
Auch ja, das passwort ist ja nicht länger als 7 oder 8 Zeichen. Dann geht es sowiso nicht!
Oh und host = dynamic, wenn du mit passwort arbeitest.
Und und "auth = md5" würde ich auchnoch reinsetzen.
 

Hupe

Aktives Mitglied
Mitglied seit
8 Apr 2004
Beiträge
2,586
Punkte für Reaktionen
0
Punkte
0
Oh, du benutzt doch den ATA intern, oder? Dann muß "nat = no"

Nochwas. Mit den Einstellungen, die ich Dir letztes mal gepostet habe läuft das hanze in jedem Fall. Hab so selbst einen ATA angeschlossen.

[008]
type=friend
username=008
fromuser=008
host=dynamic
auth=md5
secret=geheim ;nicht länger als 8 zeichen
nat=no ; yes, wenn extern
canreinvide=no ; yes get auch wenn extern angeschlossen
context=default
disallow=all
allow=ulaw
allow=alaw
dtmfmode=info ;sollte so auch in der Konfig es atas stehen
qualify=yes
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,095
Beiträge
2,030,079
Mitglieder
351,417
Neuestes Mitglied
Steinchen7