.titleBar { margin-bottom: 5px!important; }

Wie stelle ich die MSN bei Asterisk ein?

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von johnyt11, 22 Okt. 2004.

  1. johnyt11

    johnyt11 Neuer User

    Registriert seit:
    27 Aug. 2004
    Beiträge:
    120
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ich habe Asterisk mit dem bristuff von junghanns.net nach dieser Anleitung instaliert. und etwas abgeändert wegen 2 HFC Karten.

    nur wenn ich den hörer Abhebe wird folgende Meldung in der Asterisk-Konsole ausgegeben.

    Code:
    *CLI>   == Primary D-Channel on span 1 up for TEI 64
        -- Going to extension s|1 because of immediate=yes
        -- Extension 's' in context 'default' from '33' does not exist.  Rejecting call on channel 0/2, span 1
      == Primary D-Channel on span 1 down for TEI 64
    
    ich sehe zwar das etwas in der Datei extensions.conf falsch sein muß, aber was?

    mit den normalen Samples, komme ich ins Demo Menü also müßten auch die Einstellungen richtig sein.
    sobald aber die extensions.conf auf die u.a. umgestellt wird kommt die obige Meldung

    sip.conf
    Code:
    [general]
    port = 5060
    bindaddr = 0.0.0.0
    externip = XXXX.homeftp.net
    localnet = 192.168.100.0/255.255.0.0
    srvlookup = yes
    context = default
    disallow = all
    allow = gsm
    allow=ulaw 
    allow=alaw 
    register => 11122233:Pass@sipgate.net/11122233
    canreinvite = no
    tos=0x18
    insecure=very
    nat=yes
    dtmfmode=info
    
    [sipgate]
    type=friend
    username=11122233
    secret=Pass
    host=sipgate.de
    fromuser=11122233
    fromdomain=sipgate.de
    context=default
    canreinvite=no
    qualify=yes
    disallow=all
    allow=gsm
    insecure=very
    nat=yes
    dtmfmode=info
    tos=0x18
    
    extensions.conf
    Code:
    [general]
    static=yes
    writeprotect=no
    
    [globals]
    IAXINFO=guest
    
    
    [default]
    include => calls
    
    [calls]
    exten => 11122233,1,Dial(Zap/2/33,60,tT)
    exten => 11122233,2,Hangup
    
    exten => _1.,1,Dial(SIP/${EXTEN:1}@sipgate,60,tT)
    exten => _1.,2,Congestion
    exten => _1.,3,Busy
    exten => _1.,4,Hangup
    
    
    zapta.conf
    Code:
    [channels] 
    ; 
    ;defaults 
    switchtype = euroisdn 
    signalling = bri_net_ptmp  
    pridialplan=local 
    echocancel=yes 
    immediate=yes 
    setcallerid(""<${CALLERIDNUM}>) 
    usecallerid=yes 
    group = 1 
    context=default 
    channel => 1-2 
    ; 
    signalling = bri_cpe_ptmp  
    group = 2 
    channel => 4-5 
    
    zaptel.conf
    Code:
    loadzone=nl 
    defaultzone=nl 
    
    span=1,1,3,ccs,ami 
    bchan=1-2 
    dchan=3
    
    span=2,1,3,ccs,ami 
    bchan=4-5 
    dchan=6
    
     
  2. Blackvel

    Blackvel Mitglied

    Registriert seit:
    4 Mai 2004
    Beiträge:
    624
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    selbständig als IT-Consultant (VoIP, Asterisk, J2E
    Ort:
    Nürnberg, Einsatzorte Schwerpunkt D6-D9 (MCH, STG,
    Jou hast Du Probläm.

    Musst Du in extensions.conf [call] reinnehmen s/33
    Normalerweise macht man das hier:

    zapata.conf:
    context=isdn

    extensions.conf:
    [isdn]
    exten => s/33,1,Accept
    exten => s/33,2,Goto(default,BYEXTENSION,1)

    Problem ist halt, daß keine Nummer zu * beim Abheben durchgeschickt wird. Ich denke auch, dass immediate=yes falsch ist!!!

    Ich selbst hab wegen TK-Anlage _/33 (bei ISDN-TEL) bzw. s/33,1,DISA für Analog-TEL konfiguriert.
     
  3. johnyt11

    johnyt11 Neuer User

    Registriert seit:
    27 Aug. 2004
    Beiträge:
    120
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Mit dem ZAP und den extensions.conf komm ich so noch nicht klar...
    den Befehl "accept" will * wohl nicht kennen.. oder mach ich was falsch?

    Code:
        -- Accepting call from '33' to 's' on channel 0/2, span 1on_helper:
    No application 'Accept' for extension (ISDN, s, 1)
      == Spawn extension (ISDN, s, 1) exited non-zero on 'Zap/2-1'
        -- Hungup 'Zap/2-1'
    @Blackvel schrieb:
    Ich denke auch, dass immediate=yes falsch ist!!!

    jau, das war falsch! hab ich auch schon bemerkt.

    ich hab auch einiges durchprobiert.

    die Makros von allesOK und auch den von der Seite junghanns.net

    nur, das ist dann ja schon mehr für fortgeschrittene... und nicht mehr der "einfache" Dialplan.

    ich denke das werde ich auch noch schaffen. aber die liebe Zeit die mann nicht hat.

    ich will doch nur eine TK-Anlage am extern S0-Port anschließen, Um an der Telefonanlage zusätzliche Leitungen über einen SIP-Provider zu erhalten.
    (das andere kommt später)
    wer kann mir da auf die schnelle helfen??
    wenn meine Fragen zu speziel sind, gerne per Tel.