[Problem] Windows 11 und das gute alte Shrew Soft VPN

gundi88

Neuer User
Mitglied seit
21 Mai 2010
Beiträge
34
Punkte für Reaktionen
0
Punkte
6
Hallo,

da ich vor paar Tagen meinen PC neu gemacht hab und gleich auf Windows 11 bin wollte ich heute mal wieder eine VPN verbindung aufbauen und hab das Shrew Soft 2.2.2 installiert wie vorher unter Windows 10 auch.

Nachdem er den Treiber installiert war ende Lan Verbindung war noch Aktiv und aber INET tot bis ich es wieder Deinstalliert habe!

Hat da wer eine idee ?

Gruß gundi

TanteEDIT: hab rausgefunden das wenn ich in den Eigenschaften vom Ethernet also meiner Karte die "Shrew Soft Lightweight Filter" ausschalte alles klappt bis auf die VPN verbindung dann natürlich -.-
 
Zuletzt bearbeitet:

mp37c4

Neuer User
Mitglied seit
26 Aug 2011
Beiträge
3
Punkte für Reaktionen
0
Punkte
1
na ja, der shrew soft vpn client ist jetzt aber schon ziemlich veraltet. Ich habe mich immer gewundert, dass der die ganzen Win-10 Updates mitgemacht hat. Ich mochte ihn wegen seiner „Leichtigkeit“ gegenüber einem richtigen IPsec client und dem Performance Vorteil von Ipsec gegenüber SSL. Wenn es nicht sein muss, würde ich bei einer stabilen Win10 Konfiguration bleiben oder eben auf SSL wechseln.
 

SAM.BONN

Neuer User
Mitglied seit
2 Nov 2012
Beiträge
7
Punkte für Reaktionen
1
Punkte
3
Hallo @gundi88,

hatte das gleiche Problem:
Windows 10 + Shrew Soft VPN-Lösung = LAN+VPN funktioniert,
Windows 11 + Shrew Soft VPN-Lösung = LAN+VPN funktioniert nicht.
Um es kurz zu machen ich habe eine Lösung für mich gefunden.
Habe ein USB-LAN-Adapter von meinem Notebook an den PC gesteckt, LAN-Kabel rein, und nun funktioniert alles wieder, auch Shrew Soft VPN.

Habe ein Motherboard mit integriertem "Realtek PCIe GbR Familiy Controller".
Wie bei Dir war nach der Installation der Shrew Soft VPN-Lösung hatte die Netzwerkkarte eine 169.254.x.x-Adresse (APIPA). Nach der Deaktivierung des Shrew Soft Lightweiht Filter im Netzwerkadapter-Eigenschaften war die korrekte LAN-Adresse wieder aktiv. Nach der Deinstallation der Shrew Soft VPN-Lösung war auch wieder alles in Ordnung.
Irgendwo, in einem anderem Forum, hatte ich gelesen, dass jemand das gleiche Problem mit der Shrew Software hatte, aber mit einer Intel-Netzwerkkarte. Dieser Leidensgenosse hatte dann die aktuelle Treiberversion von Intel installiert und war damit erfolgreich, Shrew VPN funktionierte.
Leider hat die Installation der aktuellen Realtek Treiber für Windows 11 nicht funktioniert. Daher nehme ich an, dass der gelesen Lösungsweg "neue Treiber" nur mit den Intel-NICs glückt.
Interessant bei meiner Konfiguration ist, dass der LAN-Controller im USB-Adapter auch aus der Realtek GbE Family ist. Nur eben USB ("Realtek USB GbR Familiy Controller").

Vielleicht ist ein UAB-LAN-Adapter auch für Dich eine Lösung.

Und vielen Dank, dass Du dein Problem in ein Forum gepostet hast.
Ich kann mir gut vorstellen, dass dein Beitrag den ein oder anderen Ratsuchenden hilft.

Grüße
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
14,852
Punkte für Reaktionen
1,583
Punkte
113
Der Shrewsoft VPN-Client bietet zwei verschiedene Modi, wie er sich in das System integrieren kann - einmal als Filter bei einem physikalisch vorhandenen NIC und einmal als virtuelles Interface (also als eigener NIC). Die zweite Version (Virtual Adapter Mode) sollte eigentlich mit jedem W11-System und jedem NIC funktionieren: https://www.shrew.net/static/help-2.1.x/files/GeneralSettings.html
 

SAM.BONN

Neuer User
Mitglied seit
2 Nov 2012
Beiträge
7
Punkte für Reaktionen
1
Punkte
3
@PeterPawn
Wollte eine Rückmeldung geben.
Habe beide Settings ausprobiert.
Unter dem Reiter "General" bei "Local Host" den "Adapter Mode" auf "Use a vitual adapter and assigned adress" (mit aktivem "Optain Automaticly") und den "Adapter Mode" auf "Use an existing adapter an current address".
Leider konnte ich keinen Unterschied feststellen. Bei beiden Modis hatte die NIC eine APIPA-Adresse.
Somit ist wohl einfach festzuhalten, dass unter Windows 11 bei einigen On-Board-Netzwerkkarten, bei mir der "Realtek PCIe GbR Familiy Controller" (PCI\VEN_10EC&DEV_8168&SUBSYS_81681849&REV_15), und deren Treiber der Shrewsoft VPN-Client nicht einsetzbar ist.
Wie schon geschrieben, funktioniert bei mir der Shrewsoft VPN-Client mit einem USB-LAN-Adapter, auch wenn dieser laut dem Gerätenamen aus der Realtek GbE Family ist (USB\VID_0BDA&PID_8153&REV_3000 + Treiber von Microsoft).
¯\_(ツ)_/¯
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
14,852
Punkte für Reaktionen
1,583
Punkte
113
Ich nutze zwar kein Windows 11 (und habe auch nicht Deine spezielle Netzwerk-Hardware und -Konfiguration), aber wenn:
Leider konnte ich keinen Unterschied feststellen. Bei beiden Modis hatte die NIC eine APIPA-Adresse.
stimmen sollte, dann hat bei Dir die Umschaltung wohl nicht richtig funktioniert, weil nur bei einem virtuellen Adapter überhaupt ein eigenes Netzwerkinterface verwendet wird. Im anderen Fall wird ein existierender physikalischer Adapter genutzt (und der Treiber klinkt sich als Filter in die Kette der Paketverarbeitung ein) und der sollte - wenn das Gerät ins Internet kommt - dann auch eine passende IP-Adresse haben. Das KANN zwar auch eine APIPA-Adresse sein, aber üblicherweise sollte das eher eine private Adresse sein, die von einem DHCP-Sevrer im lokalen Router bezogen wurde.

Da besteht also schon ein erkennbarer Unterschied zwischen den beiden Betriebsarten (bzw. "Adapter modes") und wenn das bei Dir nicht der Fall war, hat vermutlich die Änderung nicht funktioniert. Es wäre aber immerhin denkbar, daß eine "dynamische Konfiguration" der VPN-Verbindung (der "Adapter mode" ist ja eine Eigenschaft der Verbindung) unter Windows 11 nicht richtig klappt ... daß der Shrewsoft-Client generell funktioniert, hast Du ja selbst feststellen können, wenn es bei Dir mit einem zusätzlichen USB-NIC dennoch läuft.
 

SAM.BONN

Neuer User
Mitglied seit
2 Nov 2012
Beiträge
7
Punkte für Reaktionen
1
Punkte
3
@PeterPawn
Das Problem mit der Shrewsoft-VPN-Anwendung ist, dass sobald die Anwendung installiert wird bzw. ist, die NIC eine APIPA-Adresse erhält oder besser die IPv4-Adresse des Heimnetzwerks verliert. Irgendwie verträgt sich der Shrew Soft Lightweiht Filter/-Dienst sich nicht mit den Windows 11-Netzwerkeigenschaften/der Windows-IP-Konfiguration
Natürlich ist bei der reinen Installation noch nichts konfiguriert. Aber die Tests mit konfigurierten Partnern innerhalb der Anwendung hatte ich ja auch schon gemacht. Jedoch nutzt es nichts, wenn Windows 11 mit dem Shrewsoft-VPN-Filter/-Dienst derart nichts anzufangen weiß, dass die Heimnetz-IP plötzlich der APIPA-Adresse weicht.
Übrigens ist nun auch mein USB-NIC-Adapter ebenso von dieser fehlerhaften Konfiguration betroffen. Somit habe ich keine Möglichkeit mehr mit meinem Windows 11-Rechner die Shrewsoft-VPN-Lösung zu nutzen.

Interessant bei den Installationen und Deinstallationen war der Umstand, dass sofort die Zustandsänderung eintrat, Also nach der Installation die IPv4-Adresse weg, nach der Installation war die IPv4-Adresse wieder da, Sah so aus wie "Service aus" und dann wieder "Service ein".
Im der Ereignisanzeige waren Fehler vom "DHCP-Client" zu sehen:
"Dem Computer wurde (vom DHCP-Server) keine Adresse aus dem Netzwerk für die Netzwerkkarte mit der Netzwerkadresse 0xA8A159378990 zugewiesen. Fehler: 0x79. Der Computer versucht, weiterhin selbständig eine Adresse vom Netzwerkadressserver (DHCP-Server) abzurufen."
Ebenso Warnungen vom "SetupDeviceManager":
"Vom Netzwerklisten-Manager wird eine fehlende Internetkonnektivität gemeldet."
sowie
"Eine Verbindung mit Windows Metadata and Internet Services (WMIS) konnte nicht hergestellt werden."
sowie
"Es konnte keine Verbindung mit dem Windows Update-Dienst hergestellt werden."
Alles leider ohne Hinweis auf den Verursacher.
Der Service "DHCP-Client" lief. Der Versuch diesen Service neu zu starten schlug fehl (Zugriff verweigert).
Auch das deaktivieren der bei der Installation eingebrachten Dienste "ShrewSoft IKE Deamon" und "ShrewSoft IPSEC Deamon" zeigte keine Änderungen.
Hatte auch mal in den Firewall-Regeln nachgesehen, ob der Shrewsoft-VPN-Dienst geblockt werden würde, aber ich habe dort keinen Shrewsoft-Eintrag gefunden.
Auch den Defender-AV und die -FW komplett zu deaktivieren (ohne reboot) brachte keine Veränderung.

Ich hab das "herumgestochere" dann abgebrochen.

Noch habe ich ein Notebook mit Windows 10 und hiermit funktioniert alles. Somit ist es für mich nicht ganz so dramatisch, dass Shrewsoft mit Windows 11 - oder umgekehrt - "klemmt".
Da ich eher selten eine VPN-Verbindung in andere Netz (Gegenstelle mit einer AVM Fritzbox 7490) einwähle, scheue ich mich auf die NCP Secure Entry Client-Lösung zu wechseln, da diese mit rund 90€ schon eine berufliche Notwendigkeit voraussetzt.
Vielleicht kommt mal auf der Gegenstelle eine Fritzbox 7590 zum Einsatz, damit soll ja WireGuard funktionieren.

Grüße und Danke für den Austausch
 

koyaanisqatsi

IPPF-Urgestein
Mitglied seit
24 Jan 2013
Beiträge
14,126
Punkte für Reaktionen
576
Punkte
113
Moin

Na, dass lässt ja Raum für Spekulationen.
Ala,....

Shrewsoft: Zu junge Programmierer, die https://openlibrary.org/books/OL1885911M/Undocumented_DOS nicht kennen?
Damals, beim Durchblättern, war der Großteil Netzwerkkram :cool:

Windows 11: Nutzt jetzt janz viel aus obigen Link :cool::eek:

Und ich dachte Linux wäre kompliziert ;)
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
14,852
Punkte für Reaktionen
1,583
Punkte
113
Den Filter sollte man auch manuell deaktivieren können (notfalls über netsh bzw. PowerShell - ich weiß nicht, ob es unter W11 noch den Dialog mit den erweiterten Eigenschaften eines Netzwerk-Interfaces gibt, wo man die zu bindenden Dienste und Protokolle einzeln auswählen kann per Checkbox) und wenn der nicht mehr geladen wird, sollte das Interface auch wieder per DHCP eine Adresse beziehen können.

Für den Betrieb(!) mit dem eigenen, virtuellen Interface wird der Filter gar nicht gebraucht und das virtuelle Interface erhält ohnehin seine IP(v4)-Adresse vom VPN-Gateway, zu dem die Verbindung aufgebaut wurde. Zumindest bei Nutzung von MODE-CFG nach Cisco-Gusto, wo der "Server" auch die IP-Konfiguration des Clients übernimmt - je nach IPSec-Version auch mal mode configuration oder configuration mode bei der (eigenen) Suche im Internet ....
 

Anhänge

  • bindings_windows_7.png
    bindings_windows_7.png
    23.7 KB · Aufrufe: 17
Zuletzt bearbeitet:

SAM.BONN

Neuer User
Mitglied seit
2 Nov 2012
Beiträge
7
Punkte für Reaktionen
1
Punkte
3
Danke für die Rückmeldungen.

Ich glaube ein wenig schlauer geworden zu sein.
Bei diesem Artikel auf deskmodder.de (https://www.deskmodder.de/blog/2022...thernet-treiber-fuer-windows-11-10-8-1-und-7/) habe ich erst realisiert, dass Windows 11 ein anderes Treibermodell hat als die vorherigen Windows-Versionen. Microsoft nennt das NetAdapter-Klassenerweiterung (NetAdapterCx) und nutzt hier das WDF (Windows Driver Framework). Damit ist "NDIS" nach dem Willen von Microsoft auf Windwos 11-Systemen raus.
Und wie wir schon bemerkt haben, mag ein NetAdapterCx-Treiber keine Erweiterung welche offenbar NDIS voraussetzt, hier der ShrewSoft-VPN-Treiber bzw. der "Shrew Soft Lightweight Filter".

Microsoft gibt Entwicklern auch Informationen, wie WDF zum Entwickeln eines Treibers genutzt werden soll: https://learn.microsoft.com/de-de/w...s/wdf/using-the-framework-to-develop-a-driver
Hilft uns leider nicht, denn Shrew Soft Inc. hat die Entwicklung 2013 eingestellt.

Nun habe ich den Windows 11-NetAdapterCx-Treiber auf meinem AMD-System deinstalliert.
Da ich vor einiger Zeit den aktuellen Realtek-NetAdapterCx-Treiber für die On-Board-NIC installiert hatte, habe ich dies über die App-Deinstalltion (Einstellungen > Apps > Installierte Apps) gemacht. Hätte ich diese Möglichkeit nicht gehabt, wäre ich über den Geräte-Manger gegangen (Gerät deinstallieren).

Hiernach habe ich dann den Realtek-NDIS-Treiber für Windwos 10 installiert (Link ist im deskmodder.de-Artikel, oder eben über die Realtek-Downlaod-Page: https://www.realtek.com/en/downloads).
Die Installation erfolgt ohne Probleme und auch nach einem Systemreboot war alles gut, Also mit Shrewsoft kein APIPA mehr, NIC hat eine Heimnetz-IP.

Und das Beste bei der Aktion war/ist: ShrewSoft VPN funktioniert!

Nun besteht das Risiko, dass irgendwann ein Windows 11-Update den Realtek-NDIS-Treiber durch ein NetAdapterCx-Treiber ersetzt. Dann hoffe ich, dass der Windows 10-NDIS-Treiber wieder alles heilt.

Vielleicht probiert jemand mit dem gleichen Problem den NDIS-Treiber aus und postet dann den Erfolg oder Misserfolg hier rein.

Grüße
 

Anhänge

  • 2022-12-28 (Shrew Soft Lightweight Filter).png
    2022-12-28 (Shrew Soft Lightweight Filter).png
    20.1 KB · Aufrufe: 13
  • 2022-12-28 (Realtek Win10_10063_12212022 - NDIS).png
    2022-12-28 (Realtek Win10_10063_12212022 - NDIS).png
    21.6 KB · Aufrufe: 13

Zentralplasma

Neuer User
Mitglied seit
15 Aug 2005
Beiträge
65
Punkte für Reaktionen
0
Punkte
6
Vielleicht probiert jemand mit dem gleichen Problem den NDIS-Treiber aus und postet dann den Erfolg oder Misserfolg hier rein.

Vielen Dank für die Info - hatte dasselbe Problem. Nachdem ich den Realtek PCIe GbE Family Controller Win11 Treiber deinstalliert hatte und durch den alten Win10 Treiber ersetzt hatte, geht der ShrewSoft VPN Client einwandfrei.

Mal sehen was das nächste automatische Update macht...
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
14,852
Punkte für Reaktionen
1,583
Punkte
113
Nur noch mal als Verständnisfrage von meiner Seite: Das Deaktivieren des Filters in der Konfiguration des NIC (s. erster Screenshot in #10) reichte NICHT aus, damit die Probleme mit dem DHCP verschwanden? Das wäre insofern bemerkenswert, als ein deaktivierter Filter gar nicht erst geladen werden sollte und da stellt man sich schon die Frage, wie der dann die Protokolle (bzw. Pakete) noch verändern kann.

Denn wenn man den Filter DEAKTIVIERT hat, sollte der auch beim Update des Netzwerk-Treibers nicht wieder automatisch aktiviert werden - das würde dann die Notwendigkeit des "Mal sehen ..." entfallen lassen bei künftigen Updates.
 

SAM.BONN

Neuer User
Mitglied seit
2 Nov 2012
Beiträge
7
Punkte für Reaktionen
1
Punkte
3
Hallo @PeterPawn ,

doch. Du hast recht.
Wenn man bei dem neuen, für uns aber problematischen NetAdapterCx-Treiber den "Shrew Soft Lightweight Filter" in den Netzwerkkarten-Eigenschaften deaktiviert wurde, hatte die LAN-Verbindung wieder funktioniert => also keine Probleme mehr mit DHCP.
Dies hatte schon @gundi88 in deinem Post #1 berichtet.
Aber dann brauche ich keinen VPN-Client, wenn ich den benötigten VPN-Treiber deaktivieren muss um eine gültige LAN-Verbindung zu erhalten und so oder so auch kein VPN nutzen kann.
Beim NDIS-Treiber muss man nichts deaktivieren. Da funktioniert alles wie es soll.

Ich glaube das "Mal sehen ..." von @Zentralplasma ist gleich zu setzen mit meinem "..., dass irgendwann ein Windows 11-Update den Realtek-NDIS-Treiber durch ein NetAdapterCx-Treiber ersetzt".
Denn dann haben wir ja wieder die gleiche - nicht funktionale - Konfiguration.

Aber vielleicht schreibt @Zentralplasma noch eine Antwort auf deine Frage.

Eine Rückmeldung von @gundi88 wäre noch schön.

Grüße
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
14,852
Punkte für Reaktionen
1,583
Punkte
113
Aber dann brauche ich keinen VPN-Client, wenn ich den benötigten VPN-Treiber deaktivieren muss um eine gültige LAN-Verbindung zu erhalten und so oder so auch kein VPN nutzen kann.
Dieser "Shrew Soft Lightweight Filter" wird aber NUR DANN benötigt, wenn man eben nicht den "Virtual Adapter Mode" benutzt.

Aber egal ... ich hake das Thema für mich erst einmal ab. Danke für die Rückmeldung.
 

SAM.BONN

Neuer User
Mitglied seit
2 Nov 2012
Beiträge
7
Punkte für Reaktionen
1
Punkte
3
Hallo @PeterPawn ,

ahh ... glaube jetzt zu verstehen, welche Konfiguration Du meinst.
Ich versuch den Test mit NetAdapterCx-Treiber, deaktivierten "Shrew Soft Lightweight Filter" und den VPN-Client Adapter Mode "Use an existing adapter and current address" durchzuführen, komme aber frühestens nächste Woche dazu.
Ich melde mich.

Grüße

Edit: Hatte bei meinen alten Test mit den beiden Adapter Mode "Use a virtual adapter and assigned address" und "Use an existing adapter and current address" den "Shrew Soft Lightweight Filter" aktiviert.
 

Anhänge

  • Use_an_existing_adapter.png
    Use_an_existing_adapter.png
    44.2 KB · Aufrufe: 10
Zuletzt bearbeitet:

SAM.BONN

Neuer User
Mitglied seit
2 Nov 2012
Beiträge
7
Punkte für Reaktionen
1
Punkte
3
Hallo @PeterPawn ,

habe nun die Tests mit dem NetAdapterCx-Treiber und den beiden Adapter Modes "Use a virtual adapter and assigned address" und "Use an existing adapter and current address" mit deaktiviertem "Shrew Soft Lightweight Filter" durchgeführt.
Beide ohne Erfolg.

Die Meldung des VPN Client ist in beiden Fällen:
config loaded for site 'testefeste.vpn'
attached to key daemon ...
peer configured
iskamp proposal configured
esp proposal configured
client configured
local id configured
remote id configured
pre-shared key configured
bringing up tunnel ...
negotiation timout occurred
tunnel disabled
detached from key daemon


Mir mich ist dies ein deutlicher Hinweis, dass die Shrew Soft VPN-Lösung mit dem neuen Microsoft Treibermodel nicht funktioniert.

Mit dem NDIS-Treiber und dem Modus "Use a virtual adapter and assigned address" funktioniert es in gewünschter und gewohnter Weise.

Wollte dann wenigstens mit dem NDIS-Treiber den Modus "Use an existing adapter and current address" an laufen bringen. Zuerst hatte ich den "Shrew Soft Lightweight Filter" noch aktiv und die IP-Konfiguration des vorliegenden Systems auf DHCP belassen.
Die VPN-Verbindung wurde erfolgreich aufgebaut => "tunnel enabled" .
Natürlich konnte ich mit meiner lokalen IP nicht ins andere Netz.
Dann habe ich den "Shrew Soft Lightweight Filter" deaktiviert.
Und beim Verbindungsversuch kam wieder die obige Fehlermeldung: negotiation timout occurred

Es tut mir leid, aber da ich nicht weiß, wie ich den Modus "Use an existing adapter and current address" korrekt verwenden muss, habe ich den Test dann aufgegeben müssen.

Grüße
 
  • Like
Reaktionen: PeterPawn

Zurzeit aktive Besucher

Statistik des Forums

Themen
242,279
Beiträge
2,178,617
Mitglieder
367,277
Neuestes Mitglied
Eltra
Holen Sie sich 3CX - völlig kostenlos!
Verbinden Sie Ihr Team und Ihre Kunden Telefonie Livechat Videokonferenzen

Gehostet oder selbst-verwaltet. Für bis zu 10 Nutzer dauerhaft kostenlos. Keine Kreditkartendetails erforderlich. Ohne Risiko testen.

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.