x-lite, Fritz! Box, 1&1 und Port 5060 (Problem gelöst)

Ralf24

Neuer User
Mitglied seit
25 Okt 2004
Beiträge
83
Punkte für Reaktionen
0
Punkte
0
Meine Konfiguration:
WinXP, 1&1 mit VoIP, Router: Fritz! Box Phone wlan, wlan-usb-Sticks an den Rechnern.

Wie auch andere hier im Forum hatte ich ziemliche Probleme, diese Kombi zum Laufen zu bringen, Viele Tips anderer Forenmitglieder in vielen Beiträgen verstreut habe ich ausprobiert.
Hier nun die, die mir weitergeholfen haben:

Hintergrund:
Die Fritz! Box Phone verwendet Port 5060 für das angeschlossene (Harware)Telefon. Im Router läßt sich der Port nicht forwarden:
Einen Workaround fand ich hier im Forum: Statt Port 5060 Port 0 (richtig! Null) UDP forwarden.
Meine Versuche, alles z.B. auf Port 5061 zu legen, klappten nicht (also Sip-Proxy: sip.1und1.de:5061).

Die Protokolle zeigten, daß sowohl x-lite als auch sip.1und1.de immer wieder auf Port 5060 zugreifen wollten.

Jetzt habe ich folgende Einstellungen in x-lite:

System Settings>sip proxy:
sip.proxy und outbound proxy: sip.1und1.de (ohne! :5061)
System Settings>network:
listen sip Port: 5061
(und natürlich namen, PW etc.)

An der Fritz! Box ist Port 0 "geforwarded" (welch ein Wort!), s.o.
und natürlich die übrigen nach Liste 1&1 und zusätzlich 5061

Wenn ich mir jetzt die Protokolle ansehe passiert folgendes: Nach anfänglichen Fehlversuchen über Port 5060 einigen sich x-lite, fritz und 1&1 auf Port 5061, das geht aber recht schnell.
Solange ich versucht habe, alles auf 5061 (oder auch 5070) zu zwingen, klappte es nicht.

Da ich zusätzlich zu 1&1 auch einen web.de und freenet.de Account mit einer Software verwalten will, schied das von 1&1 mitgelieferte (mini)Sipps aus. Da geht nur 1&1 und Schluss.

Ob das nun hier die ultimative Lösung ist, kann ich nicht beurteilen, Solange es funktioniert, ist es mir auch egal.
Ich hoffe, das hilft allen mit ähnlicher Konfiguration (und den dazugehörigen Problemen) weiter.

Viele Grüße aus Kiel
Ralf
 

rollo

IPPF-Promi
Mitglied seit
5 Jul 2004
Beiträge
8,288
Punkte für Reaktionen
1
Punkte
38
Re: x-lite, Fritz! Box, 1&1 und Port 5060 (Problem gelös

Ralf24 schrieb:
Jetzt habe ich folgende Einstellungen in x-lite:

System Settings>network:
listen sip Port: 5061
Hallo Ralf,

das ist eigentlich die einzige Änderung, die an X-Lite vorgenommen werden muss. Wurde auch sicher schon hier beschrieben (Mehrere IP Telefone in einem LAN) Falls es Überschneidungen mit den RTP Ports gibt, können die in X-lite auch geändert werden. Ist aber bei der Fritz!Box nicht der Fall, die benutzt 7878 -7081.

Das Portforwarding kann sich dann auf 5061, 8000-8005 beschränken.

Wenn Du versuchst den Port beim Register Server zu ändern, kann das natürlich nicht klappen, der hört ja nur auf 5060.

jo
 

hasi999

Neuer User
Mitglied seit
8 Jan 2010
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
Ich versuche grad bei der Fritz!Box den Port "0" zu forwarden - bekomme aber eine Fehlermeldung, wonach das nicht geht. Wie schaffst Du es, in der FritzBox Port 0 zu forwarden???

Danke +
Grüße
Johannes
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,868
Beiträge
2,027,542
Mitglieder
350,982
Neuestes Mitglied
rolmor2417