.titleBar { margin-bottom: 5px!important; }

zaphfc[0] received d channel frame with bad CRC

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von xplosive, 17 Nov. 2005.

  1. xplosive

    xplosive Neuer User

    Registriert seit:
    16 Nov. 2005
    Beiträge:
    2
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!
    Bin jetzt schon die dritte nacht drauf und dran mein Asterisk zum Laufen zu bringen, habe alle möglichen Anleitungen usw. befolgt, mehrere Threads auf dem Forum genau durchgelesen, aber mein Problem konnte ich noch nicht lösen!!!! :-(
    Anfangs war der worst-case Anrufe von Aussen wurden nach einem klingeln zwar entgegengenommen, aber alles was man hören konnte war ein clicken in der Leitung(wahrscheinlich der echo-trainer oder was auch immer) nun bin ich so weit, dass ich von Aussen an das Demo von Asterisk komme, hab die extensions.conf noch nicht geändert...
    ABER: So bald ich das Kabel von meiner ACER PCI (mit zaphfc) an das ISDN-Telefon(Siemens GigaSet SX353 ISDN) bleibt die Leitung tot und das Telefon meldet am Display "Störung".
    Wenn ich ein bisschen herumdrücke und am Telefon herumprobiere krieg ich dann eine oder vielleicht zwei Meldungen die so aussehen:

    chan_zap.c:7819 pri_dchannel: PRI got event: HDLC Abort (6) on Primary D-channel of span 1

    mein Kernel gibt dann auch noch seinen Senf dazu:
    zaphfc[0]: received d channel frame with bad CRC
    zaphfc[0]: empty HDLC frame received(<- diese hier immer xMal)

    Nun zu meiner Konfiguration:
    Fritz! PCI (läuft korrekt im TE-Mode über chan_capi)
    Acer ISDN 128 Surf PCI (läuft angeblich korrekt im NT Mode, da cat /proc/zaptel/1 folgendes ausgibt:

    Span1: ZTHFC "HFC-S PCI A ISDN card 0 [NT] layer 1 ACTIVATED (G3)" AMI/CSS
    1 ZTHFC1/0/1 Clear (In use)
    2 ZTHFC1/0/2 Clear (In use)
    3 ZTHFC1/0/3 HDLCFCS (In use)
    also ok glaub ich)

    Hab für das Verbinden der Acer Karte -> Telefon eine terminierung zwischen einem gekreuzten und ungekreuzten kabel gegeben ohne Saft, also 2x100Ohm Kabellänge ist ca. 16m)

    Kann gern noch meine Konfigurationsdateien posten, sollten aber meines wissens nach 1:1 mit den meisten Fällen sein, die hier im Forum beschrieben werden!

    Bitte um Hilfe!!!!!!
     
  2. xplosive

    xplosive Neuer User

    Registriert seit:
    16 Nov. 2005
    Beiträge:
    2
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Weiss nicht wie ich das geschafft habe, aber jetzt geht alles, war möglicherweisse "nur" ein IRQ-Konflikt....
     
  3. Retoe

    Retoe Neuer User

    Registriert seit:
    19 März 2005
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo

    Ja, das mit dem IRQ Konflikt kann es gut gewesen sein. Hat mir auch einige Stunden gekostet. Hatte die selben Fehlermeldungen und auch wie du alle Punkte bei den Howto's beachtet und umgesetzt. Auf jeden fall solltest du noch sicherstellen, dass die ISDN HFC Karte immer einen eigenen IRQ zugeteilt bekommt! sonst könnte es nach einem Reboot eventuell nicht mehr laufen.

    Gruss Retoe