.titleBar { margin-bottom: 5px!important; }

ZAPHFC Compile Fehler (mit 2x HFC/SuSE 9.2)

Dieses Thema im Forum "Asterisk ISDN Allgemein" wurde erstellt von MoritzN, 17 März 2005.

  1. MoritzN

    MoritzN Neuer User

    Registriert seit:
    17 März 2005
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo *,

    Ich bin völlig am verzweifeln, schraube seit zwei vollen Tagen am *-Server rum :shock:

    Vielleicht könnt ihr mir ja helfen?

    Habe eigentlich alles von * zum Laufen gebracht, nur meine ISDN (HFC) Karten will dat Ding nicht!

    ZTCFG listet meine 2 Karten (2xB, 1xD, 2xB, 1xD), aber endet mit
    ZT_SPANCONFIG failed on span 1: No such device or address (6)

    HiSax ist nicht gestartet, und eigenartiger Weise lässt sich zaphfc nicht fehlerfrei compilen:

    insmod: error inserting './zaphfc.ko': -1 Unknown symbol in module
    (Meldung bei loadlinux26 und loadlinux26NT gleich)

    Danke an Euch alle schonmal - Ein Lösungsansatz würde mich glücklich machen !!!!!
     
  2. rannseier

    rannseier Aktives Mitglied

    Registriert seit:
    5 Mai 2004
    Beiträge:
    986
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Suse 9.2?


    MfG,
    Karl
     
  3. MoritzN

    MoritzN Neuer User

    Registriert seit:
    17 März 2005
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi Karl,

    ja Suse 9.2 - Asterisk ist installiert über (gwdg)FTP-RPM's, da nur die Download ISO.

    asterisk läuft auch ohne Probleme, wenn ich die zap-so aus der modules.conf rausnehme.

    die HFC karten werden von yast erkannt, sind konfiguriert aber nicht gestartet.
     
  4. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Kompiliere das nach der Anweisung von Jui in der FAQ. Die Suse Zap RPM's
    laufen nicht.
    Vor dem erstmaligen makeload bzw make loadNT Rechner ausschalten! Ein reboot hat nicht ausgereicht.
     
  5. jui

    jui Mitglied

    Registriert seit:
    18 Dez. 2004
    Beiträge:
    229
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Verwende die anleitung hier und nicht die aus den FAQ (die habe ich nicht mehr weitergepflegt): http://www.ip-phone-forum.de/forum/viewtopic.php?t=8983

    Bei 2 x HFC kannst du die AVM-Sachen einfach nicht beachten. die HFC werden automatisch mit make loadNT so eingebunden, dass eine KArte im TE, die andere im NT-Mode läuft. Du musst aber darauf achten, dass Du die zapata.conf und die zaptel.conf korrekt anlegst um alle B-Kanäle verfügbar zu machen und korrekt aufzuteilen. Dafür müssen diese beiden Dateien korrekt angepasst sein. Das HowTo befasst sich nur mit der grundsätzlichen Einrichtung.

    Gruß,

    Jui
     
  6. MoritzN

    MoritzN Neuer User

    Registriert seit:
    17 März 2005
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    [gelöst] ZAPHFC Compile Fehler (mit 2x HFC/SuSE 9.2)

    Danke für Eure Hilfe - Mit einem Mischmasch der HowTo's hab ich's nun hinbekommen! Super!

    Im Groben war vor Allem der SuSE-immer-geladen-Zaptel Treiber der Hauptschuldige.. Also auch die Koexistenz beider Module (SuSE und Bristuff) - Ein Löschen des SuSE Modules und ein depmod waren dann der Startschuß :)