ZAPHFC komischer sound

Kraven

Neuer User
Mitglied seit
20 Aug 2004
Beiträge
2
Punkte für Reaktionen
0
Punkte
0
Ich habe mir jetzt auch mal eine Asterisk Box eingerichtet, Sip -> Sip mit sipgate funktioniert auch sehr gut, aber, ich habe eine HFC Karte installiert um meine Tiptel 31 Home an dem Server anzuschliessen.

Und der Sound ist für PoPo....

Was mache ich falsch?!?

Ich habe einen NTBA an der Karte angeschlossen, dessen terminierung aktiviert ist. (Anleitung PBX4Linux)

Bitte helft mir.
 

rajo

Admin-Team
Mitglied seit
31 Mrz 2004
Beiträge
1,958
Punkte für Reaktionen
0
Punkte
36
Hmm... Du könntest noch verraten bei welcher Art von Telefonaten dieses Problem auftritt:

sprich, telefonierst Du von ISDN zu ISDN und es klingt schlecht, oder rufst Du von ISDN zu VoIP (oder umgekehrt) an. Falls ja, schau mal nach welche Audio-Codecs du verwendest.
Ausserdem wäre interessant, was das für ein Rechner ist.
 

allesOK

Mitglied
Mitglied seit
24 Mai 2004
Beiträge
732
Punkte für Reaktionen
0
Punkte
0
Und für uns wäre auch ein Blick in die zapata.conf interessant ...
 

schakal2k

Mitglied
Mitglied seit
16 Aug 2004
Beiträge
309
Punkte für Reaktionen
0
Punkte
16
Nachdem ich es jetzt endlich zum laufen bekommen habe, habe ich auch erhebliche Soundprobleme.

Gibts hier schon was neues?
 

nc2001

Neuer User
Mitglied seit
29 Jul 2004
Beiträge
134
Punkte für Reaktionen
0
Punkte
0
Bitte mal etwas konkretisieren, was genau heisst Soundprobleme? Beim Sender, beim Empfänger oder bei beiden?
 

schakal2k

Mitglied
Mitglied seit
16 Aug 2004
Beiträge
309
Punkte für Reaktionen
0
Punkte
16
Mal ganz von vorne...

Folgendes Problem:

Wenn ich den Hörer meines ISDN-Telefons (welches mit einem NTBA an dem * hängt) abnehme, bekomme ich die Demo voregespielt. (Das ist noch nicht das Problem...)

Der Sound klingt irgendwie verzerrt. Es klingt nach einer Männerstimme, obwohl es eine Frauenstimme ist. Das Freizeichen klingt auch eher nach einem kranken Rauschen.

Selbiges passiert wenn ich (vor dem abnehmen des Hörers) die Sipgate-Testnummer 10000 wähle.

ABER ! :

Sobald ich mich am KDE (oder Gnome) anmlede und, nach dem er alles geladen hat, die Maus ständig bewege, ist die Qualität einwandfrei.

:?: :?: :?: :?: :?:

ALSO:

Sobald der Rechner auch nur ein kleines bißchen nebenbei belastet ist, ist die Qualität gut, sonst nicht...

Allerdings ist der Sound von meinem SIPPS irgendwie verstümmelt. Nun weiß ich nicht, ob es das gleiche Phänomen ist, oder ob das wieder was anderes ist... (Ich hatte bisher noch keine Lust mein Notebook mit in meinen Serverraum zu nehmen, wollte ich morgen machen...)

Ich hoffe, ihr könnt mir helfen...

PS: Linux ist Fedora Core 2 mit 2.6.6er Kernel
 

nc2001

Neuer User
Mitglied seit
29 Jul 2004
Beiträge
134
Punkte für Reaktionen
0
Punkte
0
Hmm. Komisch. Das hört sich ja fast so an, als sei dein Rechner mit Asterisk irgendwie überlastet. Hast du dir mal die CPU-Auslastung o.ä. angeschaut? Bringt evtl. ein Reload von Asterisk (nach dem das restliche System komplett geladen hat) etwas?
 

schakal2k

Mitglied
Mitglied seit
16 Aug 2004
Beiträge
309
Punkte für Reaktionen
0
Punkte
16
nc2001 schrieb:
Hmm. Komisch. Das hört sich ja fast so an, als sei dein Rechner mit Asterisk irgendwie überlastet. Hast du dir mal die CPU-Auslastung o.ä. angeschaut?
...
Ich denke eher, er ist unterfordert, denn es läuft ja nur, wenn ich nebenbei etwas mache...

Ausgelastet ist er kaum, aber wie gesagt, wenn er nebenbei was macht, dann gehts ja...

nc2001 schrieb:
...
Bringt evtl. ein Reload von Asterisk (nach dem das restliche System komplett geladen hat) etwas?
Nö. Ändert nichts dran.
 

Raffi

Neuer User
Mitglied seit
25 Jul 2004
Beiträge
179
Punkte für Reaktionen
0
Punkte
16
Am besten Du guckst mal mit lspci -v ob die ISDN Karte sich den Interrupt mit einer anderen Karte teilt. Ggf. dann Karte in andern PCI Slot steken oder im Bios einen andren Interrupt zuordnen.

Raffi
 

schakal2k

Mitglied
Mitglied seit
16 Aug 2004
Beiträge
309
Punkte für Reaktionen
0
Punkte
16
lspci -v sagt mir folgendes:

Code:
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
        Flags: bus master, medium devsel, latency 64
        Memory at e4000000 (32-bit, prefetchable)
        Capabilities: [a0] AGP version 1.0

00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
        Memory behind bridge: e1800000-e2dfffff
        Prefetchable memory behind bridge: e2f00000-e3ffffff

00:04.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
        Flags: bus master, medium devsel, latency 0

00:04.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01) (prog-if 80 [Master])
        Flags: bus master, medium devsel, latency 32
        I/O ports at d800 [size=16]

00:04.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01) (prog-if 00 [UHCI])
        Flags: bus master, medium devsel, latency 32, IRQ 9
        I/O ports at d400 [size=32]

00:04.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
        Flags: medium devsel, IRQ 9

00:09.0 Network controller: Asustek Computer, Inc. ISDNLink P-IN100-ST-D (rev 02)
        Subsystem: Dynalink: Unknown device 1704
        Flags: bus master, medium devsel, latency 16, IRQ 9
        I/O ports at d000 [disabled]
        Memory at e1000000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [40] Power Management version 1

00:0a.0 Network controller: AVM Audiovisuelles MKTG & Computer System GmbH A1 ISDN [Fritz] (rev 02)
        Subsystem: AVM Audiovisuelles MKTG & Computer System GmbH FRITZ!Card ISDN Controller
        Flags: medium devsel, IRQ 5
        Memory at e0800000 (32-bit, non-prefetchable)
        I/O ports at b800 [size=32]

00:0b.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 30)
        Subsystem: 3Com Corporation 3C905B Fast Etherlink XL 10/100
        Flags: bus master, medium devsel, latency 32, IRQ 10
        I/O ports at b400
        Memory at e0000000 (32-bit, non-prefetchable) [size=128]
        Capabilities: [dc] Power Management version 1

01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA 2164W [Millennium II] AGP (prog-if 00 [VGA])
        Subsystem: Matrox Graphics, Inc.: Unknown device 2100
        Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
        Memory at e3000000 (32-bit, prefetchable) [size=e2ff0000]
        Memory at e2000000 (32-bit, non-prefetchable) [size=16K]
        Memory at e1800000 (32-bit, non-prefetchable) [size=8M]
        Expansion ROM at 00010000 [disabled]
        Capabilities: [f0] AGP version 1.0
Gibts da Probleme mit der PCI-Bridge und USB?

Und was soll mir "I/O ports at d000 [disabled]" sagen?
 

Raffi

Neuer User
Mitglied seit
25 Jul 2004
Beiträge
179
Punkte für Reaktionen
0
Punkte
16
"I/O Ports disabled" ist schon in Ordnung. Allerdings liegt der USB Controller und die ISDN Karte auf einem Interrupt. Das solltest Du ändern. Meisstens kann man im BIOS die Interrupts pro PCI Slot einstellen. Mußt mal gucken. Vielleicht einen von den paralelen Schn. nehmen (5/7).

Oder, falls möglich, ACPI aktivieren.

Raffi
 

schakal2k

Mitglied
Mitglied seit
16 Aug 2004
Beiträge
309
Punkte für Reaktionen
0
Punkte
16
ACPI wird mir beim booten (in /var/log/messages) gesagt, dass mein Rechner zu alt ist.

Kann ich nicht auch einfach USB deaktivieren? Ich brauch es ja sowieso bei dem Rechner nicht...
 

Raffi

Neuer User
Mitglied seit
25 Jul 2004
Beiträge
179
Punkte für Reaktionen
0
Punkte
16
Oder so ;-)

Raffi
 

allesOK

Mitglied
Mitglied seit
24 Mai 2004
Beiträge
732
Punkte für Reaktionen
0
Punkte
0
Wie deaktiviert man das denn? (Knoppix 3.4)
 

Raffi

Neuer User
Mitglied seit
25 Jul 2004
Beiträge
179
Punkte für Reaktionen
0
Punkte
16
USB? Im Bios Setup.

Raffi
 

schakal2k

Mitglied
Mitglied seit
16 Aug 2004
Beiträge
309
Punkte für Reaktionen
0
Punkte
16
Raffi schrieb:
USB? Im Bios Setup.

Raffi
Dachte ich auch, aber mit lspci -v wird es noch immer angezeigt. Das Problem besteht auch immer noch. Ich hab sogar ein BIOS-Update durchgeführt...

Egal welchen IRQ ich der Karte (bzw. dem Slot) gebe, der USB und die PCI-Bridge nimmt den selben...

Auch umstecken bringt nichts...

Langsam werde ich irre.


EDIT:

Hab grade folgendes gefunden:

Bei Intel Chipsätzen mit PIIX4/4e lässt sich der USB Controller nicht
deaktivieren. Das geht schon vom Chipsatz her nicht. Deshalb wird er
auch immer als PCI Device auf dem PCI Bus sichtbar sein, und alle BIOSs
für diese Boards haben keine Setup-Einstellung "USB Controller: Enabled/
Disabled".
Misst...

Kann man nicht irgendwie die Treiber im Linux deaktivieren?

Aber warum belegt er den gleichen IRQ wie die HFC-Karte???


EDIT2:

Hab da was gefunden:

INT A INT B INT C INT D
PCI 1 / AGP PCI 2 PCI 3 / (PCI 6) PCI 4 / PCI 5 / USB
Ich werde nochmal ein paar andere Slots testen...


EDIT3:

Macht die Netzwerkkarte Probleme, wenn ich sie zusammen mit USB lege?
 

schakal2k

Mitglied
Mitglied seit
16 Aug 2004
Beiträge
309
Punkte für Reaktionen
0
Punkte
16
Es lag nicht an den IRQ's.

Das Problem besteht noch immer!!!

So langsam weiss ich nicht mehr weiter...

EDIT:

An der nicht-vorhandenen Soundkarte kann das doch wohl nciht liegen, oder?
 

Raffi

Neuer User
Mitglied seit
25 Jul 2004
Beiträge
179
Punkte für Reaktionen
0
Punkte
16
Hmmm. Blöd. Nein, an der nicht vorhanden Soundkarte liegt's nicht. Hab ich hier auch schon in Rechnern ohne Soundkarte. Ich halte aber noch an meiner IRQ Theorie fest ;-) Kannst Du mal Deine /var/log/kern.log posten?

Raffi
 

schakal2k

Mitglied
Mitglied seit
16 Aug 2004
Beiträge
309
Punkte für Reaktionen
0
Punkte
16
Raffi schrieb:
Hmmm. Blöd. Nein, an der nicht vorhanden Soundkarte liegt's nicht. Hab ich hier auch schon in Rechnern ohne Soundkarte. Ich halte aber noch an meiner IRQ Theorie fest ;-) Kannst Du mal Deine /var/log/kern.log posten?

Raffi
Ähm, ich hab keine kern.log im Verzeichnis /var/log/

:?: :?: :?:

EDIT:

Meine aktuelle lspci -v Ausgabe:

Code:
lspci -v
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
        Subsystem: Asustek Computer, Inc.: Unknown device 8024
        Flags: bus master, medium devsel, latency 64
        Memory at e4000000 (32-bit, prefetchable)
        Capabilities: [a0] AGP version 1.0

00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
        Memory behind bridge: e1800000-e2dfffff
        Prefetchable memory behind bridge: e2f00000-e3ffffff

00:04.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
        Flags: bus master, medium devsel, latency 0

00:04.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01) (prog-if 80 [Master])
        Flags: bus master, medium devsel, latency 32
        I/O ports at d800 [size=16]

00:04.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01) (prog-if 00 [UHCI])
        Flags: bus master, medium devsel, latency 32, IRQ 9
        I/O ports at d400 [size=32]

00:04.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
        Flags: medium devsel, IRQ 9

00:09.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 30)
        Subsystem: 3Com Corporation 3C905B Fast Etherlink XL 10/100
        Flags: bus master, medium devsel, latency 32, IRQ 9
        I/O ports at d000
        Memory at e1000000 (32-bit, non-prefetchable) [size=128]
        Capabilities: [dc] Power Management version 1

00:0a.0 Network controller: AVM Audiovisuelles MKTG & Computer System GmbH A1 ISDN [Fritz] (rev 02)
        Subsystem: AVM Audiovisuelles MKTG & Computer System GmbH FRITZ!Card ISDN Controller
        Flags: medium devsel, IRQ 5
        Memory at e0800000 (32-bit, non-prefetchable)
        I/O ports at b800 [size=32]

00:0b.0 Network controller: Asustek Computer, Inc. ISDNLink P-IN100-ST-D (rev 02)
        Subsystem: Dynalink: Unknown device 1704
        Flags: bus master, medium devsel, latency 16, IRQ 10
        I/O ports at b400
        Memory at e0000000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [40] Power Management version 1

01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA 2164W [Millennium II] AGP (prog-if 00 [VGA])
        Subsystem: Matrox Graphics, Inc.: Unknown device 2100
        Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
        Memory at e3000000 (32-bit, prefetchable) [size=e2ff0000]
        Memory at e2000000 (32-bit, non-prefetchable) [size=16K]
        Memory at e1800000 (32-bit, non-prefetchable) [size=8M]
        Expansion ROM at 00010000 [disabled]
        Capabilities: [f0] AGP version 1.0
 

Raffi

Neuer User
Mitglied seit
25 Jul 2004
Beiträge
179
Punkte für Reaktionen
0
Punkte
16
Das Logfile in dem Du die Meldungen findest, die Linux Dir beim Booten anzeigt. Wie gesagt, ich kenne Fedora nicht, sollte aber boot.log, kern.log oder so ähnlich heissen.

Raffi
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,917
Beiträge
2,028,134
Mitglieder
351,074
Neuestes Mitglied
HolgerFri