.titleBar { margin-bottom: 5px!important; }

Zaptel bristuff : 0 channels configured.

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von DerDominic, 1 Dez. 2004.

  1. DerDominic

    DerDominic Neuer User

    Registriert seit:
    1 Dez. 2004
    Beiträge:
    151
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Dipl. Ing. tI
    Ort:
    Quierschied
    Hallo zusammen,

    habe dann am Wochenende meine * augefestezt (angefangen)....
    Leider habe ich mir meiner Conceptronic HFC-Karte und bri-stuff.0.1.0-RC4a
    arge Probeleme.
    Nach make loadNT bekomme ich dann folgendens :

    cellar:/usr/src/bri-stuff.0.1.0-RC4a/zaphfc# make loadNT
    sync
    modprobe zaptel
    insmod ./zaphfc.o modes=1
    ztcfg -v

    Zaptel Configuration
    ======================


    0 channels configured.

    cellar:/usr/src/bri-stuff.0.1.0-RC4a/zaphfc#

    Ein asterix -vvvvc bringt :


    [chan_zap.so] => (Zapata Telephony w/PRI)
    == Parsing '/etc/asterisk/zapata.conf': Found
    Dec 1 12:11:50 WARNING[16384]: chan_zap.c:778 zt_open: Unable to specify channel 1: No such device or address
    Dec 1 12:11:50 ERROR[16384]: chan_zap.c:5969 mkintf: Unable to open channel 1: No such device or address
    here = 0, tmp->channel = 1, channel = 1
    Dec 1 12:11:50 ERROR[16384]: chan_zap.c:9478 setup_zap: Unable to register channel '1-2'
    Dec 1 12:11:50 WARNING[16384]: loader.c:328 ast_load_resource: chan_zap.so: load_module failed, returning -1
    == Unregistered channel type 'Tor'
    == Unregistered channel type 'Zap'
    Dec 1 12:11:50 WARNING[16384]: loader.c:423 load_modules: Loading module chan_zap.so failed!
    cellar:/etc/asterisk#


    Zapata.conf :
    [general]

    driver=i4l

    [channels]
    ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
    ;NT-Card external s0
    switchtype = euroisdn
    signalling = bri_net_ptmp
    pridialplan = local
    prilocaldialplan = local
    echocancel = yes
    overlapdial = no
    echocancelwhenbridged=no
    echotraining=no
    immediate = no
    usecallerid = yes
    group = 1
    context = isdn2out
    channel => 1-2
    usecallingpres=yes
    nationalprefix = 0
    internationalprefix = 00

    zaptel.conf
    loadzone=nl
    defaultzone=nl

    span=1,1,3,ccs,ami
    bchan=1-2
    dchan=3


    Hat da irgeneiner eine Idee dazu ?

    Danke fürs zuhören
    Dominic
     
  2. DerDominic

    DerDominic Neuer User

    Registriert seit:
    1 Dez. 2004
    Beiträge:
    151
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Dipl. Ing. tI
    Ort:
    Quierschied
    So, damit nicht andere auch noch so suchen müßen....

    So ein Drecksding, der nimmt sich die zaptel.conf standardmässig aus /etc, nicht aus /etc/asterisk.

    Nun schaut es besser aus......
     
  3. rajo

    rajo Admin-Team

    Registriert seit:
    31 März 2004
    Beiträge:
    1,958
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    hehe :)
    jupp /etc/zaptel.conf <- konfiguriert den Treiber/Hardware unter linux, daher in /etc
    /etc/asterisk/zapata.conf <- konfiguriert dann den Rest (rufnummern etc)
     
  4. Pirx

    Pirx Neuer User

    Registriert seit:
    26 Mai 2004
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hallo,
    der vollständigkeit halber: man kann ztcfg auch mittels der option "-c <zaptel.conf>" dazu überrreden, eine andere config zu nehmen. afaik funktioniert das nur mit absoluten pfaden, aber dann gut.
    für alle die, die das makefile zwar nett finden, aber gern auch selbst hand anlegen
    bye