.titleBar { margin-bottom: 5px!important; }

7170 / FW 29.04.21, bekomme debug.cfg nicht ausgefuehrt

Dieses Thema im Forum "FRITZ!Box Fon: Modifikationen" wurde erstellt von flunki, 18 Nov. 2006.

  1. flunki

    flunki Neuer User

    Registriert seit:
    13 Nov. 2006
    Beiträge:
    104
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bitte lasst mich nicht dumm sterben . . .

    Bin (immer noch) dran bftpd und openvpn ans Laufen zu bringen. Manuell klappt das auch alles soweit. Nur wenn ich es ueber die debug.cfg starten moechte passiert rein garnix.

    Vorgehensweise im Moment wie folgt:
    - 7170 auf 29.04.21 recovered
    - #96*7* fuer Telnetzugang
    - cd /var/tmp
    - wget http://www.tecchannel.de/download/432803/bftpd.conf
    - wget http://www.tecchannel.de/download/432803/bftpd
    - chmod +x bftpd
    - echo "user:passwort:0:0:/root:/var:Null" >> /var/tmp/passwd
    (im passwd sind schon default-user fuer den ftp-zugang drin. Ich vermute fuer den USB)
    - ./bftpd -d -c /var/tmp/bftpd.conf

    Dann per ftp untenstehende debug.cfg nach /var/tmp und mit cp/var/tmp/debug.cfg /var/flash/debug.cfg kopiert

    Das hat schon mal auf einer gemoddeten FW funktioniert

    Was mach ich denn falsch ?
    Es wird weder bftpd noch openvpn bei einem reboot geladen.

    danke im Voraus
    Gruss Frank

    QOUTE
    debug.cfg
    # 180 Sekunden warten
    sleep 180

    #Pruefen ob Internet da ist
    while !(ping -c 1 www.tecchannel.de); do
    sleep 10
    done

    cd /var/tmp
    #Files holen
    wget http://www.tecchannel.de/download/432803/bftpd.conf
    wget http://www.tecchannel.de/download/432803/bftpd
    chmod +x bftpd
    echo "user:passwort:0:0:/root:/var:Null" >> /var/tmp/passwd
    ./bftpd -d -c /var/tmp/bftpd.conf

    # load VPN-Server (OpenVPN)
    # wait for server
    while !(ping -c 1 fritzbox.the-construct.com)
    do
    sleep 5
    done

    # change dir
    cd /var/tmp

    # write 'secret.key' to file
    cat > /var/tmp/secret.key << 'ENDSECRETKEY'
    #
    # 2048 bit OpenVPN static key
    #
    -----BEGIN OpenVPN Static key V1-----
    da steht er key . . .
    -----END OpenVPN Static key V1-----
    ENDSECRETKEY

    wget http://fritzbox.the-construct.com/files/openvpn/openvpn
    wget http://fritzbox.the-construct.com/files/openvpn/server.ovpn

    chmod +x /var/tmp/openvpn
    chmod 0600 /var/tmp/server.ovpn
    chmod 0600 /var/tmp/secret.key

    ./openvpn --config ./server.ovpn
    # Ende
    UNQOUTE
     
  2. Duff

    Duff Neuer User

    Registriert seit:
    18 Juni 2005
    Beiträge:
    157
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Soweit ich das richtig verstehe, muss man für openvpn auch noch das Portforwarding einstellen. Hast du dass auch schon gemacht?

    Und vorallem musst du dazu vorher mal in die server.ovpn schauen, damit du weißt ob du udp oder tcp nehmen musst.
     
  3. flunki

    flunki Neuer User

    Registriert seit:
    13 Nov. 2006
    Beiträge:
    104
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Naja, der OpenVPN-Prozess startet nicht mal, wenn ich nur wuesste warum . . .
    Das der einen Port mit Loch in der Firewall braucht und Forwarding ist klar, ich lerne Schritt fuer Schritt.

    Inzwischen habe ich gerausgefunden das mir die debug.cfg scheinbar ich beim ping "haengenbleibt" (PS zeigt mit abwechselnd ping und sleep an). Ich halte das fuer ein DNS-Problemchen meinerseits . . .

    Also das ganze umgestrickt auf einen USB-Memory-Stick.

    Da brauche ich dann auch keinen bftp da der ftpd ja laeuft. War aber nix da der erst spaet gemountet wird und die debug.cfg da scheinbar schon "rum" ist.

    Vielleicht hat noch jemand einen Tipp wie ich hinbekomme das:

    - die debug.cfg (oder ein entsprechendes script) erst laeuft wenn ftpd aktiv ist
    oder
    - die Ausfuehrung von Befehlen in der debug.cfg um 2 Minuten verzoegert werden kann (sleep 120 als erste Zeile tut es nicht . . . ich bin jedoch noch blutiger Anfaenger)

    Danke im Voraus
    Gruss Frank
     
  4. Duff

    Duff Neuer User

    Registriert seit:
    18 Juni 2005
    Beiträge:
    157
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Wie sieht denn die Konfig-Datei aus, die openvpn beim Starten laden soll?

    Ich hatte z.B. dort einen Fehler drin, und deshalb wollte der Prozess erst gar nicht starten.
     
  5. flunki

    flunki Neuer User

    Registriert seit:
    13 Nov. 2006
    Beiträge:
    104
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke duer die rasche Antwort.

    Dieselben Parameter auf der Console (mit cut/paste) eingegeben fuehren zum Erfolg. Daher gehe ich davon aus = alles OK udn somit nur ein Problem von zu fruehem ausfuehren.

    Da das passwort nicht angefuegt wird (auch wenn ich es in die erste Zeile nehme) gehe ich davon aus das debug.cfg "zu frueh" laeuft . . .
     
  6. Duff

    Duff Neuer User

    Registriert seit:
    18 Juni 2005
    Beiträge:
    157
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Heißt das jetzt, dass dein openvpn sauber läuft bzw. dass du eine Verbindung von deinem Rechner über Inernet auf die Box herstellen konntest?
     
  7. SkyMaster

    SkyMaster Neuer User

    Registriert seit:
    1 Dez. 2005
    Beiträge:
    52
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi, ich bin kein Fachmann, aber möchte trozden mal was dzusagen (ohne zu wissen ob es richtig ist :)

    Du schreibst das du die Debug.cfg per CP vom /var/tmp nach /var/flash kkopierst.
    Mir wurde mal gesagt, das man das nicht machen darf (warum auch immer)
    Mir wurde gesagt, das man es mit den Befhel CAT übertragen muss !
    CAT /var/tmp/debug.cfg > /var/flash/debug.cfg

    und was mir selber nun schon passiert ist, bit due wirklich 100% sicher das Die debug.cfg kein Windows-Zeichen enthält? (was ja nicht sofort sichtbar ist)
    oder ist es zu 100% mit ein Linux-Editor gemacht worden ?

    gruß
    Andy
     
  8. flunki

    flunki Neuer User

    Registriert seit:
    13 Nov. 2006
    Beiträge:
    104
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #8 flunki, 21 Nov. 2006
    Zuletzt bearbeitet: 21 Nov. 2006
    100 Mal gelesen und doch passierts

    Ja-ja, die CR+LF. Ist mir die debug.cfg doch mal in einen falschen Editor gerutscht . . . NVI zeigt dann schoen am Zeilenende Crtl+M an. Das wars, nun laeufts.

    OpenVPN ist nun zwischen PC-7170 am Laufen, nun muss ich noch das Routing gerade ziehen. Die Files hole ich mir vom USB-Stick . . .

    debug.cfg mit cp ins /var/flash klappt bei mir problemlos . . .

    Kurzanleitung:
    #96*7* = telnet ein
    echo "user:passwort:0:0:/root:/var:Null" >> /var/tmp/passwd = user/password fuer FTP anlegen

    debug.cfg per ftp nach /var/tmp, Inhalt wie folgt:

    # Datei debug.cfg
    echo "user:passwort:0:0:/root:/var:Null" >> /var/tmp/passwd
    sleep 15

    cd /var/tmp
    wget ftp://IP-der-box/Der-Partitionsname-des-Sticks/openvpn
    wget ftp://192.168.0.250/TransMemory-Partition-0-1/server.ovpn
    wget ftp://192.168.0.250/TransMemory-Partition-0-1/secret.key

    chmod +x openvpn
    chmod 0600 secret.key
    chmod 0600 server.ovpn

    ./openvpn --config /var/tmp/server.ovpn
    #Ende

    Der USB-Stick laesst sich ueber /var/media/ftp/ . . . vom PC laden.

    Gruss Frank