.titleBar { margin-bottom: 5px!important; }

A@H 1.5 Registrierungsproblem mit "backbone.ch-Account&

Dieses Thema im Forum "FreePBX, TrixBox (Asterisk@Home)" wurde erstellt von Scharlie, 5 Okt. 2005.

  1. Scharlie

    Scharlie Neuer User

    Registriert seit:
    27 Juni 2005
    Beiträge:
    19
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Zusammen

    Ich habe die A@H Version 1.5 installiert.
    Also ITSP verwende ich backbone.ch, die Sipcall.ch-Accounts lauffen auch über diesen Provider.

    Bei der Registierung im Webinterface des ITSP steht bei mir: sip:s@195.141.xxx.xxx

    Ich weiss nicht wie dieses komische "s" statt meine SIP-Nummer in die Registierung kommt!?!?!
    Es ist also auch klar, dass die Incoming-Calls nicht an meine Nummer geroutet werden können.
    Mit dem Eintrag "s" funktionieren natürlich keine Gespräche.
    Outgoing-Calls funktionieren ohne Probleme und es wird auch die Richtige Nummer angezeit.

    Hier noch meine Outgoing- und Incoming Settings
    Outgoing: (Trunk Name: voipgateway.org)
    allow=alaw&ulaw
    disallow=all
    fromdomain=voipgateway.org
    fromuser=4181511xxxx
    host=212.117.200.148
    insecure=very
    secret=*******
    type=peer
    username=4181511xxxx

    Incoming: (USER Context: 4181511xxxx)
    canreinvite=no
    context=from-pstn
    fromuser=4181511xxxx
    insecure=very
    qualify=no
    secret=********
    type=user
    username=4181511xxxx

    Registration:
    4181511xxxx:********@voipgateway.org

    Ich hoffe jemand hat eine Idee.

    Gruss
     
  2. cmmehl

    cmmehl Aktives Mitglied

    Registriert seit:
    15 Juni 2004
    Beiträge:
    812
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    kleinschreiber
    Ort:
    Derzeit im Irak
    Ich benutze *@home zwar nicht mehr und erinnere mich auch nicht an alle details, aber mir fallen so auf anhieb zwei sachen ein:

    1 - probier mal als registrierungs-string:
    4181511xxxx:********@voipgateway.org/4181511xxxx

    2 - hast du eine DID route fuer die nummer definiert? Ohne das funktioniert beim *@home kein eingehender anruf.

    Ansonsten mal im CLI das verbose auf 5 oder hoeher setzen und beobachten, was im asterisk passiert, wenn du deine nummer anrufst.

    Hoffe, das hilft dir weiter.

    Gruss
    Chris
     
  3. Scharlie

    Scharlie Neuer User

    Registriert seit:
    27 Juni 2005
    Beiträge:
    19
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Chris

    Danke für deine schnellen Ideen.

    1)
    Die Registrierung mit /4181511xxxx hat jetzt geklappt. Im Web-Interface vom ITSP bin ich jetzt richtig registriert.
    Wobei sonst noch der Port nach der IP-Adresse stehen sollte!?!

    2)
    Ich habe eine jetzt eine DID-Route mit der nummer 4181511xxxx auf eine Extension gesetzt.

    Leider ist mein Problem von Incoming-Calls noch nicht gelöst.
    Ich habe mal einen Anruf von Aussen im CLI gedebugt. Verbose habe ich auf 5 gesetzt.
    Hier der betreffende Ausschnitt

    Code:
    *************************************************
    *                                               *
    *Anruf von 081286yyyy auf Asterisk 081511xxxx   *
    *                                               *
    *************************************************
    
    asterisk1*CLI>
    asterisk1*CLI>
    asterisk1*CLI>
    
    Sip read:
    INVITE sip:4181511xxxx@195.141.xxx.xxx SIP/2.0
    Record-Route: <sip:212.117.200.148;ftag=67f97b46422a5263aed724736b015787;lr>
    Via: SIP/2.0/UDP 212.117.200.148;branch=z9hG4bKb037.e64d41431f3781a4a03cbc9a69e4f385.0
    Via: SIP/2.0/UDP 212.117.200.148:5061;branch=z9hG4bK698fa74d294cbca639f1c27c56ae5dec;rport=5061
    Max-Forwards: 16
    From: "voip 64" <sip:081286yyyy@212.117.200.148>;tag=67f97b46422a5263aed724736b015787
    To: <sip:4181511xxxx@212.117.200.148>
    Call-ID: 9DF882FE-0629-4350-AF9F-D8401B0718A5@192.168.1.247
    CSeq: 200 INVITE
    Contact: Anonymous <sip:212.117.200.148:5061>
    Expires: 300
    User-Agent: Sippy
    cisco-GUID: 520712110-3531469579-4043462693-1974278539
    h323-conf-id: 520712110-3531469579-4043462693-1974278539
    Content-Length: 371
    Content-Type: application/sdp
    
    v=0
    o=419981286yyyy 5815640 5815656 IN IP4 192.168.1.247
    s=X-Lite
    c=IN IP4 212.117.200.148
    t=0 0
    m=audio 39012 RTP/AVP 0 8 3 98 97 101
    a=rtpmap:0 pcmu/8000
    a=rtpmap:8 pcma/8000
    a=rtpmap:3 gsm/8000
    a=rtpmap:98 iLBC/8000
    a=rtpmap:97 speex/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-15
    a=direction:active
    a=oldmediaip:192.168.1.247
    a=nortpproxy:yes
    
    16 headers, 16 lines
    Using latest request as basis request
    Sending to 212.117.200.148 : 5060 (non-NAT)
    Found peer 'voipgateway'
    Found RTP audio format 0
    Found RTP audio format 8
    Found RTP audio format 3
    Found RTP audio format 98
    Found RTP audio format 97
    Found RTP audio format 101
    Peer audio RTP is at port 212.117.200.148:39012
    Found description format pcmu
    Found description format pcma
    Found description format gsm
    Found description format iLBC
    Found description format speex
    Found description format telephone-event
    Capabilities: us - 0xc (ulaw|alaw), peer - audio=0x60e (gsm|ulaw|alaw|speex|ilbc)/video=0x0 (nothing), combined - 0xc (ulaw|alaw)
    Non-codec capabilities: us - 0x1 (g723), peer - 0x1 (g723), combined - 0x1 (g723)
    Looking for 4181511xxxx in from-sip-external
    list_route: hop: <sip:212.117.200.148;ftag=67f97b46422a5263aed724736b015787;lr>
    list_route: hop: <sip:212.117.200.148:5061>
    Transmitting (no NAT):
    SIP/2.0 100 Trying
    Via: SIP/2.0/UDP 212.117.200.148;branch=z9hG4bKb037.e64d41431f3781a4a03cbc9a69e4f385.0
    Via: SIP/2.0/UDP 212.117.200.148:5061;branch=z9hG4bK698fa74d294cbca639f1c27c56ae5dec
    From: "voip 64" <sip:081286yyyy@212.117.200.148>;tag=67f97b46422a5263aed724736b015787
    To: <sip:4181511xxxx@212.117.200.148>
    Call-ID: 9DF882FE-0629-4350-AF9F-D8401B0718A5@192.168.1.247
    CSeq: 200 INVITE
    User-Agent: kuba
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER
    Contact: <sip:4181511xxxx@195.141.xxx.xxx>
    Content-Length: 0
    
    
     to 212.117.200.148:5060
        -- Executing AbsoluteTimeout("SIP/4181511xxxx-0e19", "15") in new stack
        -- Set Absolute Timeout to 15
        -- Executing Congestion("SIP/4181511xxxx-0e19", "") in new stack
    Transmitting (no NAT):
    SIP/2.0 503 Service Unavailable
    Via: SIP/2.0/UDP 212.117.200.148;branch=z9hG4bKb037.e64d41431f3781a4a03cbc9a69e4f385.0
    Via: SIP/2.0/UDP 212.117.200.148:5061;branch=z9hG4bK698fa74d294cbca639f1c27c56ae5dec
    From: "voip 64" <sip:081286yyyy@212.117.200.148>;tag=67f97b46422a5263aed724736b015787
    To: <sip:4181511xxxx@212.117.200.148>;tag=as71ee09f5
    Call-ID: 9DF882FE-0629-4350-AF9F-D8401B0718A5@192.168.1.247
    CSeq: 200 INVITE
    User-Agent: kuba
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER
    Contact: <sip:4181511xxxx@195.141.xxx.xxx>
    Content-Length: 0
    
    
     to 212.117.200.148:5060
        -- Executing AbsoluteTimeout("SIP/4181511xxxx-0e19", "15") in new stack
        -- Set Absolute Timeout to 15
        -- Executing Congestion("SIP/4181511xxxx-0e19", "") in new stack
    asterisk1*CLI>
    
    Sip read:
    ACK sip:4181511xxxx@195.141.xxx.xxx SIP/2.0
    Via: SIP/2.0/UDP 212.117.200.148;branch=z9hG4bKb037.e64d41431f3781a4a03cbc9a69e4f385.0
    From: "voip 64" <sip:081286yyyy@212.117.200.148>;tag=67f97b46422a5263aed724736b015787
    Call-ID: 9DF882FE-0629-4350-AF9F-D8401B0718A5@192.168.1.247
    To: <sip:4181511xxxx@212.117.200.148>;tag=as71ee09f5
    CSeq: 200 ACK
    User-Agent: Sip EXpress router (0.9.0 (i386/freebsd))
    Content-Length: 0
    
    
    8 headers, 0 lines
    Destroying call '9DF882FE-0629-4350-AF9F-D8401B0718A5@192.168.1.247'
    asterisk1*CLI>
    asterisk1*CLI>
    
    Die IP-Adresse 212.117.200.148 ist die von ITSP.
    Das Gespräch wird zwar an die richtige Nummer, aber mit der falschen IP-Adresse geschickt. Oder sehe ich das flasch?

    Hast du noch weitere Ideen?

    Gruss
     
  4. cmmehl

    cmmehl Aktives Mitglied

    Registriert seit:
    15 Juni 2004
    Beiträge:
    812
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    kleinschreiber
    Ort:
    Derzeit im Irak
    Sieht mir nach einem NAT problem aus. Hast du eine feste IP adresse? Was fuer einen router? Und poste doch mal deine sip.conf

    Gruss
    Chris

    P.S.: signaturen sind sehr hilfreich ....
     
  5. Scharlie

    Scharlie Neuer User

    Registriert seit:
    27 Juni 2005
    Beiträge:
    19
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Chris

    Ich habe eine feste IP-Adresse. Der Asterisk-Server steht hinter einer Firewall. Wobei alle Ports frei geschaltet sind.
    Was das genau für eine Firewall ist, weiss ich nicht. Ich mache diese Asterisk-Versuche im Geschäft und kenne
    deshalb nicht alle Komponenten. Sind eine IT-Firma.

    Der ITSP gibt nach meiner Meinung, seine eigene IP-Adresse mit der SIP-Meldung mit.
    In der Contact Zeile steht die Nummer mit der richtigen IP-Adresse.

    Signaturen sind sicher super. Probiere aber für das Geschäft immer wieder neue Sachen aus.
    Wird schwierig, wenn man jedesmal die Signatur abändern muss.
    Sobald ich privat auch ausgerüstet bin, folgt meine Signatur.
    :)

    Hier meine sip.conf:

    Code:
    ***********************
    *                     *
    *sip.conf             *
    *                     *
    ***********************
    
    ; Note: If your SIP devices are behind a NAT and your Asterisk
    ;  server isn't, try adding "nat=1" to each peer definition to
    ;  solve translation problems.
    
    [general]
    
    port = 5060           ; Port to bind to (SIP is 5060)
    bindaddr = 0.0.0.0    ; Address to bind to (all addresses on machine)
    disallow=all
    allow=ulaw
    allow=alaw
    context = from-sip-external ; Send unknown SIP callers to this context
    callerid = Unknown
    nat=yes
    useragent = kuba
    
    #include sip_nat.conf
    #include sip_custom.conf
    #include sip_additional.conf
    
    
    sip_nat.conf und sip_custom.conf sind nicht vorhanden
    
    sip_additional.conf
    ********************
    register=4181511xxxx:password@voipgateway.org/4181511xxxx
    
    [203]
    username=203
    type=friend
    secret=203
    record_out=On-Demand
    record_in=On-Demand
    qualify=no
    port=5060
    nat=never
    mailbox=203@default
    host=dynamic
    dtmfmode=rfc2833
    context=from-internal
    canreinvite=no
    callerid="Heinzer" <203>
    
    [300]
    username=300
    type=friend
    secret=300
    record_out=On-Demand
    record_in=On-Demand
    qualify=no
    port=5060
    nat=yes
    mailbox=300@default
    host=dynamic
    dtmfmode=rfc2833
    context=from-internal
    canreinvite=no
    callerid="Alpiger" <300>
    
    [4181511xxxx]
    username=4181511xxxx
    type=user
    secret=password
    qualify=no
    insecure=very
    fromuser=4181511xxxx
    context=from-pstn
    canreinvite=no
    
    [voipgateway]
    username=4181511xxxx
    type=friend
    secret=passwords
    insecure=very
    host=voipgateway.org
    fromuser=4181511xxxx
    fromdomain=voipgateway.org
    disallow=all
    allow=alaw
    allow=ulaw
    
    
    Ich hoffe du hast nochmals eine Idee.

    Vielen Dank und Gruss
     
  6. cmmehl

    cmmehl Aktives Mitglied

    Registriert seit:
    15 Juni 2004
    Beiträge:
    812
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    kleinschreiber
    Ort:
    Derzeit im Irak
    Hallo,

    ... firewall mit offenen toren? ;-) Vermutlich meintest du, alle fuer * relevanten ports ... ja?

    Aendere mal die entsprechenden eintraege deiner sip.conf (bzw fuege die zeilen ein) wie dieses hier:
    Code:
    [general]
    port = 5060                     
    bindaddr = deine feste IP adresse
    srvlookup = yes                 
    maxexpirey=3600
    defaultexpirey=120
    nat=no
    allow=all
    und mach dann einen sip reload.

    Wenn das noch nichts bringen sollte, kommentiere diese zeile aus:
    Code:
    ; context = from-sip-external ; Send unknown SIP callers to this context
    Dieser from-sip-external context beim *@home hatte mir viele kopfschmerzen bereitet, ich habe ihn rauskommentiert und danach nie vermisst.

    Viel erfolg!
    Chris
     
  7. Scharlie

    Scharlie Neuer User

    Registriert seit:
    27 Juni 2005
    Beiträge:
    19
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Chris

    Habe mich nicht korrekt ausgedrückt. Natürlich ist die Firewall nicht ganz offen!

    Ich habe die sip.conf mit deinen Einträgen ergänz bzw. abgeändert und ein sip reload druchgeführt.
    Leider ist immernoch das gleich Problem vorhanden.

    Wenn ich den context = from .... austexte, dann kommt immer eine Sip-Fehler Meldung 404:
    Code:
    404 Not Found
    ******************
    Sip read:
    OPTIONS sip:4181511xxxx@195.141.xxx.xxx SIP/2.0
    Via: SIP/2.0/UDP 212.117.200.148;branch=z9hG4bK7861.5090cb31000000000000000000000000.0
    To: sip:4181511xxxx@195.141.xxx.xxx
    From: sip:registrar;tag=4df8520445f0eb1eb2f53b2b28e07244-596e
    CSeq: 10 OPTIONS
    Call-ID: 4cd36801-464@212.117.200.148
    User-Agent: Sip EXpress router (0.9.0 (i386/freebsd))
    
    
    7 headers, 0 lines
    Looking for 41815115511 in default
    Transmitting (NAT):
    SIP/2.0 404 Not Found
    Via: SIP/2.0/UDP 212.117.200.148;branch=z9hG4bK7861.5090cb31000000000000000000000000.0;received=212.117.200.148;rport=5060
    From: sip:registrar;tag=4df8520445f0eb1eb2f53b2b28e07244-596e
    To: sip:4181511xxxx@195.141.xxx.xxx;tag=as1ceaa3cc
    Call-ID: 4cd36801-464@212.117.200.148
    CSeq: 10 OPTIONS
    User-Agent: kuba
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER
    Contact: <sip:195.141.xxx.xxx>
    Accept: application/sdp
    Content-Length: 0
    
    
     to 212.117.200.148:5060
    Destroying call '4cd36801-464@212.117.200.148'
    
    Darf darum diese Zeile nicht austexten!!

    Ich hoffe du hast nochmals eine Idee.
    Sonst probier ich mal eine normale Asterisk Version. Vermutet, dass im *@H etwas eingestellt ist, was mich am Incoming-Call hintert. Keine Ahnung, was das ist und wo dies eingestellt ist.

    Gruss
     
  8. cmmehl

    cmmehl Aktives Mitglied

    Registriert seit:
    15 Juni 2004
    Beiträge:
    812
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    kleinschreiber
    Ort:
    Derzeit im Irak
    Hm, eine letzte idee habe ich noch.

    Ergaenze mal (aber ueber das GUI !!!) bei "incoming" der betreffenden nummer folgendes:

    username=4181511xxxx
    type=user
    secret=password
    qualify=no
    insecure=very
    fromuser=4181511xxxx
    context=from-pstn
    canreinvite=no
    host=voipgateway.org
    fromdomain=voipgateway.org


    Nicht direkt in der sip_additional.conf aendern, sonst wird das nicht in die datenbank geschrieben. Danach natuerlich noch seinen sip reload.

    Good luck!
    Chris
     
  9. Scharlie

    Scharlie Neuer User

    Registriert seit:
    27 Juni 2005
    Beiträge:
    19
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Chris!

    Danke für deinen Einsatz.

    Die letzte Idee hat leider auch keinen Erfolg gebracht.
    Schmeisse jetzt das *@H vom Server und probiere mal die 1.2er Asterisk Version.

    Ich hoffe mit dieser komme ich zum Erfolg.

    Gruss und vielen Dank
     
  10. Scharlie

    Scharlie Neuer User

    Registriert seit:
    27 Juni 2005
    Beiträge:
    19
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Chris!

    Mit der normalen Asterisk-Version klappt alles wunderbar.
    Weiss auch nicht warum!

    Gruss
     
  11. cmmehl

    cmmehl Aktives Mitglied

    Registriert seit:
    15 Juni 2004
    Beiträge:
    812
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    kleinschreiber
    Ort:
    Derzeit im Irak
    Na das hoert man doch gerne!

    :)
     
  12. schnaepsli

    schnaepsli Neuer User

    Registriert seit:
    22 Nov. 2005
    Beiträge:
    2
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Problem wohl gelöst

    Hallo
    ... war auch fast am verzweifeln. Habe aber in sip.conf den einrag context auf
    context=from-pstn geändert und schon gehts.

    Versteh die Meldung ; send unknow SIP Callers to this context sowieson nicht

    Meiner Meinung nach ist jeder Anruf der über die SIP hereinkommt unbekannt.

    Bin übrigen bei sipcall.ch und die sind auf sip.backbone.ch angeschlossen
     
  13. Scharlie

    Scharlie Neuer User

    Registriert seit:
    27 Juni 2005
    Beiträge:
    19
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo

    In dieser Kälte ist ein Schnäpsli immer eine gute Lösung.
    Werde diesen Eintrag bei Gelegenheit versuchen.

    Vielen Dank und Gruss
     
  14. riedere

    riedere Neuer User

    Registriert seit:
    24 Juli 2005
    Beiträge:
    131
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbstständig
    Ort:
    Zürich
    Konntet Ihr das lösen ?

    Hab den 2. A&H aufgesetzt. auch sipcall.
    Ausgehend geht aber Ankommende nicht, dh Asterisk sieht sie aber kommt dann auf Timeout. Aber beim letzten hatte ich es und ich meinte wieder gleich konfiguriert (print screen gemacht)
    Ist der Incomming Teil so ok ?
    context=from-pstn
    fromdomain=sip.backbone.ch
    fromuser=41432105082
    host=sip.backbone.ch
    insecure=very
    nat=yes
    qualify=yes
    secret=xxxxxx
    type=friend
    username=41432105082

    Das Zeug kommt an aber nur das passiert:
    -- Executing AbsoluteTimeout("SIP/41432105082-1dc6", "15") in new stack
    -- Set Absolute Timeout to 15
    -- Executing Congestion("SIP/41432105082-1dc6", "") in new stack
    -- Executing AbsoluteTimeout("SIP/41432105082-1dc6", "15") in new stack
    -- Set Absolute Timeout to 15
    -- Executing Congestion("SIP/41432105082-1dc6", "") in new stack
    Und dann gibts beim Anrufer "Die gewählte netzverbindung ist nich..."
     
  15. sike

    sike Neuer User

    Registriert seit:
    5 Apr. 2005
    Beiträge:
    161
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hast du im sip.conf in GENERAL der Eintrag

    useragent=blabla (Irgend etwas aber nicht astersik)

    gemacht?

    Gruss

    Sike