Abbrüche / Probleme beim schreiben auf SAMBA Laufwerke

grandis

Neuer User
Mitglied seit
27 Mai 2006
Beiträge
11
Punkte für Reaktionen
0
Punkte
0
Hilfe,

dank der guten arbeit der Forumsmitglieder habe ich ohne größere Problem meine Fritz!Box 7170 mit dem DS-MOD 0.2.9 incl. Samba ausstatten können.
Ich habe auf die 250 GB USB Platte (leider fat32 ext2 hat nicht funktioniert) Lese und Schreibzugriff.

Leider läuft das ganze nicht stabil!
Beim schreiben größerer Dateien kommt es nach kürzerer Zeit (während des Schreibens) zu der Fehlermeldung „Der angegebene Netzwerkname ist nicht mehr verfügbar“.
Nach der Fehlermeldung hängt sich die Explorer Session meistens auf und auch die Fritz!Box ist schwer in Mitleidenschaft gezogen (Zugriff über Samba meist nicht mehr möglich, Geschwindigkeit, ..).
Auffällig ist das nach der Fehlermeldung auf der Fritz!Box ein zusätzlicher smbd Prozess gestartet wurde (siehe unten).

Was mache ich falsch?

Gruß Grandis

Vor dem Fehler
Code:
/ # ps -ef
  PID  Uid     VmSize Stat Command
    1 root        272 S   init
    2 root            SW  [keventd]
    3 root            RWN [ksoftirqd_CPU0]
    4 root            SW  [kswapd]
    5 root            SW  [bdflush]
    6 root            SW  [kupdated]
    7 root            SW  [mtdblockd]
    8 root            SW  [tffsd_mtd3]
  249 root            SW  [khubd]
  340 root            SW  [capitransp]
  395 root       1396 S N ctlmgr
  408 root        348 S   wpa_authenticator
  411 root            DW  [usb-storage-0]
  412 root            SW  [scsi_eh_0]
  434 root        224 S   ftpd -D -q -t 120 -m 15 -h FRITZ!Box Fon WLAN 7170
  442 root        884 R N websrv
  460 root       1040 S   igdd
  511 root       1000 S   multid
  527 root       1072 S   dsld -i -n
  534 root        596 S   telefon a127.0.0.1
  538 root       1160 S < voipd
  542 root        884 S N websrv
  543 root        884 S N websrv
  544 root        884 S N websrv
  546 root        164 S   /bin/run_clock -c /dev/tffs/mtd3 -d
  560 root       1040 S   igdd
  561 root       1040 S   igdd
  562 root       1040 S   igdd
  615 root        232 S   telnetd -l /sbin/ar7login
  624 root        272 S   httpd -p 81 -c /mod/etc/httpd.conf -h /usr/mww/ -r DS
  682 root        696 S   nmbd -D -o -H /tmp/flash/samba/lmhosts
  685 root        672 S   smbd -D -o
  703 root        272 S   httpd -p 82 -c /mod/etc/httpd-wol.conf -h /mod/pkg/wo
  706 root        380 S   -sh
  753 samba      1116 R   smbd -D -o
  754 root        384 S   -sh
  806 root        304 R   ps –ef
Nach dem Fehler
Code:
/ # ps -ef
  PID  Uid     VmSize Stat Command
    1 root        164 S   init
    2 root            SW  [keventd]
    3 root            RWN [ksoftirqd_CPU0]
    4 root            SW  [kswapd]
    5 root            SW  [bdflush]
    6 root            SW  [kupdated]
    7 root            SW  [mtdblockd]
    8 root            SW  [tffsd_mtd3]
  249 root            SW  [khubd]
  340 root            SW  [capitransp]
  395 root       1224 S N ctlmgr
  408 root        280 S   wpa_authenticator
  411 root            DW  [usb-storage-0]
  412 root            SW  [scsi_eh_0]
  434 root        156 S   ftpd -D -q -t 120 -m 15 -h FRITZ!Box Fon WLAN 7170
  442 root        824 S N websrv
  460 root        976 S   igdd
  511 root        924 S   multid
  527 root       1012 S   dsld -i -n
  534 root        528 S   telefon a127.0.0.1
  538 root       1088 S < voipd
  542 root        824 S N websrv
  543 root        824 S N websrv
  544 root        824 S N websrv
  546 root         96 S   /bin/run_clock -c /dev/tffs/mtd3 -d
  560 root        976 S   igdd
  561 root        976 S   igdd
  562 root        976 S   igdd
  615 root        132 S   telnetd -l /sbin/ar7login
  624 root        152 S   httpd -p 81 -c /mod/etc/httpd.conf -h /usr/mww/ -r DS
  682 root        660 S   nmbd -D -o -H /tmp/flash/samba/lmhosts
  685 root        520 S   smbd -D -o
  703 root        152 S   httpd -p 82 -c /mod/etc/httpd-wol.conf -h /mod/pkg/wo
  706 root        172 S   -sh
  753 samba       736 D   smbd -D -o
  754 root        268 S   -sh
  807 samba      1076 D   smbd -D -o
  808 root        304 R   ps -ef
 

jesus.christ

Mitglied
Mitglied seit
25 Jun 2005
Beiträge
494
Punkte für Reaktionen
0
Punkte
0
Das liegt am FAT32, dass das Schreiben nicht zuverlässig funktioniert. Seitdem ich meine externe Platte auf ext3 formatiert habe, funktioniert der Samba wunderbar, zuvor herrschten die gleichen Probleme. Für ext3 brauchst du aber auch noch das ext3.o-Modul aus dem DS-Mod, außerdem musst du die Platte manuell (bzw in der debug.cfg) mounten.
Gruß Niko
 

grandis

Neuer User
Mitglied seit
27 Mai 2006
Beiträge
11
Punkte für Reaktionen
0
Punkte
0
Vielen Dank für den Tipp
Ich mache gerade den Härtetest.
Bisher stabil :)

Weiß jemand ob es für ext3-Laufwerken unter XP eine alternative zu Ext2IFS gibt die das Journal unterstützt? Bei Googel bin ich nicht fündig geworden.
 
Zuletzt bearbeitet:
O

omgwtfbf

Guest
Ich habe das gleiche Problem auf meine 7141. Meine Platte läuft aktuell in ext2. Ist es zwingend notwendig sie in ext3 zu formatieren oder gibt es noch eine andere Möglichkeit ?
 

McNetic

Mitglied
Mitglied seit
7 Feb 2007
Beiträge
674
Punkte für Reaktionen
0
Punkte
16
OT: Um die Platte als ext3 zu mounten ist lediglich ein vorheriges 'tune2fs -j <device>' notwendig, kein Neuformatieren.
 
O

omgwtfbf

Guest
Es klappt jetzt. Ich habe die Festplatte in ext3 formatiert und dann noch die ext3.o vom dsmod nachgeladen.
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Neueste Beiträge

Statistik des Forums

Themen
232,847
Beiträge
2,027,349
Mitglieder
350,937
Neuestes Mitglied
Elperator