.titleBar { margin-bottom: 5px!important; }

After upgrading: info led blinks twice periodically

Dieses Thema im Forum "Freetz" wurde erstellt von M66B, 31 Mai 2010.

  1. M66B

    M66B Mitglied

    Registriert seit:
    17 Feb. 2010
    Beiträge:
    225
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Dordrecht
    #1 M66B, 31 Mai 2010
    Zuletzt bearbeitet: 31 Mai 2010
    Today I did a svn up to rebuild Freetz to revision 4965M. I selected an extra package (Polipo) using make menuconfig. I saw there were a lot of new files, so to be sure I did a make distclean after saving the dl folder and the .config file. After restoring the dl folder and the .config I did a make and when it was ready I upgraded the firmware using the Freetz UI. After the usual blinking phase of the info led and the big red flash (without smoke :) ) the info led remained blinking twice with a few seconds interval. I had this before and had the device rebooting normally again after ./tools/push_firmware <previous>.image. This time I choose the do a make kernel-menuconfig and to disable Automatic kernel module loading. After rebuilding I did again a make kernel-menuconfig and enabled Automatic kernel module loading again. After the second rebuild I pushed the new, twice rebuilt firmware using ./tools/push_firmware and it worked! So this seem to have to do something with the automatic kernel module loading.

    So here is a little recipe to fix this problem (maybe there other, better methods). But I am curious what went wrong exactly and how I can prevent this.
     
  2. Silent-Tears

    Silent-Tears IPPF-Promi

    Registriert seit:
    3 Aug. 2007
    Beiträge:
    7,456
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    BI
    You should use an unmodified trunk or a fresh checkout to prevent errors, otherwise noone can reproduce your problems...
     
  3. M66B

    M66B Mitglied

    Registriert seit:
    17 Feb. 2010
    Beiträge:
    225
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Dordrecht
    If you mean by an unmodified trunk the default config: I tried that the time before this time (rm .config and make clean), except for resetting the automatic kernel module loading, and it didn't work. If you mean by an unmodified trunk no modifications to the kernel: the only modification I did was support for automatic kernel module loading.

    Everthing works if I do I fresh checkout after removing all files and folder (inluding all hidden files), of course (most of the time :) )
     
  4. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,765
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Modified means that you have a svn version like "4965M". The M has a meaning. I would have to google it too.

    I don't think that it has something to do with your kernel changes.

    Regards
    Oliver
     
  5. M66B

    M66B Mitglied

    Registriert seit:
    17 Feb. 2010
    Beiträge:
    225
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Dordrecht
    I know the magic M appears when I enable Automatic kernel module loading.

    If the kernel change isn't the problem, what else could be the problem?
    Basically the only thing I did was a svn up, make clean and make. So the clean maybe isn't totally clean.

    Anyway, don't put too much energy in this, since I know how I can solve it.
     
  6. M66B

    M66B Mitglied

    Registriert seit:
    17 Feb. 2010
    Beiträge:
    225
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Dordrecht
    Again this problem after upgrading 4965M to 4969M ...
    Executing make kernel-menuconfig, saving without changes and make solves the problem.