.titleBar { margin-bottom: 5px!important; }

anruf ohne dad wird nicht angenommen

Dieses Thema im Forum "Asterisk ISDN mit mISDN" wurde erstellt von onkel_fritz, 10 Okt. 2006.

  1. onkel_fritz

    onkel_fritz Neuer User

    Registriert seit:
    10 Apr. 2006
    Beiträge:
    110
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hi

    habe jetzt mal ausnahmsweise probleme mit dem TE mode ;)
    wie es aussieht, kommt bei meinem anschluss, bei anruf auf
    der hauptnummer garkeine msn mit; sprich DAD is
    leer und folglich matchd es nicht im dialplan
    ein anruf an einer zweiten msn funktioniert wie
    erwartet einwandfrei; woran kann das liegen? :(

    /etc/asterisk/misdn.conf
    [von-telekom]
    ports=2
    context=match
    msns=*

    /etc/asterisk/extension.conf
    [match]
    exten => _X.,1,Noop(here)
    exten => i,1,Noop(here)
    exten => t,1,Noop(here)
    exten => 0,1,Noop(here)

    output:
    P[ 2] set_channel: bc->channel:0 channel:2
    P[ 2] I IND :SETUP oad:664XXXXXXX dad: pid:48 state:none
    P[ 2] --> channel:2 mode:TE cause:16 ocause:16 rad: cad:
    P[ 2] --> info_dad: onumplan:2 dnumplan: rnumplan: cpnnumplan:0
    P[ 2] --> caps:Speech pi:0 keypad: sending_complete:1
    P[ 2] --> Bearer: Speech
    P[ 2] --> Codec: Alaw
    P[ 0] --> * NEW CHANNEL dad: oad:664XXXXXXX
    P[ 2] --> CTON: Unknown
    P[ 2] EXPORT_PID: pid:48
    P[ 2] --> PRES: Restricted (0)
    P[ 2] --> SCREEN: Unscreened (0)
    P[ 2] --> sending_complete so we never match ..
    P[ 2] I SEND:RELEASE oad:0664XXXXXXX dad: pid:48
    P[ 2] --> bc_state:BCHAN_CLEANED
    P[ 2] --> channel:2 mode:TE cause:16 ocause:1 rad: cad:
    P[ 2] --> info_dad: onumplan:2 dnumplan: rnumplan: cpnnumplan:0
    P[ 2] --> caps:Speech pi:0 keypad: sending_complete:1
    P[ 2] MGMT: SSTATUS: L2_ESTABLISH
    P[ 2] $$$ CLEANUP CALLED pid:48
    P[ 2] I IND :RELEASE_COMPLETE oad: dad: pid:48 state:EXTCANTMATCH
    P[ 2] --> channel:0 mode:TE cause:-1 ocause:16 rad: cad:
    P[ 2] --> info_dad: onumplan:0 dnumplan:0 rnumplan:0 cpnnumplan:0
    P[ 2] --> caps:Speech pi:0 keypad: sending_complete:0
    P[ 2] hangup_chan
    P[ 2] -> hangup
    P[ 2] * IND : HANGUP pid:48 ctx:match dad: oad:0664XXXXXXX State:EXTCANTMATCH
    P[ 2] --> l3id:2002b
    P[ 2] --> cause:-1
    P[ 2] --> out_cause:-1
    P[ 2] --> state:EXTCANTMATCH
    P[ 2] Channel: mISDN/2-2 hanguped new state:CLEANING
    P[ 2] release_chan: bc with l3id: 2002b
    P[ 2] $$$ CLEANUP CALLED pid:48
     
  2. onkel_fritz

    onkel_fritz Neuer User

    Registriert seit:
    10 Apr. 2006
    Beiträge:
    110
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    habs schon *g*

    die option

    immediate=yes

    in der datei misdn.conf muss aktiviert werden! :eek:


    2 bitten:
    erstens:
    der kommentar im misdn.conf file ist für meinen geschmack
    irreführend; da steht
    Code:
    ; uncomment the following if you want callers which called exactly the
    ; base number (so no extension is set) jump to the s extension.
    ; if the user dials something more it jumps to the correct extension
    ; instead
    ;
    ; default value: no
    
    es sollte aber besser stehen: "set the following to yes" anstatt "uncomment the following";
    sieht ja sonst so aus als würde immediate=no das machen was eigentlich ja
    immediate=yes macht!!
    (klar was ich meine??!?!?)

    zweitens:
    es wäre schön, wenn im trace output stehen würde, das man eben das aktivieren muss!
    wie oben zu sehen, steht im trace nur "extension cant match"; muss sagen es wäre kein fehler
    wenn dort stehen würde "no DAD; enable immediate=yes for enableing this setup"

    so jetzt zurück zu meinem kampf gegen den dialplan ;)