.titleBar { margin-bottom: 5px!important; }

Anrufer hört mich nicht

Dieses Thema im Forum "kphone" wurde erstellt von rolf-hh, 21 Jan. 2005.

  1. rolf-hh

    rolf-hh Neuer User

    Registriert seit:
    21 Jan. 2005
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,
    bin Neu hier und habe schon festgestellt, dass das Thema nicht neu ist - aber eine Antwort habe ich auch nicht gefunden.
    Benutze kphone unter SuSE-Linux 9.2 und Sipgate, habe dort auch ein Guthaben für Anrufe nach Aussen. Dies funktioniert auch alles bis auf die Tatsache dass mich niemand hört, hingegen kann ich den Angerufenen gut hören.
    Mein Microfon unter kmix funktioniert wenn ich den Schalter "Mic Boost" setze.

    Habe keine Idee mehr und hoffe hier kann mir jemand weiterhelfen.
    Danke im voraus.
    Rolf
     
  2. palinkas

    palinkas Neuer User

    Registriert seit:
    18 Dez. 2004
    Beiträge:
    2
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    "kein sound"

    Nachdem ich gute Erfahrungen mit den alsa-utils (siehe diesen Beitragbeitrag) gemacht habe ist das auch mein einziger tipp ...
     
  3. chamaeleo

    chamaeleo Neuer User

    Registriert seit:
    3 Feb. 2005
    Beiträge:
    24
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bei mir muss ich nach dem einloggen in KDE in den KMix-Enstellungen unter "Eingang" immer den Schalter "Capture" wieder neu aktivieren.
    Sonst kann ich auch nichts vom Mikro aufzeichnen.
     
  4. rolf-hh

    rolf-hh Neuer User

    Registriert seit:
    21 Jan. 2005
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    habe das Problem zwischenzeitlich gelöst mit Hilfe vieler Tipps für die ich herzlich danke.

    Einer Empfehlung folgend habe ich Kphone 4.0.5 von Easylinux installiert, da ich der Meinung war, dass das Problem zwischen ALSA und OSS lag, habe ich KMix durch QAMix 0.0.7 von der SuSE-Linux 9.2 Version installiert - und siehe da - seit dem kann ich mit Kphone und Sipgate telefonieren.

    Nach der Installation von Kphone 4.0.5 hatte ich auch schon den Eindruck das sich der Sound verbessert hatte.

    Sehr hilfreich, weil sehr ausführliche Installationsanweisung, ist dieser Link: http://130.75.73.30/homepage_rep/svenk/kphone_sipgate.html

    Auf meinem Router habe ich nachfolgende Ports geöffnet, falls hierzu noch jemand einen Verbesserungsvorschlag hat, gerne.
    (hoffe die formatierung bleibt bestehen..)
    Enable Service Name Service Type Inbound Connection Service User
    x STUN-SIPGATE UDP:10000 TCP/UDP:10000 ANY
    x NTP UDP:123 TCP/UDP:123 ANY
    x STUN-WEB UDP:3478 TCP/UDP:3478 ANY
    x RTP UDP:5004 TCP/UDP:5004 ANY
    x SIP UDP:5060 TCP/UDP:5060 ANY
    x SIP-1 UDP:5062 TCP/UDP:5062 ANY
    x SIP-2 UDP:30000 TCP/UDP:30000..30005 ANY

    Mit dieser Konfiguration kann ich gleichzeitig Musik hören und telefonieren, die unterschiedliche Lautstärken stelle ich bei KsCD und QAMix ein, dort muss auch auf dem Reiter "Capture" das Microfon mit dem Kästchen "Aktivate" aktiviert werden und zwar nach jedem Neustart.

    Würde mich freuen wenn diese iInfos weiterhelfen.

    Beste Grüsse
    Rolf
     
  5. joey_malone

    joey_malone Neuer User

    Registriert seit:
    18 Juni 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ah... das gibt Hoffnungen!
    Also ich hab Asterix gelöscht und Qamix installiert... vergebens, denn jetzt höre ich nichts mehr. Ich bin schon seit Stunden am Linux dran, mach morgen da weiter.
     
  6. rolf-hh

    rolf-hh Neuer User

    Registriert seit:
    21 Jan. 2005
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo joey_malone,

    was meinst du mit gelöscht? Mit YAST deinstalliert?
    Ich habe nichts deinstalliert sondern nur Qamix nachinstalliert, weil es dort heißt das ALSA und OSS unterstützt werden.
    Das Problem war vorher, dass Kphone mit OSS konfiguriert war (und ist) und Kmix mit ALSA und ich keinen Weg fand dies zu ändern.
    Kphone habe ich auf Grund einer Empfehlung (ich glaube hier aus dem Forum) auf 4.0.5 upgedatet.

    Ich starte Qamix, danach Kphone und kann dann mit Sipgate telefonieren. Meine Konfiguration funktioniert auch mit Skype, einziger Unterschied, bei Skype brauche ich das Microfon nicht manuell zu aktivieren.
     
  7. joey_malone

    joey_malone Neuer User

    Registriert seit:
    18 Juni 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Achso.. Asterisk hatte ich vorher über Yast installiert und danach deinstalliert, dachte zuerst es handelt sich um ein Softphone für Linux. Jetzt geht alles, bis auf das ausgehende Anrufe in Mobil- und ISDN-Anschlüsse der Angerufene mich zerhackt hört, ein anderer Codec weist eine zu lange Verzögerung (ca. 2 sek.) Hat die Firewall schuld, oder woran könnte es sonst liegen?

    Hier ist noch ein Netzwerk, max. 10k Up werden im schnitt verbraucht und wie gesagt, wenn ich angerufen wird sind keinerlei Verzögerungen oder Qualitätminderungen zu hören. Analoge Anschlüsse sind auch nicht davon betroffen.
     
  8. hai

    hai Neuer User

    Registriert seit:
    20 Juli 2005
    Beiträge:
    8
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Bei mir war nur ein Update auf kphone 4.2 nötig und alles ging perfekt. kphone-4.2-Pakete für SUSE 9.2/9.3 gibts auf Anfrage.