.titleBar { margin-bottom: 5px!important; }

[Gelöst] Asterisk 1.8 / Account ist registriert aber eingehende Gespräche kommen nicht an

Dieses Thema im Forum "PBX-network" wurde erstellt von rmh, 3 Dez. 2011.

  1. rmh

    rmh Aktives Mitglied

    Registriert seit:
    6 Juli 2008
    Beiträge:
    1,836
    Zustimmungen:
    6
    Punkte für Erfolge:
    38
    Beruf:
    R&D
    Ort:
    BY
    #1 rmh, 3 Dez. 2011
    Zuletzt bearbeitet: 5 Dez. 2011
    Hallo zusammen,

    Leider gelingt es mir nicht, eingehende Anrufe auf Personal-Voip Rufnummern auf meiner lokalen Asterisk-PBX signalisiert zu bekommen. Die Accounts sind registriert. Ausgehend klappt auch problemlos Da aber eingehend kein einziges SIP-Paket ankommt, bin ich etwas ratlos. Ich habe diverse debug-logs erstellt und durchgesehen, Firewall zeitweise inaktiv gesetzt, meine Konfigurationsdateien überprüft, alles ohne Befund. Da ich keinen Fehler erkennen kann, wende ich mich zunächst mal an die euch. :)

    Meine Konfiguration läuft völlig problemlos mit diversen SIP-Anbietern, daher die allgemeine Frage: Kann jemand über Erfahrungen mit den neuen Ortsrufnummern aus dem aktuellen Angebot berichten?
    Ich habe festgestellt, dass eine Weiterleitung per Webinterface auf mein Handy funktioniert. Sobald ich eine Nummer einer Account-ID zuordne, erhält man CONGESTION im Kundenmenü. :confused:


    Gruß,
    R.
     
  2. equada

    equada VoIP-Provider

    Registriert seit:
    20 Nov. 2004
    Beiträge:
    184
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    VOIP-Provider
    Ort:
    Alzenau
    Hi,

    hast du mal einen SIP Trace gemacht? Einfach mal ein ngrep -W byLine port 5060 und schauen ob bzw. was an Paketen ankommt.

    Grüße
     
  3. equada

    equada VoIP-Provider

    Registriert seit:
    20 Nov. 2004
    Beiträge:
    184
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    VOIP-Provider
    Ort:
    Alzenau
    Hi,
    bitte passe mal dein Register so an, das du als Authname deine SIPID verwendest. Also:

    register => <SIPID>:<PWD>@sip.personal-voip.de/<SIPID>

    Grüße
     
  4. rmh

    rmh Aktives Mitglied

    Registriert seit:
    6 Juli 2008
    Beiträge:
    1,836
    Zustimmungen:
    6
    Punkte für Erfolge:
    38
    Beruf:
    R&D
    Ort:
    BY
    #4 rmh, 5 Dez. 2011
    Zuletzt bearbeitet: 5 Dez. 2011
    Hallo,

    bin nicht sicher, ob ich "Authname" in diesem Zusammenhang richtig verstehe. Soll ich meine ID als authuser oder als extension setzen?

    Allgmeines Beispiel:
    Code:
    register => user[:secret[:authuser]]@host[:port][/extension]
    Ich vermute du meinst die extension, hier habe ich einen alias, aber dieser dient nach meinem Kenntnisstand nur der Zuordnung eingehender Anrufe in meiner extensions.conf. Werde es dennoch prüfen und die SIP-ID eintragen. Danke vorab!


    Gruß
    R.


    ~ EDIT: Aha - es lag tatsächlich am register. Man muss die SIP-AccountID als extension verwenden. Für die Nachwelt - richtig ist:
    Code:
    register => <SIP-AccountId>:<SIP-Password>@sip.personal-voip.de/[B][COLOR="seagreen"]<SIP-AccountId>[/COLOR][/B]
    @personal-voip: Das Ticket #2011112710000023 ist damit erledigt.
     
  5. RcRaCk2k

    RcRaCk2k Mitglied

    Registriert seit:
    4 Aug. 2005
    Beiträge:
    230
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ja, das habe ich auch schon bemerkt. Das ist aber echt nicht toll!
    @Personal-VoIP, warum kann ich die Extension bei euch nicht frei definieren? Durch diese Einschränkung muss ich im Context extra ein Mapping der SIP-ID zum echten Account machen.