.titleBar { margin-bottom: 5px!important; }

Asterisk als Client hinter NAT - keine eingehenden Anrufe

Dieses Thema im Forum "FreePBX, TrixBox (Asterisk@Home)" wurde erstellt von voipfips, 25 Nov. 2006.

  1. voipfips

    voipfips Neuer User

    Registriert seit:
    25 Nov. 2006
    Beiträge:
    37
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo liebe VoIPler!

    Ich habe seit einiger Zeit TrixBox v2ß installiert.
    Der * Server befindet sich in meinem lokalen Netz (192.168.0.0). Meine Softphones und Zyxel 2002 ATAs können sich prima anmelden, untereinander anrufen und auch über mein YESSS Trunk raustelefonieren. Alles bestens!
    Problem: Nur leider kann ich unter meiner 0780er Rufnummer von außen nicht erreicht werden, wenn der Asterisk registriert ist. (Gebe ich zu testzwecken die yesss-benutzerdaten beim ATA oder softphone ein, bin ich von aussen erreichbar, auch ohne port forwarding,...)

    Meine NAT-Firewall: MS ISA Server (habs schon mit und ohne Port forwarding probiert)
    Von außen her habe ich eine statische IP Adresse, das ist zwar nicht wirklich von belangen, aber ich schreibs mal her.

    Konfiguriert hab ich den * via FreePBX:
    -) ein Trunk angelegt
    -) outbound route (die ja funktioniert)
    -) any DID/any CID inbound Route auf 200
    -) natürlich auch extensions (200,201) angelegt
    hier hab ich noch ein paar auszüge meiner .conf dateien (änderungen habe ich nur im general -teil der sip.conf gemacht. sonst alles via freepbx):
    sip.conf
    Code:
    [general]
    bindport = 5060       ; Port to bind to (SIP is 5060)
    bindaddr = 0.0.0.0    ; Address to bind to (all addresses on machine)
    disallow=all
    allow=ulaw
    allow=alaw
    externip=!!MY IP IS HERE!!
    localnet=192.168.0.0/255.255.255.0 
    
    context = from-trunk ; Send unknown SIP callers to this context
    callerid = Unknown
    tos=0x68
    
    sip_additional.conf
    Code:
    register=43780XXXXXX:geheim@sip.yesss.at
    !!hier stehen noch meine extensions 200 und 201!!
    [43780XXXXXX] ;trunk name
    username=43780XXXXXX
    type=peer
    secret=geheim
    host=sip.yesss.at
    
    [incoming-yesss]
    type=user
    secret=geheim
    context=from-trunk
    
    extensions.conf
    Code:
    [from-trunk] ; just an alias since VoIP shouldn't be called PSTN
    include => from-pstn
    [from-pstn]
    include => from-pstn-custom ; create this context in extensions_custom.conf to include customizations
    include => ext-findmefollow		; MODIFICATOIN (PL) for findmefollow if enabled, should be bofore ext-local
    include => ext-did-direct		; MODIFICATOIN (PL) put before ext-did to take precedence
    include => ext-did
    exten => fax,1,Goto(ext-fax,in_fax,1)
    
    Ich habe schon alle möglichen Varianten mit nat,.. durchprobiert, die man im forum so findet, aber irgendwie hat noch keine gepasst (leider weiß man nicht immer was man tut ;) ich bin mir auch nicht sicher, ob es ein nat problem ist, oder ob der * von mir falsch konfiguriert wurde. das ist mehr oder weniger auch der grund warum ich hier poste, vielleicht hat jemand eine idee wie ich vorgehen könnte.
    Vielen Dank für Deine Mühe!

    lg Fips
     
  2. rollo

    rollo IPPF-Promi

    Registriert seit:
    5 Juli 2004
    Beiträge:
    8,278
    Zustimmungen:
    1
    Punkte für Erfolge:
    38
    Ort:
    JO30SK
    externip=!!MY IP IS HERE!!

    Ja wo ist sie denn?
    Wenn Du eine feste IP hast, solltest Du die da eintragen, ansonsten den DynDNS namen

    Portforwarding auf UDP 5060 und die RTP Ports die in /etc/asterisk/rtp.conf stehen im Router eintragen

    Wenn Du mehrere Telefone nach aussen betreibst, solltest Du entweder an denen oder am * den SIP Listen Port ändern.

    jo
     
  3. voipfips

    voipfips Neuer User

    Registriert seit:
    25 Nov. 2006
    Beiträge:
    37
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi Rollo!

    Danke für die rasche Antwort!

    An der Stelle !!MY IP IS HERE!! steht natürlich meine IP Adresse. Die habe ich nur genauso wie die Telefonnummer und das Passwort verdeckt.

    Portforwarding für SIP und RTP habe ich am Router eingetragen. Auch den RTP Portbereich habe ich in rtp.conf angepasst. Aber soweit kommts ja gar nicht.
    Die übrigen Telefone haben keine Verbindung nach außen (ausgenommen bei Testzwecken)

    vielleicht hast du ja noch andere Vorschläge..

    thx Fips