.titleBar { margin-bottom: 5px!important; }

asterisk antwortet nicht auf sipgate authorisierungs-anfrage

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von MehrCurry, 3 Jan. 2005.

  1. MehrCurry

    MehrCurry Neuer User

    Registriert seit:
    3 Jan. 2005
    Beiträge:
    1
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo allerseits,

    ich such hilfe bei einem Asterisk Problem. Ich versuche mich bei Sipgate und Web.de mit meinem Asterisk anzumelden - leider ohne jeden erfolg. Ich habe hier schon das Ganze Forum rauf- und runtergelesen und die sip.conf von diversen netten Helfern ausprobiert - an dem Verhalten ändert sich nix.

    Erstmal die Konfiguration

    Asterisk 1.0.3 mit chan_capi, ohne bristuff unter Suse 9.1
    hinter SMC Barricade 7404BRB (NAT!)

    Accounts bei Web.de und Sipgate (getestet mit X-Lite)
    5060 und 5004-5010 an den * weitergeleitet (auch rtp.conf)

    sip debug zeigt einen dialog zwischen * und sipgate

    Code:
    Retransmitting #3 (no NAT):
    REGISTER sip:sipgate.de SIP/2.0
    Via: SIP/2.0/UDP 62.214.33.3:5060;branch=z9hG4bK7bfb3e67
    From: <sip:9990007@sipgate.de>;tag=as0a13bfe1
    To: <sip:9990007@sipgate.de>
    Call-ID: 7d6f58953c04070d3b4a2e09661c950b@172.31.5.2
    CSeq: 105 REGISTER
    User-Agent: Asterisk PBX
    Expires: 120
    Contact: <sip:9990007@62.214.33.3>
    Event: registration
    Content-Length: 0
    
    
     to 217.10.79.9:5060
    
    
    Sip read: 
    SIP/2.0 401 Unauthorized
    Via: SIP/2.0/UDP 62.214.33.3:5060;branch=z9hG4bK7bfb3e67
    From: <sip:9990007@sipgate.de>;tag=as0a13bfe1
    To: <sip:9990007@sipgate.de>;tag=b11cb9bb270104b49a99a995b8c68544.b782
    Call-ID: 7d6f58953c04070d3b4a2e09661c950b@62.214.33.3
    CSeq: 105 REGISTER
    WWW-Authenticate: Digest realm="sipgate.de", nonce="41d96497d2c4d21fbbcc56faa19f13f4fdd0897e"
    Server: sipgate ser
    Content-Length: 0
    Warning: 392 217.10.79.9:5060 "Noisy feedback tells:  pid=26584 req_src_ip=62.214.33.3 req_src_port=5060 in_uri=sip:sipgate.de 
    out_uri=sip:sipgate.de via_cnt==1"
    
    
    10 headers, 0 lines
    Destroying call '7d6f58953c04070d3b4a2e09661c950b@62.214.33.3'
    Retransmitting #4 (no NAT):
    REGISTER sip:sipgate.de SIP/2.0
    Via: SIP/2.0/UDP 62.214.33.3:5060;branch=z9hG4bK7bfb3e67
    From: <sip:9990007@sipgate.de>;tag=as0a13bfe1
    To: <sip:9990007@sipgate.de>
    Call-ID: 7d6f58953c04070d3b4a2e09661c950b@172.31.5.2
    CSeq: 105 REGISTER
    User-Agent: Asterisk PBX
    Expires: 120
    Contact: <sip:9990007@62.214.33.3>
    Event: registration
    Content-Length: 0
    
    Und dieses Spielchen geht 10 mal und wiederholt sich 2 mal pro minute. Und zum Abschluss gibts "Registration for 9990007@sipgate.de timed out".

    Ich habe schon alle Tipps im Forum durch, mit "insecure=very", "nat=yes/no" lokal und global mit localnet und ohne ...

    Allein - es ändert nix.

    Soweit ich die Mitschnitt verstehe, fordert sipgate die Authorisierung an:

    WWW-Authenticate: Digest realm="sipgate.de", nonce="41d96497d2c4d21fbbcc56faa19f13f4fdd0897e"

    Und * müsste antworten mit

    Authorisation Digest username ....

    Tut er aber nicht, stattdessen kommt ein Retransmit des REGISTER paketes. Warum?

    Dadurch, das der WWW-Auth request im sip debug erscheint sollte auch klar sein, dass das Port-Forwardung richtig läuft. Aber was geht hier schief?

    sip.conf
    Code:
    [general]
    port=5060
    bindaddr=0.0.0.0
    externip=zockoll.dyndns.org
    localnet=172.31.5.0/255.255.255.0
    srvlookup=yes
    nat=yes
    tos=lowdelay
    insecure=very
    register => 9990007:XXXXX@sipgate.de/9990007
    context=default
    disallow=all
    allow=alaw
    allow=ulaw
    allow=gsm
    canreinvite=no
    
    [sipgate]
    type=friend
    username=9990007
    secret=XXXXX
    dtmfmode=info
    host=sipgate.de
    context=sip-incoming
    fromuser=9990007
    fromdomain=sipgate.de
    insecure=very
    qualify=no
    nat=yes
    disallow=all
    allow=alaw
    allow=ulaw
    allow=gsm
    canreinvite=no
    
    und extenstion.conf
    Code:
    ...
    [sip-incoming]
     exten => 9990007,1,Dial(CAPI/42:#33,30,tr)
    
    
    Ich bin für jeden Tipp dankbar.

    Viele Grüße und ein frohes neues Jahr

    Guido
     
  2. diabolos05

    diabolos05 Neuer User

    Registriert seit:
    30 Dez. 2004
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Re: asterisk antwortet nicht auf sipgate authorisierungs-anf

    Hallo,

    ich bin zwar auch blutiger Anfänger, aber immerhin kann ich über Sipgate.de raustelefonieren - rein will noch nicht.

    Im Unterschied zu Deiner Konfiguration habe ich nat=no und unter [sipgate] keine secret-Zeile.
     
  3. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    setze das mal in der sip.conf unter [general]:

    maxexpirey=3600
    defaultexpirey=120

    sipgate ist da ein wenig empfindlich!