[Problem] Asterisk Daemon hängt sich in unregelmäßigen Abständen auf

parityman

Neuer User
Mitglied seit
30 Apr 2012
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
Servus zusammen,

ich hab in letzter Zeit massive Probleme mit meinen Telefonanlagen. (Debian 6 32bit, asterisk1,6 aus dem Repository + Gemeinschaft 3.1)

in extrem unregelmäßigen Abständen (2 Monate, oder auch nur 5 Stunden) hängt sich scheinbar der Asterisk-Dienst auf. Hier mal genauer beschrieben: Die Anlage funktioniert also eine Zeit lang einwandfrei und plötzlich starten die Telefone neu, weil sie den Kontakt zur Asterisk verloren haben. Wenn das gerade passiert wenn ein Telefonat reinkommt, dann kann man den Höher zwar abnehmen, es bimmelt aber weiter, genauso könne auch keine Gespräche über Pickup angenommen werden.
Die Telefone starten sich also dann Munter solange neu bis man manuell den Asterisk daemon neustartet (/etc/init.d/asterisk restart). Dieser Neustart dauert auch im Vergleich zu sonst ewig (sicher 10 Sekunden bis der Daemon gestoppt wird). Danach läuft wieder alles einwandfrei sobald die Telefone neu hochgefahren sind. Dies passiert wie oben beschrieben in unterschiedlichsten Abständen. Eine Anlage hat nun von Juni bis letzte Woche Freitag perfekt funktioniert. Am Freitag jedoch das erste mal und heute das zweite mal dann den Geist aufgegeben!. Ich hab nun versuch die anlagen über Nacht neuzustarten (das das ganze System). Dies hat leider jedoch auch keinen Einfluss drauf. Dann habe ich mir gedacht, dass es evtl am Snort und dem portsentry liegen könne und beide gestoppt, jedoch haben auch gerade eben zwei Anlagen im Abstand von einer Stunde die Arbeit eingestellt, also obwohl die snort und portsentry aus war.

Im Log ist nichts zu finden. Und damit meine ich wirklich NICHTS. Ich lasse die den Asterisk Daemon mit "vvv" laufen, wo man wirklich alles ausgehrben bekommt, aber sobald der Daemon hängt bleibt das Log komplett leer.


Ich bin langsam mit meinem Latein am Ende, vor allem weil ich das Problem nicht reproduzieren kann und immer drauf warten muss bis es wieder passiert. Dann ist jedoch natürlich nicht viel Zeit weil die Leute wieder arbeiten müssen.

Jemand einen Tipp für mich, was ich unbedingt testen sollte wenn es das nächste mal passiert? schaun ob ich mich per "asterisk -r" auf den Daemon schalten kann? (mache ich bisher nicht, da ich die ganze ausgabe immer umleiten lasse in eine Datei)

edit: allerdings wurde mir übers webinterface immernoch alle Telefone als Online bzw "Frei" angezeigt. der Asterisk Daemon war also zumindest über die cli wie es scheint ansprechbar...


Danke!


Gruß,
Philipp
 
Zuletzt bearbeitet:
F

foschi

Guest
Ich vermute mal ne Menge snom-Geräte mit BLF, korrekt? Das Thema hatten wir doch schon öfter auf der [gs3-users]-Mailingliste, und die hängenbleibenden Kanäle bzw. der deadlock des Asterisk ist ja auch bekannt. Sascha Daniels hatte dazu an vielen Stellen ja bereits etwas geschrieben.

Da ich bei Dir (mehrere Anlagen von denen Du sprichst) einen nicht-privaten Kontext vermute erkundige Dich doch mal bei den Firmen, die das Thema beherrschen (durch Erweiterungen/strukturelle Änderungen), oder mach nen Backport zu 1.4.

Ich kann nur sagen, dass ich viele Installationen mit Asterisk, snom 3xx und Mediengateways habe, bei denen > 100 Endgeräte problemlos laufen. ;-)
 
Zuletzt bearbeitet von einem Moderator:

parityman

Neuer User
Mitglied seit
30 Apr 2012
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
Hi foschi und danke für deine Antwort,

also wir reden hier von 4 snom Telefonen pro TK-Anlage, d.h. auch nur 3 BLF Tasten pro Telefon, das ganze System Idelt sich zu Tode, kann doch eigentlich nicht sein, oder?
 
F

foschi

Guest
Bei Asterisk kann es eine Menge Ursachen geben (nicht alle kann man erkennen), aber ich gebe Dir Recht: das ist ungewöhnlich. Wenn Du wirklich Gemeinschaft 3.1 installiert hast (mit allen Komponenten die dort vorgesehen sind, also auch der dort eingebundenen Asterisk-Version) kommt dies normalerweise nicht vor. Sind die Systeme virtualisiert? Falls ja, reale HW testen.
 

parityman

Neuer User
Mitglied seit
30 Apr 2012
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
ja, Gemeinschaft wurde über das installscript installiert. die "eingebundene asterisk-version" ist die einfache 1.6er aus dem debian repository, da das installscript nix anderes macht als eben diese zu installieren. Ein System davon ist virtualisiert, die anderen zwei sind direkt auf eigener HW. Das virtualisierte System hat am längsten durchgehalten :)

kann ich denn die Deadlocks irgendwie erkennen? kann ich mir offene Sessions oder sowas anschaun, die dann auf so ein problem hindeuten können?
 

parityman

Neuer User
Mitglied seit
30 Apr 2012
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
ein Downgrade der Asterisk version von 1.6 auf 1.4 ist ja alles andere als spassig, vorallem so das das das ganze drumherum noch funktioniert...hab für sowas im Moment auch irgendwie überhaupt keine zeit...
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,118
Beiträge
2,030,332
Mitglieder
351,468
Neuestes Mitglied
stefanru