.titleBar { margin-bottom: 5px!important; }

Asterisk - ISDN legt sofort auf

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von maretz, 17 Okt. 2008.

  1. maretz

    maretz Neuer User

    Registriert seit:
    17 Okt. 2008
    Beiträge:
    1
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Moin zusammen,

    folgendes Problem: Ich möchte eine Asterisk-Anlage dazu verwenden mehrere Standorte miteinander zu verbinden. Die Verbindung über IAX2 steht bereits, SIP-Telefone können auch schon problemlos telefonieren. Ebenfalls kann ich mit einem SIP-Telefon problemlos jedes beliebige ISDN-Telefon erreichen.

    Soweit zum guten Teil, jetzt kommt mein Problem: Wenn ich versuche mich über die Telefonanlage (Alcatel OmniPBX 4400) an der Asterisk anzumelden dann legt der ISDN-Kanal sofort auf:

    == ISDN1#02: Incoming call '129' -> '372'
    -- Executing [372@capi-in:1] DISA("CAPI/ISDN1#02/372-1a", "no-password|sip-telefone") in new stack
    == ISDN1#02: Answering for 372
    > ISDN1#02: CAPI INFO 0x3490: Normal call clearing
    == Spawn extension (capi-in, 372, 1) exited non-zero on 'CAPI/ISDN1#02/372-1a'
    -- Executing [h@capi-in:1] NoOp("CAPI/ISDN1#02/372-1a", "16") in new stack
    == ISDN1#02: CAPI Hangingup for PLCI=0xdead0000 in state 4

    (im Beispiel ist 129 meine Interne Nummer, 372 ist die Nummer der Asterisk)

    Dazu gehört folgender Context:

    context capi-in {
    372 => {
    DISA(no-password|sip-telefone);
    };

    h => {
    NoOp(${HANGUPCAUSE});
    };
    }

    context sip-telefone {
    129 => {
    Wait(1);
    Dial(SIP/129,20,rj);
    Hangup();
    };
    };


    Ich bin für jeden Hinweis oder Lösungsvorschlag offen... Derzeit befindet sich das System eh im Test, d.h. kein Problem alles auszuprobieren was helfen kann. Selbstverständlich kann ich auch alle anderen Konfigs posten wenn die irgendwie helfen könnten...

    Danke & Gruß,

    ein verzweifelter Mike
     
  2. m.goegel

    m.goegel Mitglied

    Registriert seit:
    15 Juni 2005
    Beiträge:
    288
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Kann es sein, dass du in der Alcatel einfach vergisst, auf MFV Wahl umzustellen und die Verbindung wegen Falschwahl rausfliegt?
    Frag' ja nur ;-) ...

    mach' mal:
    PHP:
    set verbose 5
    capi debug
    Wie sieht der Trace dann aus?