.titleBar { margin-bottom: 5px!important; }

asterisk kann über sipgate nicht angerugen werden

Dieses Thema im Forum "sipgate" wurde erstellt von anfänger, 10 Dez. 2004.

  1. anfänger

    anfänger Neuer User

    Registriert seit:
    21 Okt. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hallo
    ich ahbe das problen das ich zwar mot asteriks raustelefonieren aber nicht angerufen werden kann da sipgate anscheinend eine user mit der telefonnummer des anrufenden kontaktieren will, den es aber logischerweise nicht gibt. hat einer ne ahnung was man da machen kann?
    Code:
    Dec 10 12:05:49 NOTICE[-185234512]: chan_sip.c:7231 handle_request: Failed to authenticate user "Telnummer" <sip:03026557569@195.226.161.164>;tag=as2bcf99d9
    
    danke anfänger
     
  2. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    das ist weder die IP von sipgate.net noch sipgate.de: 195.226.161.164 (ich vermute dies ist deine dynamische IP)

    setze mal unter general: nat=yes und dies auch in den Providerdefinitionen!

    ansonsten poste mal deine sip.conf zur Klarheit!
     
  3. anfänger

    anfänger Neuer User

    Registriert seit:
    21 Okt. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ja das ist meine ip

    sipgate steht allerdings auf nat =yes

    Code:
     [general]
        port = 5060
        bindaddr = 0.0.0.0
        externip = laible.no-ip.com
        Localnet = 192.168.0.0/255.255.0.0
        srvlookup = yes
        context = default
        disallow=all
        allow=gsm
        register => @sipsnip.com/sipsnip
        register => @sipgate.de/
        canreinvite=no
        tos=0x18
        insecure=very
        nat=no
        dtmfmode=info
    
        [sipsnip]
        type=friend
        username=user
        secret=secret
        host=sipsnip.com
        fromuser=user
        fromdomain=sipsnip.com
        context=default
        canreinvite=no
    ;    qualify=5000
        disallow=all
        allow=all
        insecure=very
        nat=no
    ;    dtmfmode=info
    ;    tos=0x18 
    	
    
    
    [sipgate]
    type=friend
    username=9990824
    secret=secret
    host=sipgate.de
    fromuser= 9990824
    fromdomain=sipgate.net
    nat=yes
    ;dtmfband=inband
    context=default
    canreinvite=no     
    ;tos=0x18
    ;qualify=yes
    ;disallow=all
    ;allow=all
    ;nat=no
    ;dtmfmode=info
    
    
        [pl]
        type=friend
        username=
        secret=
        host=dynamic
        context=default
        canreinvite=no
        qualify=yes
        disallow=all
        allow=all
        nat=no
    
    danke anfänger
     
  4. otaku42

    otaku42 Admin-Team

    Registriert seit:
    26 März 2004
    Beiträge:
    1,670
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
     
  5. anfänger

    anfänger Neuer User

    Registriert seit:
    21 Okt. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    [general]
    ...
    nat=no
    ...
    [/quote]


    nat=yes bringt das seble ergebnis.


    ich hab noch nicht alzu viel ahnung aber das problem ist doch das sipgate probiert einen user zu kontaktieren, den es nicht gibt.

    es wird wersucht tetnummerdesanrufers@meinserver zu konaktieren. doch ich kann nicht für jeden potentiellen anrufer einen user einrichten.


    ich habe zu testzwechen einen user eingerichtet mit einer externen nummer von der ich anrufe dann nimmt asterisk den anruf entgegen.

    es müsste also ein user problen kein nat problen. bei sipsnip kann ich über die 0180er nummer angerufen werden.

    anfänger
     
  6. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Dir fehlt unter [general] ein

    register => 8xxxxxx:passw@sipgate.de/8xxxxxx

    und in der extension.conf:

    exten => 8xxxxxx,1,Dial(...)

    Nat=yes unter [general] ist ein muss!
     
  7. anfänger

    anfänger Neuer User

    Registriert seit:
    21 Okt. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    vielleicht hatte meine conf files zu star gestript dehalb hier nochmal:

    extensions.conf
    Code:
    [default]
    include => calls
    
    
    [calls]
    ;telnummer isdn 265XXXXX 
    exten => 265XXXXX,1,Answer
    exten => 265XXXXX,2,SetLanguage(de)
    exten => 265XXXXX,3,Dial(Zap/2/10,20,tT)
    exten => 265XXXXX,4,Voicemail(u26557569)
    exten => 265XXXXX,5,Hangup
    
    ;telnummer isdn 265XXXXX
    exten => 265XXXXX,1,Wait(30)
    exten => 265XXXXX,2,SetLanguage(de)
    exten => 265XXXXX,3,Answer
    exten => 265XXXXX,4,Voicemail(u26557569)
    exten => 265XXXXX,5,Hangup
    ;exten => 265XXXXX,2,Answer
    ;exten => 265XXXXX,3,Dial(Zap/2/10,20,tT)
    
    ;festival test
    exten => 555,1,Answer
    exten => 555,2,Festival( mary had a little lamp)  ; do NOT use quotes around the string!!
    exten => 555,3,Hangup 
    
    ;telnummer 01805004XXXXXX und sipsinp 
    exten => sipsnip,1,Answer
    exten => sipsnip,2,SetLanguage(de)
    exten => sipsnip,3,Dial(Zap/2/10,30,tT)
    exten => sipsnip,4,Voicemail(utest)
    exten => sipsnip,5,Hangup
    
    ;telnummer 868XXXXXX und sipgate
    exten => sipgate,1,Answer
    exten => sipgate,2,SetLanguage(de)
    exten => sipgate,3,Dial(Zap/2/10,60,tT)
    exten => sipgate,4,Voicemail(u26557569)
    exten => sipgate,5,Hangup
    
    ;telnummer 868XXXXX und sipgate
    exten => 868XXXXX,1,Answer
    exten => 868XXXXX,2,SetLanguage(de)
    exten => 868XXXXX,3,Dial(Zap/2/10,60,tT)
    exten => 868XXXXX,4,Voicemail(utest)
    exten => 868XXXXX,5,Hangup
    
    exten => 99XXXX,1,Answer
    exten => 99XXXX,2,SetLanguage(de)
    exten => 99XXXX,3,Dial(Zap/2/10,60,tT)
    exten => 99XXXX,4,Voicemail(u26557569)
    exten => 99XXXX,5,Hangup
    
    ;rauswählen sipsnip
    exten => _8.,1,Dial(SIP/${EXTEN:1}@sipsnip,60,tT)
    exten => _8.,2,Congestion
    exten => _8.,3,Busy
    exten => _8.,4,Hangup
    
    
    ;rauswählen isdn über capi
    exten => _7.,1,Dial(CAPI/26XXXXXX:${EXTEN:1},60,r)
    exten => _7.,2,Congestion
    exten => _7.,3,Busy
    exten => _7.,4,Hangup
    
    ;rauswählen sipgate
    exten => _9.,1,Dial(SIP/${EXTEN:1}@sipgate,30,tr)
    exten => _9.,2,Playback(invalid)
    exten => _9.,3,Hangup 
    
    sip.conf
    Code:
    [general]
        port = 5060
        bindaddr = 0.0.0.0
        externip = laible.no-ip.com
        Localnet = 192.168.0.0/255.255.0.0
        srvlookup = yes
        context = default
        disallow=all
        allow=gsm
        register => laXXXX:XXXXXX@sipsnip.com/sipsnip
        register => 99XXXXX:XXXXXXX@sipgate.de/99XXXXXX
        canreinvite=no
        tos=0x18
        insecure=very
        nat=yes
        dtmfmode=info
    
        [sipsnip]
        type=friend
        username=laiXXX
        secret=XXXXXX
        host=sipsnip.com
        fromuser=laible
        fromdomain=sipsnip.com
        context=default
        canreinvite=no
    ;    qualify=5000
        disallow=all
        allow=all
        insecure=very
        nat=no
    ;    dtmfmode=info
    ;    tos=0x18 
    	
    
    
    [sipgate]
    type=friend
    username=99XXXXX
    secret=XXXXXX
    host=sipgate.de
    fromuser= 99XXXXX
    fromdomain=sipgate.net
    nat=yes
    ;dtmfband=inband
    context=default
    canreinvite=no     
    ;tos=0x18
    ;qualify=yes
    ;disallow=all
    ;allow=all
    ;nat=no
    ;dtmfmode=info
    
        [265XXXXX]
        type=friend
        username=pl
        host=dynamic
        context=default
        canreinvite=no
        qualify=yes
        disallow=all
        allow=all
        nat=no
        mailbox=pl@default
    
    
        [pl]
        type=friend
        username=pl
        secret=XXXXXX
        host=dynamic
        context=default
        canreinvite=no
        qualify=yes
        disallow=all
        allow=all
        nat=no
        mailbox=pl@default
    
        
    die fehlermeldung ist:

    Code:
    Dec 10 18:08:47 NOTICE[-185234512]: chan_sip.c:7231 handle_request: Failed to authenticate user "0160XXXXX" <sip:0160XXXX@195.226.161.164>;tag=as76dddf57
    
    ich habe zu test zwecken von mienem mobiltel auf meine sipgate festnummer angerufen und er probiert einen 0160XXXX (sprich miene mobilnummer) auf meinem server zu erreichen. wenn ich von einer anderen telnummer auf die sipgate nummer anrufe wird versucht diese ander telnummer als user zu kontaktieren.

    Code:
    sip show registry
    Host                            Username       Refresh State
    sipgate.de:5060                 99XXXX            105 Registered
    sipsnip.com:5060                laXXXX             105 Registered
    
    
    ich kann über sipgate raustelefonieren.
    und habe alle möglichen sipgatevariante (nummern usernummern und namen) in die extensions.conf gesteckt aber ohne erfolg

    ach ja wenn der anrufer seine telefonnummer unterdrückt kommt:
    Code:
    Dec 10 18:17:06 NOTICE[-185234512]: chan_sip.c:7231 handle_request: Failed to authenticate user "anonymous" <sip:asterisk@195.226.161.164>;tag=as4c3e137e
    
     
  8. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Warum hast du nachfolgende Einträge in der extension.conf?
    Über die extension 'sipgate' und '868XXXXX' wird imho nie etwas kommen:

    ;telnummer 868XXXXXX und sipgate
    exten => sipgate,1,Answer
    exten => sipgate,2,SetLanguage(de)
    exten => sipgate,3,Dial(Zap/2/10,60,tT)
    exten => sipgate,4,Voicemail(u26557569)
    exten => sipgate,5,Hangup

    ;telnummer 868XXXXX und sipgate
    exten => 868XXXXX,1,Answer
    exten => 868XXXXX,2,SetLanguage(de)
    exten => 868XXXXX,3,Dial(Zap/2/10,60,tT)
    exten => 868XXXXX,4,Voicemail(utest)
    exten => 868XXXXX,5,Hangup

    ich denke dies sollte reichen:

    exten => 99XXXX,1,Answer
    exten => 99XXXX,2,SetLanguage(de)
    exten => 99XXXX,3,Dial(Zap/2/10,60,tT)
    exten => 99XXXX,4,Voicemail(u26557569)
    exten => 99XXXX,5,Hangup

    der Verweis hierauf aus der sip.conf ist:
    register => 99XXXXX:XXXXXXX@sipgate.de/99XXXX
     
  9. anfänger

    anfänger Neuer User

    Registriert seit:
    21 Okt. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    das habe ich nur für die fehlersuche grade drin um das als fehlerquelle auszuschliessen.

    ich glaube auch nicht das es an der extensions.conf leigt. fehlermeldung die mir astersik bringt lässt doch auf ein anderes problem schliessen. da sit was mit absender und enfäger vertauscht!!!!! ider missinterpretiere ich die fehlermeldung. wenn ich mit mienem mobliltel (0160XXXX) nach 030868XXXXX (sipgate) anrufe wird mien asterisk nach einem user mit 0160XXX@meinserver angrfragt und dessen zugriff wird verweigert
    bzw ein user mit 0160XXX@meinserver probiert sich anzumelden doch weder nummer 0160XXX noch user 0160XXX sind bekannt das müsste doch nach 868XXX@mein server gehen. oder bin ich total falsch gepolt? :?
     
  10. stranzenbach

    stranzenbach Neuer User

    Registriert seit:
    29 Aug. 2004
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    incomming von sipgate

    Hallo
    Ich hab die gleiche Problematik gehabt und was gefunden:

    inder sip.conf unter deinem Provider (sipgate ) eintragen
    insecure=very
    das hat bei mir geholfen.