.titleBar { margin-bottom: 5px!important; }

Asterisk newbee, keine ausgehende anrufe.

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von codiak, 26 Nov. 2006.

  1. codiak

    codiak Neuer User

    Registriert seit:
    22 Nov. 2006
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hi alle zusammen!

    bin ebenso newbie im diesem gebiet, aber das forum hat mir echt weitergeolfen!
    ich habe es nach tagelangen herumbasteln so halbwegs mein asterisk server zum laufen überreden können, derzeit sind interne gespräche über x-lite kein problem. natürlich sollten irgendwann auch externe gespräche funktionieren.

    derzeit bekomme ich folgendes in der asterisk console wenn ein teilnehmer externe nummern anwählt:

    Setting NAT on RTP to 4
    Check for res for 20
    Call from user '20' is 1 out of 0
    build_route: Contact hop: <sip:20@192.168.2.2:5060>
    -- Executing SetCallerID("SIP/20-ea44", "43780780788") in new stack
    Timeout, but no rule 't' in context 'default'
    update_user_counter(20) - decrement inUse counter
    Stopping retransmission on '94A96CAA-2E8F-4196-B9A9-19F0BD6869D1@192.168.2.2' of Response 43429: Found



    im x-lite client erscheint: Anruf fehlgeschlagen: 403 Forbidden.

    eingehende anrufe (getestet vom GSM händy aus) funktionieren aber!

    die extension.conf schaut so aus:
    die sip.conf:

    jemand eine idee?


    lg
     
  2. blauerpeti

    blauerpeti Mitglied

    Registriert seit:
    28 Juni 2005
    Beiträge:
    723
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    in der sip.conf [general]
    versuchs mal mit context = default

    oder in der extensions.con:
    füge mal den context [yesss_in]
    mit include in den context [default] ein
     
  3. codiak

    codiak Neuer User

    Registriert seit:
    22 Nov. 2006
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hi blauerpeti!

    danke für dein Vorschlag, leider führen beide nicht zum erfolg Asterisk CLI spuckt quasi die selbe meldung aus:

    Code:
    Setting NAT on RTP to 4
    Check for res for 20
    Call from user '20' is 1 out of 0
    build_route: Contact hop: <sip:20@192.168.2.2:5060>
        -- Executing SetCallerID("SIP/20-dfd8", "43780780788") in new stack
    Timeout, but no rule 't' in context 'default'
    update_user_counter(20) - decrement inUse counter
    Stopping retransmission on '4A555A9D-898E-449B-B5D5-2E9AB26631D4@192.168.2.2' of Response 32048: Found
    
    muss man eventuell noch eine andere config datei miteinbeziehen bei einem voip anruf?! hab bisher nur die extensions.conf und die sip.conf bearbeitet.
     
  4. blauerpeti

    blauerpeti Mitglied

    Registriert seit:
    28 Juni 2005
    Beiträge:
    723
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    na dann versuch mal in der sip.conf
    [20] bzw. [21]
    type = peer

    zu setzen
     
  5. codiak

    codiak Neuer User

    Registriert seit:
    22 Nov. 2006
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hi!

    nöp leider auch nicht. aber jetzt schreibt er in der CLI noch zusätzlich: user not local