Asterisk newbee, keine ausgehende anrufe.

codiak

Neuer User
Mitglied seit
22 Nov 2006
Beiträge
5
Punkte für Reaktionen
0
Punkte
0
hi alle zusammen!

bin ebenso newbie im diesem gebiet, aber das forum hat mir echt weitergeolfen!
ich habe es nach tagelangen herumbasteln so halbwegs mein asterisk server zum laufen überreden können, derzeit sind interne gespräche über x-lite kein problem. natürlich sollten irgendwann auch externe gespräche funktionieren.

derzeit bekomme ich folgendes in der asterisk console wenn ein teilnehmer externe nummern anwählt:

Setting NAT on RTP to 4
Check for res for 20
Call from user '20' is 1 out of 0
build_route: Contact hop: <sip:[email protected]:5060>
-- Executing SetCallerID("SIP/20-ea44", "43780780788") in new stack
Timeout, but no rule 't' in context 'default'
update_user_counter(20) - decrement inUse counter
Stopping retransmission on '[email protected]' of Response 43429: Found



im x-lite client erscheint: Anruf fehlgeschlagen: 403 Forbidden.

eingehende anrufe (getestet vom GSM händy aus) funktionieren aber!

die extension.conf schaut so aus:
[general]
static=yes
writeprotect=yes

[default]
include => sip20
include => sip21
include => yesss_out

[sip20]
exten => 20,1,Dial(SIP/20,25,tT)
exten => 20,2,Hangup

[sip21]
exten => 21,1,Dial(SIP/21,25,tT)
exten => 21,2,Hangup

[yesss_out]
exten => _xxx.,1,SetCallerID(43780xxxxxx)
exten => _xxx.,n,Dial(SIP/${EXTEN:1}@yesss-out)
exten => _xxx.,n,Hangup

[yesss_in]
exten => 43780xxxxxx,1,Dial(SIP/20,30,tT)
exten => 43780xxxxxx,n,Hangup
die sip.conf:

[general]
language=de
port=5060
disallow=all
allow=alaw
allow=ulaw
allow=GSM
nat=no
canreinvite=yes
tos=lowdelay
context=default
register => 43780xxxxxx:p[email protected][/email]/43780xxxxxx
context=yesss_in

[yesss-out]
type=peer
username=43780xxxxxx
fromuser=43780xxxxxx
fromdomain=yesss.at
secret=password
insecure=very
host=sip.yesss.at
qualify=yes

[20]
type=friend
username=20
secret=password
host=dynamic
callerid=cm1 <20>
context=default

[21]
type=friend
username=21
secret=password
host=dynamic
callerid=cm2 <21>
context=default
jemand eine idee?


lg
 

blauerpeti

Mitglied
Mitglied seit
28 Jun 2005
Beiträge
723
Punkte für Reaktionen
0
Punkte
0
in der sip.conf [general]
versuchs mal mit context = default

oder in der extensions.con:
füge mal den context [yesss_in]
mit include in den context [default] ein
 

codiak

Neuer User
Mitglied seit
22 Nov 2006
Beiträge
5
Punkte für Reaktionen
0
Punkte
0
hi blauerpeti!

danke für dein Vorschlag, leider führen beide nicht zum erfolg Asterisk CLI spuckt quasi die selbe meldung aus:

Code:
Setting NAT on RTP to 4
Check for res for 20
Call from user '20' is 1 out of 0
build_route: Contact hop: <sip:[email protected]:5060>
    -- Executing SetCallerID("SIP/20-dfd8", "43780780788") in new stack
Timeout, but no rule 't' in context 'default'
update_user_counter(20) - decrement inUse counter
Stopping retransmission on '[email protected]' of Response 32048: Found
muss man eventuell noch eine andere config datei miteinbeziehen bei einem voip anruf?! hab bisher nur die extensions.conf und die sip.conf bearbeitet.
 

blauerpeti

Mitglied
Mitglied seit
28 Jun 2005
Beiträge
723
Punkte für Reaktionen
0
Punkte
0
na dann versuch mal in der sip.conf
[20] bzw. [21]
type = peer

zu setzen
 

codiak

Neuer User
Mitglied seit
22 Nov 2006
Beiträge
5
Punkte für Reaktionen
0
Punkte
0
hi!

nöp leider auch nicht. aber jetzt schreibt er in der CLI noch zusätzlich: user not local

Setting NAT on RTP to 0
Check for res for 20
20 is not a local user
build_route: Contact hop: <sip:[email protected]:5060>
-- Executing SetCallerID("SIP/20-c7e6", "43780780788") in new stack
Timeout, but no rule 't' in context 'default'
update_user_counter(20) - decrement inUse counter
20 is not a local user
Stopping retransmission on '[email protected]' of Response 37829: Found
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,904
Beiträge
2,028,015
Mitglieder
351,047
Neuestes Mitglied
sboom