[Problem] Asterisk PJSIP Einrichtung funktioniert nicht

Mitglied seit
6 Jun 2021
Beiträge
2
Punkte für Reaktionen
0
Punkte
1
Moin zusammen,

ich wechsele momentan in Asterisk von chan_sip -> pjsip, was auf den ersten Blick in der Doku ganz gewöhnlich aussah. Nach einigem Probieren läuft es leider immernoch nicht. Eine konkrete Fehlermeldung ist für mich nicht erkenntlich.
Asterisk 18 betreibe ich auf einem aktuellen Centos 8.2 und meine pjsip-config sieht wie folgt aus:

Code:
;General settings
[global]
type=global
language=de

[transport-udp]
type=transport
protocol=udp
bind=0.0.0.0

[transport-tcp]
type=transport
protocol=tcp
bind=0.0.0.0



;endpoing registrations
[5555-user]

type=endpoint

transport=transport-udp

;context=zadarma-out

disallow=all

allow=alaw

allow=ulaw

auth=5555-user_auth

aors=5555-user_aor


[5555-user_auth]

type=auth

auth_type=userpass

password=asdaSdwG4ehwrh

username=5555


[5555-user_aor]

type=aor

max_contacts=10

remove_existing=true


Wenn ich in der Asterisk Console das Log Level hochschraube kommt folgende Meldung:

Code:
<--- Received SIP request (530 bytes) from UDP:10.1.1.50:5060 --->
REGISTER sip:10.1.1.2 SIP/2.0
Via: SIP/2.0/UDP 10.1.1.50:5060;branch=z9hG4bK68595b59dd96a5ca
From: "IP-Phone" <sip:[email protected];user=phone>;tag=773c4c169c139c19
To: <sip:[email protected];user=phone>
Contact:<sip:[email protected]:5060;transport=udp;user=phone>
Supported: path
Call-ID: [email protected]
CSeq: 10001 REGISTER
Expires: 3600
User-Agent: IP-Phone
Max-Forwards: 70
Allow: INVITE,ACK,CANCEL,BYE,NOTIFY,REFER,OPTIONS,INFO,SUBSCRIBE,UPDATE,PRACK
Content-Length: 0

Für mich sagt diese Meldung, dass der Asterisk Server eine Request von dem Client erkennt, aber diese nicht anwendet, sondern ggf. ablehnt, weil das IP-Phone den Status bei Registrierung nicht ändert. Mit dem "normalen" SIP hat alles einwandfrei funktioniert.
Hat jemand eine Idee, was ich da falsch eingegeben habe? Selinux habe ich erstmal zum Testen kurzfristig auf permissive gesetzt. Dort gab es bis jetzt auch auch keine Probleme im audit Log. Die IP des IP-Phones habe ich in der Firewall des Asterisk Servers komplett freigegeben.

Epische Grüße
epicgangstafuerAsterisk

[CODE] TAGs [/CODE] gesetzt by stoney
 
Zuletzt bearbeitet von einem Moderator:

sonyKatze

Aktives Mitglied
Mitglied seit
6 Aug 2009
Beiträge
2,941
Punkte für Reaktionen
269
Punkte
83
Jener Log-Eintrag, sagt mir nur, dass ein Paket mit einem SIP-Register empfangen wurde. Nicht mehr und nicht weniger.
  1. Hast Du vielleicht chan_sip noch parallel laufen?
  2. Hast Du bereits das Migrationskript probiert?
 

Zurzeit aktive Besucher

3CX

Statistik des Forums

Themen
238,408
Beiträge
2,112,005
Mitglieder
361,135
Neuestes Mitglied
TLAS22

Erhalten Sie 3CX für 1 Jahr kostenlos!

Gehostet, in Ihrer privaten Cloud oder on-Premise! Ganz ohne Haken. Geben Sie Ihren Namen und Ihre E-Mail an und los geht´s:

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.
oder via