Asterisk <-> Shorewall <-> QSC

Mona

Neuer User
Mitglied seit
14 Aug 2005
Beiträge
123
Punkte für Reaktionen
0
Punkte
0
Ich habe in letzter Zeit immer wieder starke Probleme mit Asterisk und QSC. Es läuft ein, zwei Tage alles einwandfrei und auf einmal kann sich Asterisk nicht mehr mit QSC verbinden. Es kommt zur Fehlermeldung:

chan_sip.c sip_reg_timeout Registration for <XXXXX> timed out, trying again
sip_poke_noanswer: Peer 'qsc' is now UNREACHABLE! Last qualify: 0

In der Firewall werden die Ports 4569, 5060, und 10000-20000 (UDP) direkt auf den Asterisk Server umgelenkt. Ein nslookup zeigt auch, dass das Ziel sip.qsc.de vom Asterisk Server auch gefunden wird.

Hat jemand eine Idee für mich?

Code:
/etc/asterisk/sip.conf
[qsc]
host=sip.qsc.de
context=qsc-incoming
type=peer
dtmfmode=rfc2833
canredirect=no
disallow=all
allow=alaw
allow=ulaw
insecure=very
username=XXXXXXXX
fromuser=XXXXXXXX
secret=XXXXXXXX
qualify=yes
Code:
/etc/shorewall/rules:
(...)
DNAT    INET        LOCAL:10.0.0.2      UDP     4569,5060,10000:20000
 

himpierre

Mitglied
Mitglied seit
18 Apr 2007
Beiträge
316
Punkte für Reaktionen
0
Punkte
0
qualify=yes is ne gaaaanz schlechte Idee.
 

Mona

Neuer User
Mitglied seit
14 Aug 2005
Beiträge
123
Punkte für Reaktionen
0
Punkte
0
Habe ich herausgenommen, hat aber leider nichts an dem Problem geändert. Gleich heute morgen wieder:


Jan 29 09:41:29 NOTICE[2855]: chan_sip.c:5402 sip_reg_timeout: -- Registration for '[email protected]' timed out, trying again (Attempt #890)
Jan 29 09:41:49 NOTICE[2855]: chan_sip.c:5402 sip_reg_timeout: -- Registration for '[email protected]' timed out, trying again (Attempt #891)
Jan 29 09:42:09 NOTICE[2855]: chan_sip.c:5402 sip_reg_timeout: -- Registration for '[email protected]' timed out, trying again (Attempt #892)
Jan 29 09:42:29 NOTICE[2855]: chan_sip.c:5402 sip_reg_timeout: -- Registration for '[email protected]' timed out, trying again (Attempt #893)
Jan 29 09:42:49 NOTICE[2855]: chan_sip.c:5402 sip_reg_timeout: -- Registration for '[email protected]' timed out, trying again (Attempt #894)
(...)



Firewall/Router und Asterisk-Server neu gestartet und alles geht wieder .... ?
 
Zuletzt bearbeitet:

himpierre

Mitglied
Mitglied seit
18 Apr 2007
Beiträge
316
Punkte für Reaktionen
0
Punkte
0
Dann würde ich jetzt mal versuchen die Firewall als Fehlerquelle auszuschliessen. Hast Du die Möglichkeit?
 

Mona

Neuer User
Mitglied seit
14 Aug 2005
Beiträge
123
Punkte für Reaktionen
0
Punkte
0
Leider hat auch eine Regel wonach alle Verbindungen von und zum Asterisk-Server (egal welcher Port) zugelassen werden, das Problem nicht beheben können. Auch heute morgen wieder keine Verbindung zu QSC...
 

PsychoLoKI

Neuer User
Mitglied seit
11 Nov 2007
Beiträge
6
Punkte für Reaktionen
0
Punkte
0
Ich habe seit gestern genau das gleiche Problem. TimeOut beim Registrieren bei QSC. Bislang funzte es prima. Andere SIP, bspw. sipgate, funktionieren problemlos.
 

ipfox

Mitglied
Mitglied seit
22 Nov 2004
Beiträge
242
Punkte für Reaktionen
0
Punkte
0
Liebe Q-DSL home Kundin,
lieber Q-DSL home Kunde,


aus technischen Gründen werden wir am 29.01.2008 gegen 5.00 Uhr in unserem IP-Netz ein Software-Update vornehmen. Während des Wartungsfensters wird für ca. 10 Minuten mit IPfonie privat keine Telefonie möglich sein.

Wichtige Info für alle Kunden, die IPfonie privat in Verbindung mit einer Asterisk-Lösung nutzen: Bitte nehmen Sie im Zusammenhang mit dem Wartungsfenster folgende Änderung in der Konfiguration Ihres Anschlusses vor, um die Funktion Ihres Produktes sicherzustellen:

In der sip.conf Datei im Abschnitt [general] ist der Parameter "pedantic" auf "yes" zu setzen:

Syntax
pedantic=yes

Description
Enable slow, pedantic checking of Call-ID:s, multiline SIP headers and URI-encoded headers.

Wir danken Ihnen für Ihr Mitwirken!

Ihr
Q-DSL home Team
 

mfehleisen

Mitglied
Mitglied seit
24 Jun 2004
Beiträge
582
Punkte für Reaktionen
2
Punkte
18
Wir haben mit unserem Trunk und der ITK-Anlage (DeTeWe X320) keine Probleme mit den QSC Leitungen.
Läuft es seit den Änderungen bei Euch mit den * wieder?

-Matthias
 

PsychoLoKI

Neuer User
Mitglied seit
11 Nov 2007
Beiträge
6
Punkte für Reaktionen
0
Punkte
0
Mit der pedantic=yes option läuft es seit gestern wieder.
 

Mona

Neuer User
Mitglied seit
14 Aug 2005
Beiträge
123
Punkte für Reaktionen
0
Punkte
0
Bei mir leider nicht, jeden Tag aufs Neue, das gleiche Problem :(

chan_sip.c:5402 sip_reg_timeout: -- Registration for '[email protected]' timed out, trying again (Attempt #1472)
(...)

Offensichtlich tritt das Problem jetzt jedesmal auf, sobald QSC die Verbindung trennt und sich der Router neu einwählen muss....