.titleBar { margin-bottom: 5px!important; }

Asterisk und vServer -> AGI sehr langsam

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von Snuff, 25 Jan. 2007.

  1. Snuff

    Snuff Aktives Mitglied

    Registriert seit:
    23 Juni 2006
    Beiträge:
    1,149
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Softwareentwickler/Ausbilder
    Ort:
    65529 Waldems (Taunus)
    Hallo zusammen,

    ich habe momentan einen vServer von Schramm e.K. mit 196 MB RAM, 200% CPU Leistung und 4 GB HD. Das ganze läuft mit Suse 9.3 und Asterisk 1.2.14

    Was ich festgestellt habe, das bei eingehenden Anrufen es relativ lange dauert bis das Reverse Lookup AGI Script (für dasoertliche.de) abgearbeitet ist und der Anruf am Endgerät signalisiert wird.

    Die Virtualisierungsplattform ist Virtuozzo von SWSoft. Ich werde jetzt nochmal testweise ein Upgrade auf 256 MB, 300% CPU Leistung bekommen und schauen ob es dann besser läuft.

    Wie ist eure Erfahrung mit den Asterisk Installationen (speziell mit den AGI-Scripten) auf vServern? Die Grundfunktionen laufen ja alle ohne Probleme

    Gruß Snuff
     
  2. merlion

    merlion Mitglied

    Registriert seit:
    22 Aug. 2004
    Beiträge:
    202
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ich habe mit vserver grundsätzlich nicht so gute erfahrung wenn der Ram festgelegt ist. Am besten fand ich Vserver wo der gesamte RAM Shared ist.

    Mein Vserver bei Server4you ist völlig unbrauchbar als Asterisk gewesen. Alle 6 Stunden gab es einen Ausfall für 30 Min. Immer um 12 und 0 Uhr und um 6 und 18 Uhr alles völlig tot.

    Ich vermute aber eher das es an dasoertliche liegt und das es einfach seine Zeit braucht bis dein Asterisk das Ergebnis der Abfrage vorliegen hat.

    Was fragst du denn dort ab ?
     
  3. Snuff

    Snuff Aktives Mitglied

    Registriert seit:
    23 Juni 2006
    Beiträge:
    1,149
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Softwareentwickler/Ausbilder
    Ort:
    65529 Waldems (Taunus)
    Ich frage dort den Anrufernamen anhand der Rufnummer ab (AGI-Script gibt´s hier irgendwo im Forum). Wenn ich das ganze auf meinem lokalen Asterisk gemacht hab, ging das ohne Probleme und sehr schnell. Nur auf dem vServer ist das jetzt nicht wirklich brauchbar. Naja werd ich nochmal 80 EUR in die Hand nehmen und mir bei eBay nen "neuen" Mini-PC holen

    Gruß Snuff