Auf NTFS-Partition werden nicht alle Dateien erkannt

Belgarathfloz

Neuer User
Mitglied seit
25 Jan 2006
Beiträge
17
Punkte für Reaktionen
0
Punkte
0
Hi,

ich habe das Problem, dass nicht alle Dateien meiner externen Festplatte, die an der Box hängt, erkannt werden; schliesse ich die Platte direkt an den Rechner, dann zeigt er mir alle Dateien an. Greife ich nun auf den selben Ordner via Samba oder FTP zu, wenn die Platte an der Box hängt, so fehlen einige Dateien.
Im Log steht dazu soetwas:

Oct 4 13:31:21 fritz daemon.notice ntfs-3g[11269]: Skipping unrepresentable filename (inode 627): Invalid or incomplete multibyte or wide character

Ich habe mal spasseshalber probiert eine Datei umzubenennen und dabei Umlaute einzufügen, also statt "Aufgabe1" dann "Aufgabeü"; dies hat nicht funktioniert. Setze ich allerdings statt "ü" ein "u" so gibt es keine Probleme. Ich habe keine Ahnung, was das zu bedeuten hat, aber nach ein wenig Googlen bin ich hierauf gestossen: Link.
Allerdings hilft mir das auch nicht sehr viel weiter, aber es hat wohl mit der Spracheinstellung zu tun?

Bye,
Floz
 

Belgarathfloz

Neuer User
Mitglied seit
25 Jan 2006
Beiträge
17
Punkte für Reaktionen
0
Punkte
0
Kommt Leute, dass MUSS doch aufgefallen sein, oder?
 

McNetic

Mitglied
Mitglied seit
7 Feb 2007
Beiträge
674
Punkte für Reaktionen
0
Punkte
16
Wenn Du mal ein bisschen gegoogelt hättest, hättest Du auch selber rausfinden können, woran das Problem hängt. Hier gibt einen FAQ-Eintrag zu dem Thema. Da sind auch verschiedene Workarounds angegeben.
Ich bin mir allerdings nicht ganz sicher, wie eine 'richtige' Lösung für das Problem aussehen soll (richtig im Sinne von 'es funktioniert automatisch').
 

Belgarathfloz

Neuer User
Mitglied seit
25 Jan 2006
Beiträge
17
Punkte für Reaktionen
0
Punkte
0
Genau die Seite habe ich auch gefunden, siehe meinen Post, allerdings nützt mir das wenig, da ich nicht weiss, wie ich das anwenden kann, was da sehr theoretisch vermittelt wird.
Tut mir Leid, wenn ich so blöde war und gedacht hätte, mir würde jemand eine Antwort auf meine Frage geben. Ich habe einfach keine Ahnung, wie ich das in Freetz umsetze, da nützt mir auch jegliches googlen nichts.
 

McNetic

Mitglied
Mitglied seit
7 Feb 2007
Beiträge
674
Punkte für Reaktionen
0
Punkte
16
Sorry, ich hatte nicht gesehen, daß Du das auch schon gepostet hattest.
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Tut mir Leid, wenn ich so blöde war und gedacht hätte, mir würde jemand eine Antwort auf meine Frage geben. Ich habe einfach keine Ahnung, wie ich das in Freetz umsetze, da nützt mir auch jegliches googlen nichts.
Wenn jemand hier rein schaut und eine Antwort weiß, dann bekommst du auch eine. Ich kann dir keine Antwort geben, weil ich keine Ahnung habe wie man das beheben könnte.

MfG Oliver
 

Kneipenterroris

Neuer User
Mitglied seit
6 Nov 2006
Beiträge
20
Punkte für Reaktionen
0
Punkte
0
Ich habe da gestern auch schon ein wenig gesucht, nur bin ich mit der Dev-Struktur von freetz nicht so ganz vertraut und verstehe den build-Ablauf auch nicht so ganz, damit ich da selbst eingreifen könnte.
Man müsste wohl beim Mounten von ntfs-3g Partitionen die Option locale=de_DE.UTF-8 mit angeben.
An welcher Stelle in der source könnte man das wohl machen?
 

Silent-Tears

IPPF-Promi
Mitglied seit
3 Aug 2007
Beiträge
7,456
Punkte für Reaktionen
0
Punkte
0
Das verifiziere bitte auf deiner Box mit der Kommandozeile. (ssh oder telnet) über ein remount der Partition, um zu sehen, ob es dann funktioniert.

Code:
mount -oremount,locale=.......
 

Kneipenterroris

Neuer User
Mitglied seit
6 Nov 2006
Beiträge
20
Punkte für Reaktionen
0
Punkte
0
Meine Box zeigt sich davon irgendwie recht unbeeindruckt. Sowohl vor als auch nach dem Remount zeigt die Ausgabe von Mount folgendes:

Code:
/dev/sda2 on /var/media/ftp/uStor02 type fuseblk (rw,user_id=0,group_id=0,allow_other)
Die locale-Option müsste doch angezeigt werden, oder?!?

EDIT:

Habe jetzt bei mir lokal gesehen dass es wohl doch nicht angezeigt werden muss. Also scheinbar ist der remount mit Änderung der locale akzeptiert worden, trotzdem werden keine Umlaute angezeigt.
Das "Problem" scheint auch weit verbreitet, sagt zumindest google, aber mit der Option locale kann es wohl überall behoben werden :-(
Hat noch jemand eine Idee?
 
Zuletzt bearbeitet:

ralfjani

Neuer User
Mitglied seit
14 Dez 2007
Beiträge
44
Punkte für Reaktionen
0
Punkte
0
Hai,

bin mir jetzt nicht so ganz sicher, aber die locale müssen um verwendet zu werden doch installiert sein. Sind sie das?

gruss
 

Kneipenterroris

Neuer User
Mitglied seit
6 Nov 2006
Beiträge
20
Punkte für Reaktionen
0
Punkte
0
Guter Tipp... Ich hab mir jetzt ein neues Firmware-Image gebaut und das utf8 Kernelmodul mit rein, trotzdem läuft der mount-Befehl ins leere bzw. es ändert sich nichts an der Anzeige der Dateien mit Umlauten.
Hat noch jemand Ideen?
 

Kneipenterroris

Neuer User
Mitglied seit
6 Nov 2006
Beiträge
20
Punkte für Reaktionen
0
Punkte
0
Ich weiss, man antwortet nicht auf seine eigenen Antworten... Aber ich bin mir nicht sicher wie ich mich hier weiter verhalten soll.
Ich komme hier leider nicht weiter. Es werden nach wie vor keine Umlaute auf NTFS-Speichern erkannt, scheinbar muss echt die locale nachinstalliert werden, ich wüsste aber leider nicht mal wie.
Kann mir dazu jemand einen Tipp geben? Ich würde das gerne testen und auch die Ergebnisse hier melden, damit alle was davon haben.
Oder wäre es hier sinnvoller ein Ticket zu eröffnen?
 

Silent-Tears

IPPF-Promi
Mitglied seit
3 Aug 2007
Beiträge
7,456
Punkte für Reaktionen
0
Punkte
0
Hast du den Kernel nach Aktivierung von UTF8 neu gebaut? Ist das Modul auf der Box gelandet danach?
 

Kneipenterroris

Neuer User
Mitglied seit
6 Nov 2006
Beiträge
20
Punkte für Reaktionen
0
Punkte
0
Hast du den Kernel nach Aktivierung von UTF8 neu gebaut? Ist das Modul auf der Box gelandet danach?
ok ok... Jetzt überforderst Du mich ;)
Ich nehme an, dass ich bei make irgendwie sagen muss dass der Kernel neu gebaut werden soll?!?
Und wie stelle ich anschließend auf der Box fest ob das Kernelmodul drin ist?
 

Silent-Tears

IPPF-Promi
Mitglied seit
3 Aug 2007
Beiträge
7,456
Punkte für Reaktionen
0
Punkte
0
make kernel-dirclean && make
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Ich würde erstmal auf der Box nachschauen, ob das Modul da ist. Kernel-Modul finden sich normalerweise in /lib/modules/...

MfG Oliver
 

Kneipenterroris

Neuer User
Mitglied seit
6 Nov 2006
Beiträge
20
Punkte für Reaktionen
0
Punkte
0
Hier der Inhalt von /lib/modules/2.6.13.1-ohio/kernel/fs/nls nach dem Kernel neu Bauen:

Code:
-rwxr-xr-x    1 root     root         6888 Aug 18 10:14 nls_cp437.ko
-rwxr-xr-x    1 root     root         6028 Aug 18 10:14 nls_cp850.ko
-rwxr-xr-x    1 root     root         5176 Aug 18 10:14 nls_iso8859-1.ko
-rwxr-xr-x    1 root     root         5752 Aug 18 10:14 nls_iso8859-15.ko
-rwxr-xr-x    1 root     root         2926 Oct 13 17:54 nls_utf8.ko
Der Befehl
Code:
mount -oremount,locale=de_DE.utf-8 /dev/sda1
führt trotzdem nicht zum Erfolg, die Dateien mit Umlauten sind nach wie vor kommentarlos ausgeblendet.

Das syslog sagt nach dem Anstecken folgendes:
Code:
usb 1-1: new full speed USB device using ahci and address 2
SCSI subsystem initialized
Initializing USB Mass Storage driver...
USB Mass Storage device (0d49:3200) detected...
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
  Vendor: Maxtor    Model: 3200              Rev: 0344
  Type:   Direct-Access                      ANSI SCSI revision: 04
SCSI device sda: 625142448 512-byte hdwr sectors (320073 MB)
sda: assuming drive cache: write through
SCSI device sda: 625142448 512-byte hdwr sectors (320073 MB)
sda: assuming drive cache: write through
 sda: sda1 sda2
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
usb-storage: device scan complete
[speedup] -> 62.5 MHz
fuse init (API version 7.8)
fuse distribution version: 2.7.4
[speedup] -> 125 MHz
[avm_power]event: 27 not handled
[speedup] -> 62.5 MHz
[speedup] -> 125 MHz
[speedup] -> 62.5 MHz
[speedup] -> 125 MHz
[speedup] -> 62.5 MHz
[speedup] -> 125 MHz
Hilft Euch das zum Debuggen?
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Naja. Das Modul ist mal da. Jetzt müsstest du noch schauen, ob es auch geladen ist und verwendet wird.

MfG Oliver
 

RalfFriedl

IPPF-Urgestein
Mitglied seit
22 Apr 2007
Beiträge
12,343
Punkte für Reaktionen
0
Punkte
0
"locale=de_DE.utf-8" sieht nicht nach Kernel NLS-Modul aus, sondern nach User-Space locale. Da NTFS auch über User-Space läuft, ist das auch plausibel.
Demnach wäre die Frage, ob die C-Library überhaupt locale unetrstützt, und ob es eines für UTF-8 gibt.
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Hm, okay. Ich wüßte nicht, dass wir uClibc mit locales support kompilieren.

MfG Oliver
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,831
Beiträge
2,027,213
Mitglieder
350,919
Neuestes Mitglied
patka