Ausgehendes Gespräch: Auflegen klappt nicht so richtig!

hank

Neuer User
Mitglied seit
8 Apr 2004
Beiträge
73
Punkte für Reaktionen
0
Punkte
6
War gerade im Urlaub, komme zurueck und mein Phone geht nicht (403 bei outbound calls). Nach kurzer Suche im Forum lerne ich natuerlich von der sipgate Aenderung bei der die sipgate ID im REGISTER nach dem / mitgeschickt werden muss (nicht meine interne ID). Schnell geaendert und danach ab zum testen (jetzt kommt mein Problem):

- vom Handy zur sipgate nummer: es klingelt (also alles ok), ich lege am handy auf, klingeln hoert auf. Alles ok.
- vom Telefon das Handy angerufen: es klingelt, ich lege am telefon aus, das Handy klingelt weiter!!! Nach 60 sec hoert es auf (weil dann die Mailbox drangeht), und ich habe 6min 38sec stille auf dem Band...
Das Gespraech wurde mir natuerlich vollkommen in Rechnung gestellt, obwohl von meinem User-Verhalten her ich aufgelegt hatte, bevor ein Gespraecht zustande gekommen ist (habe ja am Handy nicht abgenommen).

Frage: Was ist hier passiert??? Nach dem Auflegen schickt doch der ATA ein BYE an Asterisk, und der sollte dann doch den sipgate call dichtmachen, oder? Ich hatte leider nicht geschaut, ob es laut Asterisk noch ein Gespraech gab (show inuse)...

Wie kann ich so was in der Zukunft verhindern? Kann ja schon mal sein, dass man auflegt, bevor der andere abnimmt...
 

Hupe

Aktives Mitglied
Mitglied seit
8 Apr 2004
Beiträge
2,586
Punkte für Reaktionen
0
Punkte
0
Vielleict ne zu alte Version von Asterisk. Da gab es mal einen Bug mit app_dial. Da würde dann nur ne neuere Version von Asterisk helfen. (bei mir war das die einzige Möglichkeit).
 

hank

Neuer User
Mitglied seit
8 Apr 2004
Beiträge
73
Punkte für Reaktionen
0
Punkte
6
Momentane version:
milkyway*CLI> show version
Asterisk CVS-05/31/04-22:00:51 built by [email protected] on a i686 running Linux

Ich versuche halt immer, die Debian Paketverwaltung nicht mit selbstkompilierten Paketen durcheinander zu bringen (Ausnahme: Kernel und wo es nicht anders geht). Daher kommt meine momentane instanz von backports.org. Kennt jemand eine bessere debian apt-source?
 

Hupe

Aktives Mitglied
Mitglied seit
8 Apr 2004
Beiträge
2,586
Punkte für Reaktionen
0
Punkte
0
Jo, wird wohl an der Version liegen. Der Bug wurde (glaube ich) irgendwann im Juli gefixt.
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,121
Beiträge
2,030,349
Mitglieder
351,472
Neuestes Mitglied
xyz.53