.titleBar { margin-bottom: 5px!important; }

[Problem] Autoprovisionierung per SSL schlägt wg. falscher Zeiteinstellung fehl

Dieses Thema im Forum "snom" wurde erstellt von flaaabes, 5 Jan. 2012.

  1. flaaabes

    flaaabes Neuer User

    Registriert seit:
    22 Aug. 2005
    Beiträge:
    30
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Zusammen,

    Ich habe hier ein Snom 820 (FW 8.4.32) stehen, welches sich seine Provisionierungsdaten von einem Server mit SSL-Verschlüsselung holen soll. Dies schlägt jedoch fehl, bzw. das Snom schaltet nach einigen Versuchen automatisch von https auf http um.

    Ich glaube das Problem liegt daran, dass das Telefon erst versucht die verschlüsselte Verbindung aufzubauen und dann erst den NTP-Server abfragt bzw. die richtige Zeit einstellt.
    Code:
    [1] 24/12/2001 00:00:34: TLS: Refusing TLS connection. Invalid or unknown Certificate received
    Erst einige Zeit später schaltet das Telefon dann auf die richtige Zeit um:
    Code:
    [2] [2] 24/12/2001 01:01:00: Registered at registrar as 12345@sipserver.com (Expires: 300 secs)
    [2] 5/1/2012 10:32:46: start_dst(1332640800) end_dst(1351393200) offset_dst(3600) offset_utc(3600)
    Das SSL-Zertifikat des Provisionierungsservers war natürlich 2001 noch nicht gültig. Hat jemand eine Idee warum das so ist oder bin ich komplett auf dem falschen Dampfer?

    (Firmwareabhängig scheint das Problem übrigens nicht zu sein, ein Downgrade hat auch keine Besserung gebracht.)
     
  2. anmeldungsnerv

    anmeldungsnerv Neuer User

    Registriert seit:
    10 Nov. 2007
    Beiträge:
    30
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Naja - es ist nicht genau das selbe:

    allerdings tritt ein aehnlicher Fehler auch auf, wenn man OpenVPN benutzt und sich per WLAN verbinden will - die Zeitabfrage an den NTP Server ganz am Anfang geht scheinbar nicht ueber WLAN, sondern nur ueber den Ethernet port raus - daher klappt die Verbindung nicht und alle Certs vom OpenVPN sind auch noch nicht gueltig.

    Ein Workaround bei den SSL-Certs koennte sein, dass man bei 'http://IP/certificates_unknown_certs.htm' die Zertifikatabfrage aktiviert und dann eine Ausnahme hinzufuegt, oder?

    Cheers

    anmeldungsnerv
     
  3. ProudLion

    ProudLion Neuer User

    Registriert seit:
    16 Feb. 2011
    Beiträge:
    65
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hallo,
    ich habe ein ähnliches Problem.

    Bei ZERTIFIKATE
    Country: ; State: ; Locality ; Organization: ; Common Name: app.placetel.de; eMail:

    Bei Klick auf "Ausnahme hinzufügen"

    kommt nur:
    "Sicherheitswarnung !
    Sie oder ein anderer Anwender haben eine nicht authorisierte HTTP POST Anfrage an dieses Telefon geschickt.

    Diese Anfrage wurde verworfen und die bestehende authentifizierte Sitzung geschlossen.

    Sie müssen sich erneut anmelden, um die Webseite des Telefons zu benutzen. "


    Obwohl ich korrekt angemeldet bin. Hat da jemand eine Idee?

    PS: Uhrzeit/Datum im Telefon sind korrekt.

    VG