.titleBar { margin-bottom: 5px!important; }

blueSIP & Asterisk

Dieses Thema im Forum "blueSIP" wurde erstellt von betateilchen, 2 Aug. 2004.

  1. betateilchen

    betateilchen Grandstream-Guru

    Registriert seit:
    30 Juni 2004
    Beiträge:
    12,882
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    am Letzenberg
    Hallo !

    So - ich bin nun mal einen Schritt weiter. Die folgenden Bluesip-Nummern kann ich nun auch von meinem Asterisk aus erreichen, aber mit anderen VoIP-Nummern sieht es noch irgendwie schlecht aus. Das einzige, was zu funktionieren scheint, sind Rufnummern von Sipgate.

    Rufnummern von BlueSip zum Testen
    Code:
    	
    
    Echo Test          +49 89 721010 99701
    Signalton          +49  89 721010 99702
    blueSIP Song    +49 89 721010 99703
    
    

    sip.conf
    Code:
    
    register => bluesip/user:passwort@bluesip.net/bluesip
    
    [bluesip]
    type=friend
    username=bluesip/user
    fromuser=user
    secret=passwort
    host=bluesip.net
    context=default
    fromdomain=bluesip.net
    auth=md5,plaintext
    qualify=yes
    canreinvite=no
    nat=no
    
    
    extensions.conf
    Code:
    
    ; Anrufe über BlueSip mit *5 als Vorwahl
    exten => _*5.,1,Dial(SIP/${EXTEN:2}@bluesip,60,tr)
    
    
     
  2. kandy

    kandy Neuer User

    Registriert seit:
    19 Feb. 2005
    Beiträge:
    61
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    I am not able to use bluesip with asterisk
    I am behing a router and I receive the following error

    Got SIP response 479 "Please don't use private IP addresses" back from 217.74.179.29

    I am currently use the last cvs
     
  3. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Are vou using 'externip=dyndns-service' under [general] in der sip.conf?
    The message you have received, means that your * includes local-ip adresses in the sip-header which are not routed/supported out of your local network (LAN)! Therefor, * gets his public IP via the externip parm in combination with a dyndns-service!
     
  4. kandy

    kandy Neuer User

    Registriert seit:
    19 Feb. 2005
    Beiträge:
    61
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    No, I do not use externip but I tried and I have the same result
     
  5. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Okay - can you please give us your settings specially the sip.conf and extensions.conf!
     
  6. kandy

    kandy Neuer User

    Registriert seit:
    19 Feb. 2005
    Beiträge:
    61
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    sip.conf

    general]
    context=local
    port=5060
    bindaddr=0.0.0.0
    srvlookup=no
    tos=lowdelay ; Setta IP QoS
    maxepirey=1800 ;
    defaultexpirey=60
    disallow=all
    allow=alaw
    allow=uLaw
    allow=gsm
    allow=ilbc
    language=it
    rtptimeout=60 ; Termina la chiamata se per 60s non c'e' attivita' RTP
    rtpholdtimeout=300
    ...
    register => bluesip/USER:pASS@bluesip.net/bluesip
    ...

    [bluesip]
    type=friend
    username=bluesip/USER
    fromuser=USER
    secret=PASS
    host=bluesip.net
    context=da-internet
    fromdomain=bluesip.net
    auth=md5,plaintext
    qualify=yes
    canreinvite=no
    nat=no

    extension.conf

    [da-internet]
    exten => s,1,Dial(ZAP/1-1/42,30,rtT)
     
  7. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    You miss:

    [general]
    nat=yes I think this is the main problem!

    defaultexpirey=60 this is too short - please define:

    maxexpirey=3600
    defaultexpirey=600

    allow srv-lookup with:
    srvlookup=yes
     
  8. kandy

    kandy Neuer User

    Registriert seit:
    19 Feb. 2005
    Beiträge:
    61
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    I must have some problem on my configuration since when I put srvlookup=yes I am not able to see the information regarding the registration with sip show register
    I also tried to install the asterisk 1.0.5 but the same thing.
    I need to understand what is wrong with my asterisk.
     
  9. der_Gersthofer

    der_Gersthofer Admin-Team

    Registriert seit:
    17 Apr. 2004
    Beiträge:
    3,585
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    The reason for your problem is: You are trying to connect to the blueSIP server with a private IP (like 192.168.0.x) in contact header. blueSIP rejects those registering messages.
     
  10. sipgateuser

    sipgateuser Mitglied

    Registriert seit:
    17 Juli 2008
    Beiträge:
    564
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich komme mit diesem Problem auch nicht weiter.

    sip.conf
    Code:
    context=default                 ; Default context for incoming calls
    allowoverlap=no                 ; Disable overlap dialing support. (Default is yes)
    bindport=5060                   ; UDP Port to bind to (SIP standard port is 5060)
    bindaddr=0.0.0.0                ; IP address to bind to (0.0.0.0 binds to all)
    srvlookup=yes                   ; Enable DNS SRV lookups on outbound calls
    language=de
    auth=md5,plaintext
    
    externhost=irgendwas.uni.cc        ; Alternatively you can specify an
    nat=yes
     
  11. sipgateuser

    sipgateuser Mitglied

    Registriert seit:
    17 Juli 2008
    Beiträge:
    564
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Nun habe ich es,

    es war schon alles richtig, nur es fehlte in der sip.conf

    localnet=192.168.0.0/255.255.0.0 (oder ähnlich)

    Damit klappt es nun mit bluesip und mit ekiga.