[Gelöst] Bug beim make von trunk Build 7981

Status
Für weitere Antworten geschlossen.

ploieel

Aktives Mitglied
Mitglied seit
13 Mrz 2005
Beiträge
1,772
Punkte für Reaktionen
8
Punkte
38
Hallo,
wollte eben updaten und bekomme folgenden Fehler:

Code:
make[1]: Betrete Verzeichnis '/home/guenter/freetz-trunk/source/kernel/ref-ohio-8mb-04.87/linux-2.6.13.1'
.config:4: *** missing separator.  Schluss.
make[1]: *** [scripts_basic] Fehler 2
make[1]: Verlasse Verzeichnis '/home/guenter/freetz-trunk/source/kernel/ref-ohio-8mb-04.87/linux-2.6.13.1'

ERROR: Build failed.
make: *** [source/kernel/ref-ohio-8mb-04.87/.configured] Fehler 1
[email protected]:~/freetz-trunk$ ^C
Kann man das bitte fixen, oder mache ich was falsch? Hab schon neu ausgecheckt... trotzdem der Fehler.

Viele Grüße.

edit: die code-tags scheinen nicht zu ziehen.
 
Zuletzt bearbeitet:

RalfFriedl

IPPF-Urgestein
Mitglied seit
22 Apr 2007
Beiträge
12,343
Punkte für Reaktionen
1
Punkte
0
Wie sieht denn die Zeile 4 der .config aus?

Die CODE-Tags funktionieren nicht, wenn man eine runde statt einer eckigen Klammer verwendet. Dann ist es nämlich für den Computer kein CODE-Tag.
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
So sieht die Datei im Repository aus:
Code:
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.13.1
# Thu Sep  1 01:43:31 2011
#
CONFIG_MIPS=y
# CONFIG_MIPS64 is not set
# CONFIG_64BIT is not set
CONFIG_MIPS32=y
 

RalfFriedl

IPPF-Urgestein
Mitglied seit
22 Apr 2007
Beiträge
12,343
Punkte für Reaktionen
1
Punkte
0
Das ist nichts schlimmes in Zeile 4 erkennbar.

Zur Klarstellung, mit .config ist hier die source/kernel/ref-ohio-8mb-04.87/linux-2.6.13.1/.config gemeint.
 

ploieel

Aktives Mitglied
Mitglied seit
13 Mrz 2005
Beiträge
1,772
Punkte für Reaktionen
8
Punkte
38
Hm,
ich sehe in dieser .config genau wie dargestellt einige Zeilen, wovon ein paar auskommentiert sind, aber nur zwei Zeilen ziehen:

CONFIG_MIPS=y
CONFIG_MIPS32=y

wo ist Zeile 4?

Bitte, ich kann sehr wenig Linux; ich tät schon selbst was tun, wenn ich es könnte.

btw. ich schreib mal hier einige offene eckige Klammern: [[[[[
und ein paar geschlossene: ]]]]]

Stellt die mein Ubuntu 11.10 32bit richtig dar oder doch nicht?

Viele Grüße.
 

RalfFriedl

IPPF-Urgestein
Mitglied seit
22 Apr 2007
Beiträge
12,343
Punkte für Reaktionen
1
Punkte
0
ich sehe in dieser .config genau wie dargestellt einige Zeilen
Ich sehe in meiner Kristallkugel auch einige Zeilen.
Nach Zeile 3 und vor Zeile 5.
btw. ich schreib mal hier einige offene eckige Klammern: [[[[[
und ein paar geschlossene: ]]]]]
Und zu welchem Zweck? In der Hoffnung, das die Foren-Software diese selbständig an die Stellen bringt, wo sie hingehören?
Das Problem oben war, dass Du "(/CODE]" geschrieben hattest und nicht [NOPARSE]"[/CODE]"[/NOPARSE].
 

ploieel

Aktives Mitglied
Mitglied seit
13 Mrz 2005
Beiträge
1,772
Punkte für Reaktionen
8
Punkte
38
Problem gelöst, saß wohl zwischen Bildschirm und Tastatur. Es war wohl zur Threaderöffnung ein bischen zu spät am Abend.

Habe jetzt auf freetz-devel-8150 updated, und alles ist gut.
Viele Grüße.
 
Status
Für weitere Antworten geschlossen.

Zurzeit aktive Besucher

3CX

Statistik des Forums

Themen
235,914
Beiträge
2,067,827
Mitglieder
356,957
Neuestes Mitglied
IBimsShweit