.titleBar { margin-bottom: 5px!important; }

CAPI auf Mehrprozessorsystem

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von fant, 10 Aug. 2005.

  1. fant

    fant Mitglied

    Registriert seit:
    6 Mai 2005
    Beiträge:
    622
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Hallo Leutinnen und Leute,

    ich habe hier als Server einen Dual PII-450 laufen und möchte mit der eingebauten FritzCard * verwenden. Nun steht aber überall, daß die CAPI-Treiber von AVM nicht mit SMP kompatibel sind. Hat das schon jemand versucht? Oder ist die I4L-Version inzwischen brauchbar (Echo, usw.)?

    Gruß,
    Fant
     
  2. MichaelS

    MichaelS Neuer User

    Registriert seit:
    30 Juni 2005
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hab einen * auf nem Dual P2-400 laufen mit den Capitreibern von AVM, das funktioniert ohne Probleme. Ob er die 2. CPU benutzt hab ich nich nach geguckt.
     
  3. fant

    fant Mitglied

    Registriert seit:
    6 Mai 2005
    Beiträge:
    622
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Sers MichaelS,

    checke mal bitte, ob Du wlrklich beide Prozessoren ansprichst. Welche Linux-Distribution verwendest Du?

    Gruß,
    Fant
     
  4. MichaelS

    MichaelS Neuer User

    Registriert seit:
    30 Juni 2005
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das System kennt und nutzt beide CPUs, ich nur nich ob sich der AVM Treiber was draus macht. Ich wüsste im Moment auch nich wo ich das sehen kann.
     
  5. Memphiz

    Memphiz Neuer User

    Registriert seit:
    5 Aug. 2005
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Kann auch bestätigen, dass es funzt ...

    Kernel 2.6.12 (mit SMP) auf nem Dual PIII 500Mhz mit Asterisk und FRITZCARD Classic unter Verwendung der AVM-Capitreiber.

    Keine Probleme seit monaten.

    ciao

    Memphis
     
  6. fant

    fant Mitglied

    Registriert seit:
    6 Mai 2005
    Beiträge:
    622
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Also mir wird gesagt, das System sei nicht SMP-fähig, wenn ich versuche, die Treiber zu kompilieren. Was für eine Distri habt Ihr? Ich verwende Debian Sarg mit einem selbst kompilierten Kernel. Gebt mir mal bitte einen Tip, wie Ihr das zum Laufen bekommen habt.

    Gruß,
    Fant
     
  7. MichaelS

    MichaelS Neuer User

    Registriert seit:
    30 Juni 2005
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Im moment läuft der * auf einem eisfair mit smp Kernel (2.4.27-1 iirc).
    Mir ist es beim Telefonieren (capi -> hfc und hfc -> capi) jetzt paarmal passiert das der Ton plötzlich weg ist (auf beiden Seiten), nach etwa 10-15s gehts wieder. Der Fehler lässt sich nicht reproduzieren und es tauchen auch keine Fehlermeldungen auf. Das tritt auf seit der * auf dem Dual-System läuft. Vorher auf dem Celeron 667 gab es keine Probleme.
     
  8. armincm

    armincm Aktives Mitglied

    Registriert seit:
    3 Aug. 2005
    Beiträge:
    1,006
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Kannst Du sagen, ob es auch Probleme bei hfc -> hfc oder capi -> capi gibt?

    So koennte man das Problem etwas eingrenzen.

    Armin
     
  9. fant

    fant Mitglied

    Registriert seit:
    6 Mai 2005
    Beiträge:
    622
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    @Memphis:
    Woher hattest Du CAPI-Drivers für die 2.6er-Kernelreihe? Bring mal bitte Beistand und/oder Link.

    Ich verwende hier Debian Sarge, aber ich bekomme nicht mal die Treiber irgendwo. Kann sein, daß ich einfach blind bin. Hiiiiiiiiiiiiiiiiiiiiilfe!!!

    :bahnhof:

    Gruß,
    Fant