.titleBar { margin-bottom: 5px!important; }

Capi dial out

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von d4aha, 20 Dez. 2004.

  1. d4aha

    d4aha Neuer User

    Registriert seit:
    20 Dez. 2004
    Beiträge:
    1
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Halo, ich habe asterisk installiert und mochte ISDN avm Karte benutzen zum dial-out, weil ich noch nicht keine ¨supported hw¨ habe. Aber asterisk core dumped immer mit folgende Fehler:
    -------snip-------------
    *CLI> -- Accepting AUTHENTICATED call from 192.168.2.69, requested format = 2, actual format = 2
    -- Executing ResponseTimeout("IAX2/server2@server2/3", "100") in new stack
    -- Set Response Timeout to 100
    -- Executing Dial("IAX2/server2@server2/3", "CAPI/881375375:375") in new stack
    -- Called 880000375:375
    -- CAPI[contr1/880000375]/0 is ringing
    -- CAPI[contr1/880000375]/0 answered IAX2/server2@server2/3
    Ouch ... error while writing audio data: : Broken pipe
    Warning, flexibel rate not heavily tested!
    Segmentation fault (core dumped)
    -------snip-----------
    fur test zwecke ich habe zwei IAX servers in Office1 und Office2. Channel IAX2 funktioniert gut. Dafür gibt solches log. Aber hier kein Problem ich kann von Office1 SIP1 zu Office2 Sip2 rufen und sprechen. Aber wen ich rufe aussen Nummer mit CAPI mein Telephone ringt. Aber wann ich antworte bekomme ich core dumped.
    Meine System. Asterisk aus CVS, chan_capi-0.3.5 mit patch. Linux mandrake 10.1 mit ALSA und gcc-3.x, kernel-2.6.x Ich benutze original isdn Paket von mandrake isdn4k-utils-3.2p3-16mdk. und habe Ales gemacht vie im ¨Asterisk how to connect with CAPI¨. Vielleicht es ist ALSA Probleme? Für das ich habe modules.conf modifiziert:
    --snip-------
    [modules]
    autoload=yes
    noload => pbx_gtkconsole.so
    noload => pbx_kdeconsole.so
    noload => app_intercom.so
    load => chan_modem.so
    load => res_musiconhold.so
    load => chan_alsa.so
    noload => chan_oss.so
    load => res_features.so
    load => chan_capi.so
    [global]
    chan_modem.so=yes
    chan_capi.so=yes
    ---snip---
    Und ich habe keine Module für hifax ¨lsmod¨? Der konnte Problem mit avm haben. Noch etwas ich habe capi probiert. Irgendwo ein Skript gefunden ¨tonline¨. Ich kann verbinden aber leider nicht komplett weil ich keine Benutzer Name und Passwort habe.
    Vielen dank für Ihre Hilfe.
    Und Entschuldigung für mein Deutsch. Ich lerne noch.