.titleBar { margin-bottom: 5px!important; }

Chanspy

Dieses Thema im Forum "Asterisk Rufnummernplan" wurde erstellt von WoHi, 19 Dez. 2008.

  1. WoHi

    WoHi Neuer User

    Registriert seit:
    1 Nov. 2007
    Beiträge:
    28
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich probiere gerade ChanSpy.
    In meiner extensions.conf habe ich in [default] u.a. folgende Zeilen:
    exten => 111,1,ChanSpy(|b)
    exten => 111,n,Hangup()

    Das klappt für Gespräche von SIP zu SIP innerhalb des Hauses
    wie auch für Gespräche zwischen S0 und SIP innerhalb des Hauses
    wie auch für Gespräche von externem Festnetz zu SIP.

    Was nicht klappt, ist ChanSpy für Gespräche von externem Festnetz zu S0.
    Das wundert mich, weil es eben sowohl Anrufe aus externem Festnetz (mit SIP) als auch für Telefonate mit S0 (mit SIP) funktioniert, aber eben nicht für
    Gespräche zwischen beidem (extFN und S0)

    Meine internen Gespräche zwischen SIP und S0 erzeugen die Meldung
    SIP/3002-005f5cb0 answered CAPI/ISDN1#02/12345678-5.

    Ich habe obige exten-Zeilen mit der ChanSpy-Funktion mal verschoben nach [capi_in1] und ein andermal nach [capi_in3]; dann funktionierte ChanSpy jeweils gar nicht mehr, das war also nicht die Lösung.

    Vorsorglich hier mal meine [capi_in1], wobei 12345678 für meine ISDN-Festnetznummer steht:
    exten => 12345678,1,Dial(SIP/3001&SIP/3002&SIP/3003,20,Ttr)
    exten => 12345678,2,Hangup

    Irgendwie habe ich das Gefühl, als liege die Lösung in der SIP-Nummer, die ich dem S0 bereits zugewiesen habe (die 59). Ich habe mal versucht, in capi_in1 folgendes einzufügen:
    exten => 12345678,1,Dial(SIP/59,20,Ttr)
    wobei wie gesagt 59 die SIP zu 12345678 ist.
    Klingeln tat das Telefon aber offenbar nicht wegen der 59, sondern wegen der 12345678, denn die cli meldete, dass 59 busy sei. So konnte also auch Chanspy nicht auf die 59 anspringen.
     
  2. WoHi

    WoHi Neuer User

    Registriert seit:
    1 Nov. 2007
    Beiträge:
    28
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich würde mich über eine Reaktion auf das Problem freuen, denn ich bin trotz einiger weiterer Stunden Probiererei und Recherche immer noch nicht weiter mit einer Lösung.
    Ich muss noch ergänzen, dass mein Asterisk auf einer Fritzbox läuft. Ich habe den Laien-Eindruck, dass das Problem darin liegen könnte, dass der telefon-daemon der Fritzbox das von extern beim S0 ankommende Telefonat ohne asterisk verarbeitet. Bei einem anderen Problem habe ich im ippf mal gelesen, es sei dadurch gelöst worden, dass der daemon "vor die Wand gefahren" wird (meine Nachfrage dort,wie das gemacht wurde, wurde allerdings ebenfalls nicht beantwortet).
    Aber eigentlich müsste es doch irgendwie auch ohne "vor die Wand fahren gehen", denn Asterisk greift doch auch sonst auf von der fritzbox verarbeitete Telefonate zu.
    Ich habe es mal mit chanspy(CAPI/ISDN1) versucht, aber ebenfalls vergeblich.
     
  3. WoHi

    WoHi Neuer User

    Registriert seit:
    1 Nov. 2007
    Beiträge:
    28
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
  4. WoHi

    WoHi Neuer User

    Registriert seit:
    1 Nov. 2007
    Beiträge:
    28
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bislang klappte es nur mit den eingehenden Telefonaten, weil die über Asterisk abgewickelt wurden. Nicht klappte es mit den vom ISDN-Telefon über die Fritzbox rausgehenden Telefonate, auf die Asterisk an der cli überhaupt nicht reagierten. Das klappt jetzt auch, nachdem in Fritzbox als Wahlregel eingestellt ist, dass ausgehende Telefonate über eine interne (!) Internetrufnummer laufen sollen.