.titleBar { margin-bottom: 5px!important; }

codec einstellungen?

Dieses Thema im Forum "Asterisk ISDN Allgemein" wurde erstellt von copymaster1000, 26 Nov. 2008.

  1. copymaster1000

    copymaster1000 Neuer User

    Registriert seit:
    12 Nov. 2008
    Beiträge:
    16
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo mal wieder ;)

    So eine TEstinstallation ist erledigt. ASTERISK an internem S0 von TK-Anlage.

    Nun habe ich je zwei Softphones konfiguriert. also zweimal SIP und zweimal AIX.

    Nun ist es aber leider so, dass die Sprachqualität bei beiden nicht ganz optimal ist.

    Eingestellt ist alaw für SIP und IAX.

    Wenn ich aber nun von einem IAX oder SIP Softphone ein telefon anrufe, hört sich das ganze ziemlich "dumpf" an und s-Laute sind eher ein zischen.


    Habe ich optimierungsmöglichkeiten, wenn ja, wo muss ich ansetzen?

    Asterisk 1.6 , als Softphone (SIP) Ekiga, und (IAX) Voixphone

    Die Verbindung zur TK Anlage macht eine AVM B1


    An den Softphones ist als Audiocodec alaw eingestellt. Das soll ja, wenn ich es richtig verstanden habe, ISDN Qualität bieten und Standard für Europa sein.


    Ich poste sonst gerne mal meine aktuelle sip.conf, IAX.conf und capi.conf
     
  2. doxon

    doxon Mitglied

    Registriert seit:
    11 Juni 2006
    Beiträge:
    781
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    IT-Systemelektroniker
    Ort:
    Aurich
    Ja, alaw ist ISDN-Standard in Eropa, daher sollte die Qualität dementsprechend gut sein.


    Mit
    Code:
    show channel CHANNELNAME
    kannst du dir den akteull verwendeten Codec der Verbindung angucken.

    Code:
       NativeFormat: 8
        WriteFormat: 8
         ReadFormat: 8
    
    In diesem Fall 8=alaw.
    http://www.voip-info.org/wiki/view/Asterisk+codecs

    Configs währen nicht schlecht.

    EDIT:
    Die gewählten Codecs der SIP/IAX-Peers stehen dort:
    Code:
    sip show peer PEERNAME
    iax2 show peer PEERNAME
     
  3. copymaster1000

    copymaster1000 Neuer User

    Registriert seit:
    12 Nov. 2008
    Beiträge:
    16
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ok..

    sip.conf:
    Code:
    [general]
    port = 5060
    bindaddr = 0.0.0.0
    context = sonstige
    language=de
    canreinvite=yes
    
    [2000]
    type=friend
    context=meine-telefone
    secret=1234
    host=dynamic
    allow=alaw
    callerid=822
    
    
    [2001]
    type=friend
    context=meine-telefone
    secret=1234
    host=dynamic
    allow=alaw
    callerid=821
    
    iax.conf
    Code:
    
    [global]
    bandwith=high
    autokill=3500
    bindport=4569           ;IAX2!
    bindaddr=0.0.0.0
    language=de
    mailboxdetail=yes
    tos=ef
    
    
    [2002]
    type=friend
    username=2002
    secret=1234
    host=dynamic
    callerid="EDV"
    permit=0.0.0.0/0.0.0.0
    context=meine-telefone
    qualify=yes
    disallow=all
    allow=alaw
    language=de
    
    capi.conf
    Code:
    [general]
    nationalprefix=+49        ; or for example "+49"
    internationalprefix=00  ; or for example "+"
    rxgain=0.6       ;linear receive gain (1.0 = no change)
    txgain=0.6       ;linear transmit gain (1.0 = no change)
    language=de      ;set default language
    ;ulaw=yes         ;set this, if you live in u-law world instead of a-law
    ;jb.....         ;with Asterisk 1.4 you can configure jitterbuffer,
                     ;see Asterisk documentation for all jb* setting available.
    mohinterpret=default ;Asterisk 1.4: default music on hold class when placed on $
    
    [ISDN1]
    isdnmode=did 
    incomingmsn=* 
    defaultcid=*
    controller=1 
    group=1 
    softdtmf=on 
    relaxdtmf=on
    faxdetect=off
    faxdetecttime=0 
    context=capi-in
    immediate=yes 
    bridge=no
    devices=2
    
    wenn ich eine verbindung aufbaue, sieht das so aus:
    Code:
    erbosity is at least 6
        -- Remote UNIX connection
        -- Accepting AUTHENTICATED call from 192.168.0.5:
           > requested format = alaw,
           > requested prefs = (),
           > actual format = alaw,
           > host prefs = (gsm|alaw),
           > priority = mine
        -- Executing [962@meine-telefone:1] Dial("IAX2/2002-12413", "CAPI/ISDN1/62,30,r") in new stack
        -- Called ISDN1/62
        -- CAPI/ISDN1#02/62-13 is proceeding passing it to IAX2/2002-12413
        -- CAPI/ISDN1#02/62-13 is making progress passing it to IAX2/2002-12413
        -- CAPI/ISDN1#02/62-13 is ringing
        -- CAPI/ISDN1#02/62-13 answered IAX2/2002-12413
    
    Edit Guard-X: Code-Tags eingefügt!
     
  4. doxon

    doxon Mitglied

    Registriert seit:
    11 Juni 2006
    Beiträge:
    781
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    IT-Systemelektroniker
    Ort:
    Aurich
    Poste mal die Ausgaben von
    Code:
    sip show peer PEERNAME
    iax2 show peer PEERNAME
    
    von jeweis beiden Peers.

    Und dann noch von einem Gespräch:
    Code:
    show channel CHANNELNAME
    Und füge mal vor dem allow=alaw eine Zeile drüber, überall ein disallow=all ein. (So wie bei der 2002)

    Und bitte verwende für deine Configs die CODE-Tags. Kannst du ja noch editieren.
     
  5. copymaster1000

    copymaster1000 Neuer User

    Registriert seit:
    12 Nov. 2008
    Beiträge:
    16
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    iax2 show peer 2002

    * Name : 2002
    Secret : <Set>
    Context : meine-telefone
    Mailbox :
    Dynamic : Yes
    Callerid : "EDV" <>
    Expire : 2169
    ACL : Yes
    Addr->IP : 192.168.0.5 Port 41782
    Defaddr->IP : 0.0.0.0 Port 4569
    Username : 2002
    Codecs : 0x600a (gsm|alaw)
    Codec Order : (gsm|alaw)
    Status : OK (5 ms)
    Qualify : every 60000ms when OK, every 10000ms when UNREACHABLE (sample smoothing Off)


    iax2 show channels
    Channel Peer Username ID (Lo/Rem) Seq (Tx/Rx) Lag Jitter JitBuf Format
    IAX2/2002-11059 192.168.0.5 2002 11059/01638 00021/00016 00086ms -0001ms 0000ms alaw
     
  6. doxon

    doxon Mitglied

    Registriert seit:
    11 Juni 2006
    Beiträge:
    781
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    IT-Systemelektroniker
    Ort:
    Aurich
    #6 doxon, 26 Nov. 2008
    Zuletzt bearbeitet: 26 Nov. 2008
    Merkwürdig, anscheinend wird alaw verwendet.
    Komisch finde ich es nur das beim peer gsm und alaw steht.

    Sehen die anderen peers genauso aus?

    Und zu gsm passt auch der dumfpe ton und das Zischen...

    Mehr fällt mir im moment auch nicht ein...

    EDIT: Eine Vermutung noch... Hast du die Einstellungen evtl mal verändert aber vergessen einen "reload" zu machen?
     
  7. copymaster1000

    copymaster1000 Neuer User

    Registriert seit:
    12 Nov. 2008
    Beiträge:
    16
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ja. reload und neustart. nun hab ich es aber auch soweit, dass er nur noch alaw anzeigt. es ist aber immernoch dumpf und zischt.

    kann es an der avm b1 liegen?
     
  8. doxon

    doxon Mitglied

    Registriert seit:
    11 Juni 2006
    Beiträge:
    781
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    IT-Systemelektroniker
    Ort:
    Aurich
    Keine Ahnung, da hab ich keine Erfahrungen mit.
    Habe auch sonst keine weiteren Idden woran das liegen könnte.

    Vielleicht kann dir da ein anderer helfen.