connected line has changed. Saving it until answer for PJSIP/telekom_in_264*********

neitmedia

Neuer User
Mitglied seit
29 Okt 2019
Beiträge
10
Punkte für Reaktionen
1
Punkte
3
Hallo zusammen,

ich habe leider ein kleines Problem mit meiner Asterisk Konfiguration.

Folgende Grundsituation: Einige Telekom-Rufnummern sind in Asterisk 13.14.1 konfiguriert. Eingehende und ausgehende Anrufe funktionieren soweit. Leider kommt es in letzter Zeit vermehrt zu Meldungen der Art

PJSIP/************-0000006e connected line has changed. Saving it until answer for PJSIP/telekom_in_************-00000069

mit dem Resultat, dass der entsprechende Endpoint nicht klingelt, bzw. dort kein Anruf eingeht, obwohl der Endpoint ordnungsgemäß registriert ist.

Verbindet man den Endpoint neu, funktioniert es erstaunlicherweise erstmal wieder für eine Zeit. Bei den betroffenen Endpoints handelt es sich um PhonerLite Clients.

Hier meine Konfiguration (beispielhaft für eine konfigurierte Nummer):

[pjsip.conf]

[telekom_xxxxxxxxxx]
type=registration
transport=transport-udp
outbound_auth=telekom_xxxxxxx_auth
server_uri=sip:tel.t-online.de
client_uri=sip:[email protected]-online.de
contact_user=xxxxxxxxxxxxx
retry_interval=60
forbidden_retry_interval=300
expiration=480
auth_rejection_permanent=false
line=yes
endpoint=telekom_in_xxxxxxxxxxxxxxx

[telekom_xxxxxxxxxxxxxxxxx_auth]
type=auth
auth_type=userpass
password=xxxxxxxxxxx
username=xxxxxxxxxxxxxxx
realm=tel.t-online.de

[telekom_out_xxxxxxxxxxx]
type=endpoint
transport=transport-udp
context=unspecified
disallow=all
allow=g722
allow=alaw
outbound_auth=telekom_xxxxxxxxxxx_auth
aors=telekom_out_xxxxxxxxxxxx
callerid=xxxxxxxxxxxxxx
from_user=xxxxxxxxxxxx
from_domain=tel.t-online.de
timers=no
rtp_symmetric=yes

[telekom_out_xxxxxxxxxxxxx]
type=aor
contact=sip:[email protected]-online.de
; neu hinzugefügt
qualify_frequency=60

[telekom_in_xxxxxxxxxxxxxxxx]
type=endpoint
transport=transport-udp
context=telekom-in-xxxxxxxxxxxxxxxxxxx
disallow=all
allow=g722
allow=alaw
outbound_auth=telekom_xxxxxxxxxxxxxx_auth

[telekom_in_xxxxxxxxxxxx]
type=identify
endpoint=telekom_in_xxxxxxxxxxxxx
match=217.0.0.0/13

[extensions.conf] - relevanter Teil für incoming calls

[general]
static=yes
writeprotect=yes
autofallthrough=yes
extenpatternmatchnew=no
clearglobalvars=no
userscontext=unspecified

[telekom-in-xxxxxxxxxxxxxxx]
exten => xxxxxxxxxxx,1,Noop(Processing an incoming call via xxxxxxxxxxxxxxx)
same => n,Dial(PJSIP/xxx&PJSIP/xxx&PJSIP/xxxxxx&PJSIP/xxxx&PJSIP/xxxx&PJSIP/xxx&PJSIP/xxx&PJSIP/xxx&PJSIP/xxx&PJSIP/xxx)
same => n,Hangup()

Ich hoffe, es hat jemand zumindest einen Tipp für mich, was die Meldung bedeutet - vielleicht weiß ja auch jemand, wie ich das Problem beheben kann.

Viele Grüße,
Nico Entz
 

gehtdoch

Neuer User
Mitglied seit
3 Feb 2019
Beiträge
172
Punkte für Reaktionen
12
Punkte
18
Ein Blick in den Sourcecode verrät, dass der Fehler im Zusammenhang einer RingGroup bei der Einstellung RingAll auftaucht.

Ich habe nicht den Eindruck, dass das RingGroup-Feature in Deinem konkreten Fall so aufgebaut ist, dass es nachhaltig funktionieren kann. Für solche, eigentlich 0815-Standardfeatures, gibt es FreePBX. Ist dort einwandfrei gelöst (nutze es selbst - auch mit der Telekom - sowohl mit internen als auch mit externen Nummern - geht beides) - allerdings deutlich komplexer implementiert. Macht keinen Sinn, Dinge nochmal zu erfinden (und zu debuggen), wenn sie schon einer gelöst hat, so dass sie nachhaltig funktionieren.