.titleBar { margin-bottom: 5px!important; }

[Problem] cron nach reboot gestoppt: 7270_v2_05.05freetz-devel.de_20111230-103220

Dieses Thema im Forum "Freetz" wurde erstellt von rolsch, 9 Jan. 2012.

  1. rolsch

    rolsch Neuer User

    Registriert seit:
    28 Okt. 2004
    Beiträge:
    177
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 rolsch, 9 Jan. 2012
    Zuletzt bearbeitet: 9 Jan. 2012
    Hallo zusammen,
    ich reboote die Box per cron.

    crontab: 30 03 * * 1-5 /sbin/reboot

    Nach dem restart der Box wird cron nicht mehr gestartet,
    obwohl unter Freetz-Einstellungen cron auf "automatisch" steht.

    Hinweis:
    Die Box ist nicht als Router eingesetzt sondern hängt hinter einem Router als Telefonanlage (Internetzugang über LAN 1).
    Daher dauert es immer einige Zeit, bis z.B. die aktuelle Uhrzeit in der Box zu Verfügung steht.

    Wer kann hier Tipps geben?
     
  2. sf3978

    sf3978 IPPF-Promi

    Registriert seit:
    2 Dez. 2007
    Beiträge:
    7,657
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    Evtl. mal mit htpdate aus dem trunk probieren:
    Code:
    htpdate -D -4 -l -p 300 -s -t -m 2048 -M 10240 82.212.63.139 141.113.97.32 217.150.151.99 129.69.8.151 141.62.1.52
    
     
  3. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Was steht denn in modlog zum crond?

    Gruß
    Oliver
     
  4. rolsch

    rolsch Neuer User

    Registriert seit:
    28 Okt. 2004
    Beiträge:
    177
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Oliver,
    meinst du mit modlog das Syslogd Protokoll?
    - dieses habe ich durchforstet, jedoch keinen Eintrag bezüglich crond gefunden.

    Komisch ist, dass cond ja über das Webinterface gestartet wird und einmalig seinen Job ausführt (s.o.).
    Nach dem Reboot ist dann aber crond nicht mehr aktiv, obwohl "automatisch" gesetzt ist.
     
  5. sf3978

    sf3978 IPPF-Promi

    Registriert seit:
    2 Dez. 2007
    Beiträge:
    7,657
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    Auf deiner Box gibt es evtl. eine "mod.log"-Datei:
    Code:
    root@fritz:/var/mod/root# [COLOR=red]find / -iname 'mod.log'[/COLOR]
    /var/log/mod.log
    
    Eintrag in der mod.log als Beispiel:
    Code:
    root@fritz:/var/mod/root# [COLOR=red]cat /var/log/mod.log[/COLOR]
    rc.mod version freetz-devel-7293_7561M
    [COLOR=red]crond is disabled.[/COLOR]
    Starting AVM telnetd ... done.
    webcfg is updating inetd ... active.
    swap is enabled.
    Starting syslogd ... done.
    Starting inetd ... done.
    Setting up virtual network interface ... done.
    Setting up SSH authorized_keys for root ... done.
    dnsmasq is disabled.
    Usage: /etc/init.d/rc.noip [start|start_nodaemon|stop|restart|status]
    opendd is disabled
    openssh SSH server is disabled.
    privoxy is disabled.
    vsftpd is updating inetd ... active.
    Starting rc.custom ... done.
    
    
     
  6. rolsch

    rolsch Neuer User

    Registriert seit:
    28 Okt. 2004
    Beiträge:
    177
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    So,
    mod.log gefunden ;)

    Oben steht zwar, dass cron gestartet ist aber im WebIF wird der Status als stopped angezeigt.

    Wenn ich dann crond übers WebIF starte:
     
  7. RalfFriedl

    RalfFriedl IPPF-Urgestein

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    12,343
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Du kannst mal am Anfang von /etc/init.d/rc.cron (Zeile 2) "set -x" einbauen, dann sieht man die Shell-Befehle, die ausgeführt werden. Wenn das nicht reicht, kannst Du cron mit strace aufrufen.

    Verwendest Du etwas spezielles im Zusammenhang mit cron? External, andere Verzeichnisse/Benutzer?