[Gelöst] curl / libcurl mit Samba-Unterstützung

WileC

Mitglied
Mitglied seit
28 Nov 2007
Beiträge
321
Punkte für Reaktionen
6
Punkte
18
Hallo,

um in Freetz "curl" mit Samba-Unterstützung nutzen zu können, müsste man das SMB-Protokoll aktivieren. Standardmäßig kann curl ja recht viel.

Allerdings scheint in der libcurl in freetz diverse Optionen abgeschaltet zu sein.

make/curl/curl.mk
Code:
$(PKG)_CONFIGURE_OPTIONS += --enable-cookies
$(PKG)_CONFIGURE_OPTIONS += --enable-crypto-auth
$(PKG)_CONFIGURE_OPTIONS += --enable-file
$(PKG)_CONFIGURE_OPTIONS += --enable-ftp
$(PKG)_CONFIGURE_OPTIONS += --enable-http
$(PKG)_CONFIGURE_OPTIONS += --enable-proxy
$(PKG)_CONFIGURE_OPTIONS += --enable-rtsp
$(PKG)_CONFIGURE_OPTIONS += --enable-unix-sockets

$(PKG)_CONFIGURE_OPTIONS += --disable-dict
$(PKG)_CONFIGURE_OPTIONS += --disable-gopher
$(PKG)_CONFIGURE_OPTIONS += --disable-imap
$(PKG)_CONFIGURE_OPTIONS += --disable-ldap
$(PKG)_CONFIGURE_OPTIONS += --disable-ldaps
$(PKG)_CONFIGURE_OPTIONS += --disable-pop3
$(PKG)_CONFIGURE_OPTIONS += --disable-smb
$(PKG)_CONFIGURE_OPTIONS += --disable-smtp
$(PKG)_CONFIGURE_OPTIONS += --disable-sspi
$(PKG)_CONFIGURE_OPTIONS += --disable-telnet
$(PKG)_CONFIGURE_OPTIONS += --disable-tftp
$(PKG)_CONFIGURE_OPTIONS += --disable-tls-srp
Reicht es dann einfach aus, dass --disable-smb durch --enable-smb zu ersetzen? Oder habe ich mal wieder die hälfte nicht beachtet?
 

f666

Mitglied
Mitglied seit
6 Apr 2016
Beiträge
304
Punkte für Reaktionen
40
Punkte
28
Ich weiß aus dem Stehgreif nicht, ob die libsmb existiert bzw. gebaut werden kann.
Einfach ausprobieren...
 

WileC

Mitglied
Mitglied seit
28 Nov 2007
Beiträge
321
Punkte für Reaktionen
6
Punkte
18
Braucht man die libsmb dazu?! Ich dachte, das kann dann die libcurl mit dem —enable-smb?
 

f666

Mitglied
Mitglied seit
6 Apr 2016
Beiträge
304
Punkte für Reaktionen
40
Punkte
28
OK, gut, kann auch sein, dass es ohne geht. Wie gesagt, einfach ausprobieren.
 

WileC

Mitglied
Mitglied seit
28 Nov 2007
Beiträge
321
Punkte für Reaktionen
6
Punkte
18
also mit dem --enable-smb funtionierts, allerdings wird lediglich SMBv1 unterstützt... das nutze ich leider gar nicht mehr ://