Debian + USB FritzCard v2.1 möglich???

2fast_driver

Neuer User
Mitglied seit
8 Aug 2008
Beiträge
62
Punkte für Reaktionen
0
Punkte
0
Hallo,

ich bin am verschweifen , seit mehrere Tagen versuche ich USB FritzCard unter Linux Debian zum laufen zu bringen. bis jetzt kein erfolgt.

ich habe CAPI Treiber von AVM versucht zu kompilieren kommt immer Fehler:

Code:
debian:/usr/src/fritz# make
make -C src
make[1]: Entering directory `/usr/src/fritz/src'
make -C /lib/modules/2.6.18-4-686/build SUBDIRS=/usr/src/fritz/src modules
make[2]: Entering directory `/usr/src/linux-headers-2.6.18-4-686'
  CC [M]  /usr/src/fritz/src/main.o
In file included from /usr/src/fritz/src/main.c:33:
/usr/src/fritz/src/tools.h:74: error: expected identifier or ‘(’ before ‘typeof’
/usr/src/fritz/src/tools.h:74: error: expected ‘)’ before ‘__xchg’
/usr/src/fritz/src/main.c:85: error: unknown field ‘owner’ specified in initializer
/usr/src/fritz/src/main.c:85: warning: initialization from incompatible pointer type
make[3]: *** [/usr/src/fritz/src/main.o] Fehler 1
make[2]: *** [_module_/usr/src/fritz/src] Fehler 2
make[2]: Leaving directory `/usr/src/linux-headers-2.6.18-4-686'
make[1]: *** [fcusb2.o] Fehler 2
make[1]: Leaving directory `/usr/src/fritz/src'
make: *** [src/fcusb2.ko] Fehler 2

hier ist mein Linux version:

Code:
debian:/usr/src/fritz# cat /proc/version
Linux version 2.6.18-4-686 (Debian 2.6.18.dfsg.1-12etch2) ([email protected]) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1 SMP Wed May 9 23:03:12 UTC 2007
hat jemand eine Installation Anleitung parat?
oder kann mir jemand helfen?
mit mISDN hat es auch nicht geklappt.


PS. ich habe gegoogelt nicht oder zu alte Beiträge gefunden, deswegen biete ich um Hilfe.

Vielen Dank

MfG


2fast_driver
 

3CX PBX - GRATIS
Linux / Win / Cloud

Neueste Beiträge

Statistik des Forums

Themen
232,919
Beiträge
2,028,145
Mitglieder
351,076
Neuestes Mitglied
Zeitgeist4