.titleBar { margin-bottom: 5px!important; }

DRINGEND!!! Exotische Browser gesucht!

Dieses Thema im Forum "PURtel" wurde erstellt von PURtel.com, 2 Juni 2004.

  1. PURtel.com

    PURtel.com Aktives Mitglied

    Registriert seit:
    1 Mai 2004
    Beiträge:
    1,420
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Gemeinde,

    wir hatten mal im internen Bereich Probs mir exotischen Browsern.
    Jetzt haben wir ein neues Sessionmanagement und die Einloggprobleme sollten dadurch behoben sein. Kann das jemand so bestätigen?

    Vielen Dank und beste Grüße

    Volker Goudschmidt
     
  2. zeeschplitz

    zeeschplitz Neuer User

    Registriert seit:
    2 Mai 2004
    Beiträge:
    179
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Falls Du Mozilla und Konqueror als exotisch bezeichnen möchtest: Meine letzte Fehlerbeschreibung lässt sich noch immer genauso nachvollziehen. Nach dem Einloggen kommt immer nur die Kontoübersicht, anstelle eines Bildwechsels dann wieder die Aufforderung zum Einloggen.

    (Mit diesem komischen IE gehts aber)

    mfg 500259
     
  3. Clemens

    Clemens Aktives Mitglied

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    1,496
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Hallo Volker,

    ich habe mich mit folgenden Browsern erfolgreich auf eurer Seite einloggen können:

    Firefox 0.8 (Mozilla/5.0 Windows)
    Firefox 0.8 (Linux)
    Konqueror 3.2.2 (Linux)
    Opera 6.0 (Qt/Embedded 2.3.2 / ARM)

    Ich habe aber immer diesen Link ohne Flash genommen: http://purtel.com/index.php?noflash=1&slnr=&wid=

    Mit Flash, also hier: http://purtel.com/ konnte ich mich mit keinem Browser einloggen - wobei ich die Flash-Animation sehen kann (ausser auf dem PDA).


    Dass es mit dem Embedded Opera auf dem Zaurus Linux PDA funktioniert ist sozusagen der Härtetest :)

    Weiter so, viele Grüße ... Clemens
     
  4. PURtel.com

    PURtel.com Aktives Mitglied

    Registriert seit:
    1 Mai 2004
    Beiträge:
    1,420
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    F*** nochmal... - das liegt daran, dass der Browser die Variable "session" im Cookie nicht verarbeitet. Darum habe ich die Variable "session" jetzt auch noch einmal mit in die URL übergeben.

    Leider mache ich das nicht generell, - dass heißt, wer mit einem (seltenen Browserderivat ;-) ) über http://PURtel.com reinkommt wird diese Schwierigkeiten auch weiterhin haben. Sobald du aber über http://www.PURtel.com reingehst sollte das auch dann gehen, weil dort die Session in der URL angehangen wird.

    Den gleichen Effekt solltest Du auch dadurch erzielen können, wenn Du einmal auf "ohne Flash", und ein weiteres Mal auf "mit Flash" klickst, denn auch dann wird die Variable "session" an die URL angehangen.

    Warum 1x so und 1x so?

    Ganz klar: Wenn jemand "nackig", also ohne eine angehangene Webmaster-ID reinkommt, dann bleibt der URL-String ganz sauber, - ohne jeglichen angehangenen Parameter. Grund ist unser "Freund Google", der diese Anhänge nicht unbedingt mag.

    Bitte probier das mal aus, - wenn das nicht geht, bastle ich etwas anderes.
     
  5. Blackvel

    Blackvel Mitglied

    Registriert seit:
    4 Mai 2004
    Beiträge:
    624
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    selbständig als IT-Consultant (VoIP, Asterisk, J2E
    Ort:
    Nürnberg, Einsatzorte Schwerpunkt D6-D9 (MCH, STG,
    Also zu Mozilla.
    Ich bin wie schon geschrieben mit www.purtel.com rein, habe auch NOFlash geklickt und alles klappt im User-Bereich mit den Menüs nach dem einloggen.

    Habe Mozilla 1.7b und der Server erkennt jetzt, dass ich schon eingeloggt bin.

    100% funktioniert's :) Und das sogar unter Linux! Echt geil endlich :)
     
  6. zeeschplitz

    zeeschplitz Neuer User

    Registriert seit:
    2 Mai 2004
    Beiträge:
    179
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Habe nochmal probiert und Clemens scheint auf der richtigen Spur zu sein. Die Sache hängt nicht vom www ab, sondern ob die Version mit oder ohne Flash aufgerufen wird.

    Wenn ich in der Navigation "ohne Flash" anklicke gehen beide Browser einwandfrei. Zumindest bei Mozilla bin ich mir sicher daß aller Cockies, Java, Realplayer und Flash Gefummel aktiv ist. Das Plugin meldet sich mit Shockwave Flash 5.0 r47

    Ohne Flash gehts ja aber allemal, blos daraufkommen tut nicht jeder
     
  7. Ber5erker

    Ber5erker Mitglied

    Registriert seit:
    6 Apr. 2004
    Beiträge:
    305
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Kann ich bestätigen: Konqueror (KDE 3.2.2) funzt, wenn ich mich "ohne Flash" einlogge.
    Ist die Flash-Version aktiv fliege ich immer wieder raus bzw. komme in keinen der Menüpunkte...
     
  8. PURtel.com

    PURtel.com Aktives Mitglied

    Registriert seit:
    1 Mai 2004
    Beiträge:
    1,420
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habt ihr möglicherweise eine Art Übersicht unter welchem Namen (User-Agent) sich eure Browser (der genaue String) am Server anmelden? Dann könnte ich das mal auffangen und gleich die Session setzen. Dann geht das bei jedem auch sofort und Google und Konsorten gehen weiterhin leer aus... ;)
     
  9. Ber5erker

    Ber5erker Mitglied

    Registriert seit:
    6 Apr. 2004
    Beiträge:
    305
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)
     
  10. Clemens

    Clemens Aktives Mitglied

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    1,496
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Hallo Volker,

    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
    Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
    Mozilla/5.0 (compatible; Konqueror/3.2; Linux 2.4.26; X11; i686; de) (KHTML, like Gecko)
    Mozilla/4.0 (compatible; MSIE 5.0; UNIX; 240x320) Opera 6.0 [en]

    Den User Agent man hier sehr schön testen.

    Ich finde es nicht schlimm wenn man sich ohne Flash einloggt - vielleicht bringts ein kleiner Hinweis für Leute die es nicht wissen.

    Viele Grüße, Clemens