.titleBar { margin-bottom: 5px!important; }

dropbear auf 7141 "access denied"

Dieses Thema im Forum "FRITZ!Box Fon: Modifikationen" wurde erstellt von Leo4455, 21 Dez. 2008.

  1. Leo4455

    Leo4455 Neuer User

    Registriert seit:
    7 Feb. 2008
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Moin Moin,

    Ich habe ein folgeschweres Problem mit meiner FB 7141 (Firmware 40.04.59)
    Habe die debug.cfg wie folge angepasst und kann nun auch per ssh drauf kommen.

    [Edit frank_m24: Bitte benutzt CODE Tags für lange Ausgaben.]
    Code:
    /usr/sbin/telnetd -l /sbin/ar7login
    
    sleep 20
    
    cd /var
    #
    # download der Software
    #
    
    /usr/bin/wget [url]http://www.spblinux.de/fbox.new/cfg_dropbear[/url]
    
    sleep 5
    chmod 755 /var/cfg_dropbear
    #
    # config und Start (modus: onlykey -> kein password authentication, nur public key)
    #
    /var/cfg_dropbear install
    /var/cfg_dropbear start
    
    /bin/dropbearkey -t rsa -f /var/tmp/dropbear_rsa_hostkey -s 512
    #
    # diese Zeilen sind als Alternative zu public key  authentication zu sehen
    # Falls gewünscht muß oben auch "onlykey" entfernt werden!
    #
    
    cp -p /var/tmp/shadow /var/tmp/tmp_shadow
    sed -e "/root:/s#^root:[^:]*:#root:PBvr5tOlt/rao:#" /var/tmp/tmp_shadow > /var/tmp/shadow
    
    /bin/dropbear -r /var/tmp/dropbear_rsa_hostkey -p 443 -p 22 -a -s
    
    cd /var/tmp
    # # # # # # # # # Installation Etherwake
    #
    # Etherwake ist bereits auf der Box installiert!
    # Damit kann man andere Maschinen per Netzwerk booten 
    # (nur MAC Adresse nötig; password als Parameter möglich)
    #
    # Hier das Interface der Fritzbox und die MAC-Adresse des PCs eintragen
    echo "/usr/bin/ether-wake -i eth0 00:XX:XX:XX:XX:XX" > /var/tmp/start_vdr_test1
    chmod  x /var/tmp/start_vdr_test1
    
    
    # add fritz box itself in resolv.conf to resolv dhcp attached machines in your network
    echo "nameserver 192.168.178.1" >> /var/tmp/resolv.conf
    
    # create valid authorized_keys file
    # hier muß der public key (openssh-keygen generiert) eingetragen werden,
    # der ohne auf die Fritz Box per ssh zugreifen können soll:
    #ssh [email]root@fritz.box[/email]
    #
    #
    cat > /var/tmp/dropbear/authorized_keys <<END_OF_FILE
    ssh-rsa 
    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    xxxx  hans@host1
    END_OF_FILE
    
    
    Leider bekomme ich nun immer access deneid ... obwohl doch das /var/tmp/shadow geschrieben (verändert) wurde.
    Das Passwort habe ich auf "http://vsrv.de/cgi-bin/htpasswd.cgi" generieren lassen ....

    Denke das es evtl. ein einfaches problem ist, da ich "Anfänger" bin ...
    Beim suchen habe ich hier jedoch nichts gefunden, da her frage ich mal vorsichtig an.

    Wen darf ich : :groesste: nennen?

    Danke schon mal
     
  2. Leo4455

    Leo4455 Neuer User

    Registriert seit:
    7 Feb. 2008
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hey zusammen,

    hat wirklich niemenad eine Anhnung?
    Hat zufällig jemand auch die 7141 und es genauso gemacht --> und es funktioniert?
    Wenn ja, würde ich mich auch über diese Info freuen :rolleyes:.

    LG,